質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.45%
terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

zsh

zshは、UNIX系OSのシェルの1つです。 cshやksn系のコマンドライン編集機能も実装されたシェルです。

Q&A

解決済

2回答

2692閲覧

[Mac]terminalをzshで起動するとエラーが表示されてしまう

fopi

総合スコア1

terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

zsh

zshは、UNIX系OSのシェルの1つです。 cshやksn系のコマンドライン編集機能も実装されたシェルです。

0グッド

0クリップ

投稿2022/06/29 03:45

編集2022/06/29 09:36

terminalを起動すると以下のメッセージが最初に表示されます。

ERROR: this script is obsolete, please see git-completion.zsh

brew経由でインストールしたりしましたが、このエラーだけ消えません。
なにか原因が分かれば教えて下さい。

設定ファイルは以下のとおりです。

# path php@8.0 export PATH=$PATH:/usr/local/opt/php@8.0/bin:/usr/local/opt/php@8.0/sbin # Path to your oh-my-zsh installation. export ZSH=/Users/noog/.oh-my-zsh ZSH_THEME="robbyrussell" plugins=(git) # User configuration export PATH="/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Users/noog/.rvm/bin" source $ZSH/oh-my-zsh.sh alias emacs="$(brew --prefix emacs)/bin/emacs" eval "$(rbenv init -)" export PATH=/usr/local/opt/php@7.3/bin:$PATH export PATH=/usr/local/opt/php@8.0/bin:$PATH export PATH="/opt/homebrew/opt/php@8.0/bin:$PATH" export PATH="/opt/homebrew/opt/php@8.0/sbin:$PATH" export PATH="/usr/local/opt/php@/bin:$PATH" export PATH="/usr/local/opt/php/bin:$PATH" export PATH="/usr/local/opt/php@8.0/bin:$PATH" GIT_PS1_SHOWDIRTYSTATE=true # default:cyan / root:red if [ $UID -eq 0 ]; then PS1='\[\033[31m\]\h\[\033[00m\]:\[\033[01m\]\w\[\033[31m\]$(__git_ps1)\[\033[00m\]\\$ ' else PS1='\[\033[36m\]\h\[\033[00m\]:\[\033[01m\]\w\[\033[31m\]$(__git_ps1)\[\033[00m\]\\$ ' fi export PATH="$PATH:$HOME/.rvm/bin" # Add RVM to PATH for scripting export PATH=$PATH:/Users/xxxxx/.nodebrew/current/bin # git-promptの読み込み source ~/.zsh/git-prompt.sh # git-completionの読み込み fpath=(~/.zsh $fpath) zstyle ':completion:*:*:git:*' script ~/.zsh/git-completion.bash autoload -Uz compinit && compinit # プロンプトのオプション表示設定 GIT_PS1_SHOWDIRTYSTATE=true GIT_PS1_SHOWUNTRACKEDFILES=true GIT_PS1_SHOWSTASHSTATE=true GIT_PS1_SHOWUPSTREAM=auto # プロンプトの表示設定(好きなようにカスタマイズ可) setopt PROMPT_SUBST ; PS1='%F{green}%n@%m%f: %F{cyan}%~%f %F{red}$(__git_ps1 "(%s)")%f \$ ' fpath=( ${HOME}/.zsh/completions ${fpath} ) autoload -Uz compinit compinit

追記
oh-my-zshの行をコメントアウトしても変化なく、.zshrcの中身を全て削除してterminalを再起動してもこのメッセージだけ残っているのです。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

ベストアンサー

.zshrcの中身を全て削除してエラーになるならエラーの原因は他にあるということなわけで、.zshrcを載せてもしょうがないでしょう。

https://linuxcommandlibrary.com/man/zsh#files
に羅列されている、

.zprofile
.zshrc
.zlogin
.zlogout
/etc/zshenv
/etc/zprofile
/etc/zshrc
/etc/zlogin
/etc/zlogout
/tmp/zsh*

のファイル群について、存在しているかと、存在するならその内容を全部確認する必要があると思います。

投稿2022/06/29 14:22

quickquip

総合スコア11072

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

fopi

2022/06/30 00:34

`/etc/zlogout`など一部のファイルがありませんでした。だからといってどうすればいいのか検討もつきませんでしたが...。
quickquip

2022/06/30 01:12

/etc/〜 に関してはわざわざいじったとは考えにくいですが一応挙げただけです。(可能性はゼロではないですし) ただ、.zprofile や .zlogin があるならそこに原因はないですか? それは分かっていますか? という趣旨の回答です。 そのあたりに問題はないと断言できるならこの回答は無視してかまいません。検索などでここにたどりついた人に向けた情報として残しておくだけです。 (それらが提示されていない以上こちらから具体的な指摘は出来ません)
fopi

2022/06/30 13:22

`~/.bashrc`のgit-completionに関する部分をコメントアウトしたところエラーが表示されなくなりました。
guest

0

ERROR: this script is obsolete, please see git-completion.zsh の意味通りだと思うのですが… ググっても色々と情報出てきますよ。

https://stackoverflow.com/questions/24315201/warning-this-script-is-deprecated-please-see-git-completion-zsh

分からないのであれば、まずはoh-my-zshの行を外して再ログインしてみれば良いと思います。

oh-my-zshでななく、git-completionの読み込みの部分が怪しいですね。

投稿2022/06/29 04:10

編集2022/06/29 09:28
AbeTakashi

総合スコア4611

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

fopi

2022/06/29 05:13

ありがとうございます。 そのページは既に確認しました。oh-my-zshの行をコメントアウトしても変化なく、`.zshrc`の中身を全て削除してterminalを再起動してもこのメッセージだけ残っているのです。
RiaFeed

2022/06/29 05:42 編集

git-completion.bashが出してるメッセージなので、質問で示している設定ファイルの該当の行周辺をコメントアウトして、 それでもなお出てくるならどこかの設定ファイルで実行されているのでgrepで探してみては。 あるいは設定ファイルによれば~/.zshにあるはずのgit-completion.bashを消すとか
AbeTakashi

2022/06/29 09:28

RiaFeedさんのご指摘も含めて、確認済みや対応済みの内容も「質問文内に追記」されると良いです(ここの返答で書いても読まない人もいますので)。すでに対応済みの内容が分かれば、回答される方が答えやすくなります。 参考) https://teratail.com/help/question-tips 「あなたが解決する為に試してみたことを書きましょう」の行は読まれることをオススメします。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.45%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問