質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.02%
Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

Q&A

解決済

Laravel 日本語化ライブラリでエラーが出る

meex
meex

総合スコア50

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

2回答

0グッド

0クリップ

1938閲覧

投稿2022/03/11 12:31

https://qiita.com/ShibuyaKosuke/items/1b194d4a907906499796

こちらの記事を参考に、Laravel日本語のため、composerを用いて下記コマンドを実行しました。

composer require shibuyakosuke/laravel-language-setting --dev

結果下記の通りエラーが出ました。

composer require shibuyakosuke/laravel-language-setting --dev Info from https://repo.packagist.org: #StandWithUkraine Using version ^1.1 for shibuyakosuke/laravel-language-setting ./composer.json has been updated Running composer update shibuyakosuke/laravel-language-setting Loading composer repositories with package information Info from https://repo.packagist.org: #StandWithUkraine Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - shibuyakosuke/laravel-language-setting 1.1.0 requires laravel/framework 5.5.*|5.6.*|5.7.*|5.8.*|^6.0|^7.0 -> found laravel/framework[v5.5.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev] but it conflicts with your root composer.json require (^9.2). - shibuyakosuke/laravel-language-setting 1.1.1 requires laravel/framework 5.5.*|5.6.*|5.7.*|5.8.*|^6.0|^7.0|^8.0 -> found laravel/framework[v5.5.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev] but it conflicts with your root composer.json require (^9.2). - shibuyakosuke/laravel-language-setting 1.1.2 requires laravel/framework ^6.20.12|^7.30.4|^8.0 -> found laravel/framework[v6.20.12, ..., 6.x-dev, v7.30.4, v7.30.5, v7.30.6, 7.x-dev, v8.0.0, ..., 8.x-dev] but it conflicts with your root composer.json require (^9.2). - Root composer.json requires shibuyakosuke/laravel-language-setting ^1.1 -> satisfiable by shibuyakosuke/laravel-language-setting[1.1.0, 1.1.1, 1.1.2]. Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions. Installation failed, reverting ./composer.json and ./composer.lock to their original content.

どのようなコマンドを打てば、正常に処理が進むのでしょうか?

補足:
昨年2021年5月にこのコマンドを流したときは正常に進めていました。

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

2022/03/11 21:37

こちらの質問が他のユーザーから「過去の低評価」という指摘を受けました。

m.ts10806

2022/03/11 22:27

composer update は試しましたか?
meex

2022/03/11 23:38

[composer update]はしていませんでしたので、してみました。 その後「composer require shibuyakosuke/laravel-language-setting --dev」をしましたが、同じ症状が出ました。

回答2

0

エラーメッセージにより

  • 作成したプロジェクト直下のcomposer.jsonでLaravel/frameworkのバージョンは^9.2と指定されている
  • shibuyakosuke/laravel-language-settingはLaravel 8までしか対応していない

ということがわかります。
実際、shibuyakosuke/laravel-language-settingのcomposer.jsonには

"laravel/framework": "^6.20.12|^7.24|^8.0"

と記述されていました。
Laravelが9になったのは2022年2月なので、昨年大丈夫だったのは対応しているバージョン8だったからでしょう。

打てる手は

  • プロジェクトをlaravel 8でやり直す
  • shibuyakosuke/laravel-language-settingがLaravel 9に対応するのを待つか自分で対応させる

でしょうか。

投稿2022/03/12 01:14

crhg

総合スコア1169

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

0

ベストアンサー

Laravel9に対応してないだけ。
まずcomposer.jsonを見る。
"^6.20.12|^7.24|^8.0"だから9にはインストールできない。
9ではlangディレクトリの置き場所変わってるのでcomposer.jsonだけ修正しても直らない。

解決策はLaravel9に対応してるパッケージを使う。
https://github.com/Laravel-Lang/lang

「Laravelのバージョンアップにきちんと追従してるパッケージを選ぶ」のもLaravelを使うために必須の能力。
Qiitaに多いけど「作った」だけでその後のバージョンアップを全くしてない無責任な初心者が多すぎる。

投稿2022/03/12 01:09

kawax

総合スコア9956

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

2022/05/02 20:33

こちらの回答が他のユーザーから「過去の低評価」という指摘を受けました。

回答へのコメント

meex

2022/03/12 03:12

お二方ともありがとうございました。 大変よく理解することができました。 ご提示いただいた回答をもとに対処いたします。 (一番最初に回答いただいた方にBAとさせて頂きました) ありがとうございました。

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.02%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。