質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
React Native

React Nativeは、ネイティブモバイルアプリ(iOS/Android)を作成できるJavaScriptフレームワークです。Reactと同じ設計のため、宣言的なコンポーネントでリッチなUIを開発することが可能です。

Q&A

1回答

1406閲覧

Windowsで npm install expo-cli --globalが出来ません。

MUSUBINON

総合スコア11

React Native

React Nativeは、ネイティブモバイルアプリ(iOS/Android)を作成できるJavaScriptフレームワークです。Reactと同じ設計のため、宣言的なコンポーネントでリッチなUIを開発することが可能です。

0グッド

0クリップ

投稿2023/02/17 13:52

編集2023/02/18 03:03

実現したいこと

uuid@3.4.0をバージョン7へアップグレードしReact Native をするためにexpoをインストールしたいです。

前提

Windows Powershell でexpoをインストールしたいのですがnpm WARN deprecated というエラーが出てインストールできません。
uuidをアップデードして欲しいとあるのですが、どれだけ調べても方法が見つかりませんでした。

発生している問題・エラーメッセージ

npm WARN deprecated @npmcli/move-file@1.1.2: This functionality has been moved to @npmcli/fs npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. changed 1177 packages in 1m 102 packages are looking for funding run `npm fund` for details

試したこと

uuid@3.4.0をアップデートする為に「npm install uuid@latest -g」や「npm install uuid@latest 」を入力してみたのですが、ずっとこのエラーが出ます。

補足情報(FW/ツールのバージョンなど)

windows10 node.js -v18.14.1

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

symfo

2023/02/17 14:28

>npm WARN deprecated というエラー WARNとはwarning、警告・注意なんだが。。。
MUSUBINON

2023/02/17 15:02

はい。調べたらそれは分かったのですが、expoのバージョンを調べようと expo --version を入力してもexpoがインストールされていなくて、バージョンが出てこなかったんです。
guest

回答1

0

グローバルオプションでインストールすると、node、npmコマンドと同じ場所にインストールされます。

% which node node is /usr/local/bin/node % which npm npm is /usr/local/bin/npm % which expo-cli expo-cli is /usr/local/bin/expo-cli % expo --version 6.3.1

投稿2023/02/17 15:39

編集2023/02/17 22:38
technocore

総合スコア7200

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

MUSUBINON

2023/02/18 01:09

回答ありがとうございます。 やってみたのですが、uuidのアップデートが出来ないみたいです、
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問