質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

Q&A

解決済

2回答

423閲覧

macでHomebrewを使ってPHPをインストールする

chako_2007

総合スコア34

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

0グッド

0クリップ

投稿2023/12/04 11:10

実現したいこと

mac OS 13.1にPHPをインストールしたいです。

作業内容

https://qiita.com/HRI-DAWN/items/b735e636056e5cbe6bfc
上記のサイトを参考にPHPのインストールを進めています。
Z ShellのintelCPUを使っています。

シェルスクリプトに以下の2行を追加後

echo 'export PATH="/usr/local/opt/php@7.4/bin:$PATH"' >> ~/.zshrc echo 'export PATH="/usr/local/opt/php@7.4/sbin:$PATH"' >> ~/.zshrc

以下を実行しました。ここまでは問題ありませんでした。

source ~/.zshrc

その後、PHPをスタートさせるコマンドを実行すると、php@7.4は無いよとエラーが出てしまいます。
どういうことか分かりますでしょうか?
ご教授お願いします。

hogeUser@Mac-mini testDir % brew services start php@7.4 ==> Tapping homebrew/services Cloning into '/usr/local/Homebrew/Library/Taps/homebrew/homebrew-services'... remote: Enumerating objects: 2583, done. remote: Counting objects: 100% (2583/2583), done. remote: Compressing objects: 100% (1143/1143), done. remote: Total 2583 (delta 1256), reused 2520 (delta 1247), pack-reused 0 Receiving objects: 100% (2583/2583), 674.60 KiB | 8.76 MiB/s, done. Resolving deltas: 100% (1256/1256), done. Tapped 1 command (45 files, 849.6KB). Error: No available formula with the name "php@7.4". Did you mean php@8.2, php@8.1 or php@8.0?

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hoshi-takanori

2023/12/04 11:42

現在の Homebrew では php@7.4 はすでにサポートされてないようです。どうしても PHP 7.4 が必要でしょうか? また、念のため確認ですが、お使いの Mac は Intel チップ搭載ですか? (その記事が書かれた当時は Apple Silicon に対応してないものが色々あったので、ターミナルを Rosetta で使う方法も有効でしたが、現在はむしろ副作用の方が大きくなっており、あまりお勧めできません。)
chako_2007

2023/12/04 12:18

特別、古いversionを入れる必要はありませんでした。 「brew install php@7.4」 このコマンド実行できていると思っていましたが、Warningが出ており、実行できていませんでした。 ご回答ありがとうございます。
guest

回答2

0

自己解決

「brew install php@7.4」ではなく、新しいversion
「brew install php@8.2」でしたら、正しくインストールできました。
「brew search php」をすれば、インストールできるPHPversionがわかりました。

投稿2023/12/04 12:21

chako_2007

総合スコア34

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

[香車]東上☆あらし☆海美「
ワシは、macOS(M1) に MAMP を入れて、php を動かしています。

回答への修正依頼: スパムと見受けられる内容を含む回答 2023/12/05 13:05
[香車]東上☆あらし☆海美「
homebrew でうまくかない、というから、別の手段を紹介した訳ですが、どこがスパムなのでしょうか。説明の書込を要求します。

投稿2023/12/04 12:21

編集2023/12/05 06:10
umimi

総合スコア198

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問