質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Router

Routerは、異なるネットワーク同士を相互に接続するための通信機器。インターネットでのデータを自動的に振り分け、一つのインターネット回線を複数のコンピュータで使用することが可能です。DHCPによりIPアドレスを自動的に割振りすることもできます。

ネットワーク

ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

Cisco

シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

解決済

L3スイッチでVLAN別々のインターネット向けルーティングについて

homino
homino

総合スコア1

Router

Routerは、異なるネットワーク同士を相互に接続するための通信機器。インターネットでのデータを自動的に振り分け、一つのインターネット回線を複数のコンピュータで使用することが可能です。DHCPによりIPアドレスを自動的に割振りすることもできます。

ネットワーク

ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

Cisco

シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

1回答

0評価

0クリップ

180閲覧

投稿2022/05/22 14:20

編集2022/05/24 00:00

L3スイッチでVLAN分けての別々のインターネット向けルーティングについて質問させてください。

GE0/8にRouter-A(192.168.100.254)
GE0/10にRouter-B(192.168.200.254)
を接続しています。

スタティックルートで
ip route 0.0.0.0 0.0.0.0 192.168.100.254
を設定すればvlan10はインターネットに出れますが
vlan20用で同じく
ip route 0.0.0.0 0.0.0.0 192.168.200.254
も設定するとvlan10もvlan20もインターネットに出れなくなります。
逆にip route 0.0.0.0 0.0.0.0 192.168.200.254だけにすればvlan20でインターネットに出ることができます。

vlan10はGE0/8にRouter-A(192.168.100.254)からインターネットへ
vlan20はGE0/10にRouter-B(192.168.200.254)からインターネットへ
別々に出て戻って来れるように設定したいです。

関係あるかわかりませんが、Router-A、Router-BはどちらもdocomoのHR01ホームルーターなので戻り経路とかの指定はできなそうです。
(39ページのIPアドレスフィルタリングという機能がそれに当たるのかもしれません。)
https://www.docomo.ne.jp/binary/pdf/support/manual/HR01_J_syousai.pdf

どの様にルーティングを設定すればいいのでしょうか?

すみませんが、よろしくお願いいたします。

!
ip routing
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/3
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/4
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/5
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/6
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/7
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/8
description Router-A(192.168.100.254)
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/9
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/10
description Router-B(192.168.200.254)
switchport access vlan 20
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.100.253 255.255.255.0
!
interface Vlan20
ip address 192.168.200.253 255.255.255.0
!
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 192.168.100.254

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Router

Routerは、異なるネットワーク同士を相互に接続するための通信機器。インターネットでのデータを自動的に振り分け、一つのインターネット回線を複数のコンピュータで使用することが可能です。DHCPによりIPアドレスを自動的に割振りすることもできます。

ネットワーク

ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

Cisco

シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品