質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.99%

  • Monaca

    864questions

    「Monaca」はiOS、Android、Windows向けのアプリ開発に対応した、Cordovaベースのモバイルアプリ開発プラットフォームです。HTML5、JavaScriptといったWeb標準技術を用いてモバイルアプリ開発を行うことができます。

  • ニフティクラウドmobile backend

    16questions

    ニフティクラウドmobile backend (mBaaS)はニフティが提供するBaasサービスです。プッシュ通知、データストア、ファイルストア、会員管理・認証機能などのバックエンド機能をクラウドから提供しています。 Andoird/iOS/JavaScript/Unityと各種SDKに対応しています。

【Monaca 】【NCMB】setDeviceTokenをせずにdeviceTokenを取得したい。

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 315

yuki-saito

score 895

前提・実現したいこと

MonacaとNCMBでプッシュ通知を実装しています。

オーソドックスな端末登録の仕方だと
devicereadyでwindow.NCMB.monaca.setDeviceTokenをするのだと思うのですが
アプリから直接NCMBに登録するのではなく
アプリから自社サーバを経由してNCMBにしたいです。

自社サーバからNCMBにセットするには
配信端末登録APIでできると思っているのですが
アプリ側でdeviceTokenを取得して自社サーバに送る必要があり
その方法が分からずに困っています。

【現在】(アプリ⇒NCMB)

window.NCMB.monaca.setDeviceToken(APP_KEY, CLIENT_KEY, SENDER_ID, successCallback, errorCallback);

【理想】(アプリ⇒自社サーバ⇒NCMB)

// deviceTokenを取得 ★こちらの方法が分かりません。
// 自社サーバへpost
// 自社サーバからNCMBへ登録
// 以下のAPIを想定
// http://mb.cloud.nifty.com/doc/current/rest/push/installationRegistration.html

window.NCMB.monaca.getInstallationIdという方法はあるようですが
NCMBのキー情報をアプリ側で持ちたくないこともあり
setDeviceTokenをせずに行いたいと考えています。

window.NCMB.monacaやNCMBのinstallationで取れると大変嬉しいのですが
その他の方法でも教えていただけるだけで有難いです。

試したこと

Githubにある各SDK内のコードも見ながら
試してみてはいますが、現時点では見つかっておりません。

補足情報(言語/FW/ツール等のバージョンなど)

Monaca、NCMB monaca_push_plugin、NCMB ncmb_js

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

+1

NCMBは使用していないのですが、
端末のデバイストークンを取得する方法であれば、
iOS・Androidともに対応できるFirebaseを使用されてはいかがでしょうか?

参考
https://utage.headwaters.co.jp/blog/?p=6406
https://utage.headwaters.co.jp/blog/?p=6478

Monacaで使用するプラグインは
https://github.com/arnesson/cordova-plugin-firebase
が良いと思います。
(https://teratail.com/questions/88609 も参考に)

プラグインの window.FirebasePlugin.getToken メソッドで
デバイストークンが取得できるので、
それを御社サーバにPOSTしてあげれば良いかと。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/10/18 11:36

    Clavatさんが自己解決されていたこちらの質問も見ておりました。
    https://teratail.com/questions/69832

    やはりFirebaseならば可能なのですね。
    テスト実装して試してみます。

    ありがとうございます。

    キャンセル

  • 2017/10/19 17:35 編集

    Clavat 様

    試しているのですが、デバッグビルドするとFirebaseでエラーが発生してしまいます。
    教えていただいたサイトも確認して0.1.22で確認しております。

    *************************************
    "external_plugins": [
    "cordova-plugin-firebase@0.1.22",
    ],
    *************************************

    *************************************
    - postBuild -
    Remove working directories...
    Build Error: Error: Sandbox Exec Error: [ 注意:一部の入力ファイルは非推奨のAPIを使用またはオーバーライドしています。
    注意:詳細は、-Xlint:deprecationオプションを指定して再コンパイルしてください。
    注意:一部の入力ファイルは非推奨のAPIを使用またはオーバーライドしています。
    注意:詳細は、-Xlint:deprecationオプションを指定して再コンパイルしてください。
    /private/tmp/monaca/59e86352e78885af358b456b/project/platforms/android/src/org/apache/cordova/firebase/FirebasePlugin.java:278: エラー: シンボルを見つけられません
    boolean areNotificationsEnabled = notificationManagerCompat.areNotificationsEnabled();
    ^
    シンボル: メソッド areNotificationsEnabled()
    場所: タイプNotificationManagerCompatの変数 notificationManagerCompat
    注意:一部の入力ファイルは非推奨のAPIを使用またはオーバーライドしています。
    注意:詳細は、-Xlint:deprecationオプションを指定して再コンパイルしてください。
    エラー1個

    FAILURE: Build failed with an exception.
    *************************************

    バージョンは0.1.22でやられていますか?

    キャンセル

  • 2017/10/19 17:58

    コード追加したので、↓に別途回答します。

    キャンセル

  • 2017/10/19 18:01

    ありがとうございます!><

    キャンセル

+1

ビルドは混雑等でたまーに同一コードでもエラー(failed)になることもありますが、
何か(プッシュ通知系の?)プラグインが競合していませんか?

私は現在もたしかに cordova-plugin-firebase@0.1.22 でプラグインをインポートしています。

まずは一度、新プロジェクト作成からシンプルに、
AndroidでFirebaseのプッシュ通知だけ構成されてはいかがでしょうか?
(とりあえずAndroidだけであれば、Appleの証明書関係は一切不要で、)

私の場合ですが
①「Onsen UI V2 JS Minimum」を選択
②cordova-plugin-firebase@0.1.22 プラグインだけを追加でインポート
③「index.html」のscript部分を以下に。
トークン取得処理すら入れていません。

  <script>
    ons.ready(function() {
      console.log("Onsen UI is ready!");

        window.FirebasePlugin.grantPermission();//iOSで必要なのでAndroidテスト時はなくてもOKなはずです

        window.FirebasePlugin.onNotificationOpen(function(notification){
        console.log(notification);
        });
    });
  </script>

④あとは、FirebaseにAndroidアプリを登録して、「google-services.json」を取得。
Monacaのルートディレクトリへアップ

⑤ビルドする

⑥Firebaseコンソールからプッシュ通知を「Androidアプリ」宛で送付
(デバイストークン指定じゃなくても送付できますので、試しに・・・)

まずはこれで流れをつかめるかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/10/19 18:02

    丁寧にありがとうございます。
    確かに色々試し過ぎて競合はあり得ます・・・
    シンプル版で試してみます!><

    キャンセル

  • 2017/10/19 18:08

    たぶんご理解されていると思いますが、アプリのID(逆ドメインで指定する)のところは、MonacaとFirebase登録のアプリIDとで合わせてくださいね。このあたりは参考サイトに色々と書いてありますので、その手順で大丈夫だと思います。

    キャンセル

  • 2017/10/19 20:12

    了解しました!
    何から何までありがとうございます。

    キャンセル

  • 2017/10/21 12:05

    Clavat 様
    色々教えていただき、本当にありがとうございました。
    おかげさまでFirebaseでも実装することができました。
    結果的には解決した方法にも書いた通り
    全てをリセットしてMonacaのプッシュ通知で実装することにしたのですが
    Firebaseのコードもできたのでとても満足しています。
    折角色々学んだので、次は是非Firebaseも使ってみたいと思っています。

    P.S
    Firebaseのバージョンは指定せずともできるようになっておりましたので、お知らせしておきます。
    (最新は0.1.24でしたかね。)

    本当に色々とありがとうございました。

    キャンセル

  • 2017/10/21 12:46

    解決したようでよかったです。
    Monacaバックエンドを使用されたのですね?
    私の場合はMonacaバックエンドの通知数に上限があることと、
    iOS・Androidを一括して1ソースで管理したいということもあり、
    Firebaseを選んで、それに伴うプラグインを入れました。

    最新バージョンはiOSでクラッシュするバグがあったので、0.1.22にしています。
    Androidですと、0.1.24でも大丈夫でした。

    キャンセル

  • 2017/10/21 13:44

    あっなるほど、そういうことなんですね!
    それでは私もMonacaバックエンドではダメかもしれないですし
    iOS・Androidどちらも使うので、結局はFirebaseで0.1.22になるかもしれません!
    もう少し調べてみます!
    またまた色々教えていただいてしまってありがとうございます!

    キャンセル

  • 2017/10/21 13:50

    最後にウラワザ的な使い方ですが、Monacaのバックエンドでプッシュ通知に必要な証明書やp12ファイルなどを作成してApple Dev Centerと
    Firebaseに登録してしまえばMonacaのバックエンドを削除して(バックエンドを経由せずに)Firebase→(APNsを自動的に経由して)→各端末への流れも確立できますので、Monacaバックエンドの通知数上限も問題なくクリアできますw
    Windowsユーザの私としてはうれしい誤算で・・・。
    MonacaをMacのキーチェーン代わりに使っている感じでしょうかね。

    また色々情報交換できればと思いますので、よろしくお願いいたします。

    キャンセル

  • 2017/10/21 14:10

    そうなのですね!
    Appleのdevelopers登録が申請してから進んでいないこともあって証明書などはこれからなのです。
    こちらこそ是非これからも情報交換させていただけたらと思います!
    よろしくお願い致します!!

    キャンセル

check解決した方法

0

結局NCMBではできず、Firebaseで取れたdeviceTokenはNCMBのものとは違った(当然ではありますが・・・)ため
プッシュ通知全てをFirebaseで行う必要が出て来てAPIから何から見ていたのですが
結果的にMonacaのプッシュ通知でいいじゃんと思ったため、全てをリセットしてMonacaだけで実装する方針としました。
(MonacaであればdeviceIDが取れるので、それをサーバに送ってそこからMonacaのプッシュ通知APIを叩くことにしています。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Monaca

    864questions

    「Monaca」はiOS、Android、Windows向けのアプリ開発に対応した、Cordovaベースのモバイルアプリ開発プラットフォームです。HTML5、JavaScriptといったWeb標準技術を用いてモバイルアプリ開発を行うことができます。

  • ニフティクラウドmobile backend

    16questions

    ニフティクラウドmobile backend (mBaaS)はニフティが提供するBaasサービスです。プッシュ通知、データストア、ファイルストア、会員管理・認証機能などのバックエンド機能をクラウドから提供しています。 Andoird/iOS/JavaScript/Unityと各種SDKに対応しています。