質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.75%

  • Ruby on Rails

    6726questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby on railsの導入について

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 271

ikyu

score 2

Ruby on railsの導入で躓いています
OSはWindows10なのですが、コマンドプロンプトで
gem install railsと指示すると以下のように表示され、最後までインストールが完了しません。

You have to install development tools first.
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:587:in try_cpp' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1091:in block in have_header'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:942:in block in checking_for' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in block (2 levels) in postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in open' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in block in postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in open' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:346:in postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:941:in checking_for' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1090:in have_header'
from extconf.rb:5:in `<main>'

一応devkitを入れなおしたりもしてみましたが解決しません。
バージョンを4.0系統にすると成功しますが、使っている書籍の都合上5.0系統をインストールする必要があります。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2017/10/12 22:23

    OS に拘りがなければ、たとえばVirtualbox にUbuntu をインストールし、その上で使っていく選択肢は考えられませんか?

    キャンセル

  • ikyu

    2017/10/12 22:31

    回答ありがとうございます。現在全くの初心者で、なるべく書籍の通りに薦めていきたいので、なんとかgem install railsで実行できないかと考えているのですが・・・

    キャンセル

  • CHERRY

    2017/10/13 13:44

    書籍などを参考にしている場合は、書籍のタイトルも 質問に追記していただけないでしょうか?

    キャンセル

回答 3

checkベストアンサー

+1

You have to install development tools first. というメッセージの通り、devkitのインストールが完了していません。

一応、以下にWindowsでの作業を示しますが、最終的にはVirtualBoxでCentOSなどのLinux仮想マシンで作業できるようになったほうが良いです。
私自身もWindowsをメインOSとして使っていますが、Railsに限らずWeb関連の開発作業は仮想マシンで作業しています。


この作業は新規インストールを前提としているので、今入っているrubyとdevkitを削除してから行ってください。

レジストリが汚れるの嫌なので、インストーラなしのバージョンで試してみました。

環境は、Windows10 64bitです。
https://rubyinstaller.org/downloads/ から以下の2つをダウンロードします。

ruby-2.3.3-x64-mingw32.7z
DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe

ruby-2.3.3-x64-mingw32.7zをC:\ruby-2.3.3に展開します。
ディレクトリの構造はこうなります。

C:\ruby-2.3.3
  bin\
  include\
  lib\
  share\

C:\ruby-2.3.3\binにパスを通して、rubyコマンドが正しく行えるか確認します。

> ruby -v
ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]

DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exeをダブルクリック。
保存先を聞かれるので、C:\devkit を指定します。

> cd C:\devkit
C:\devkit> ruby dk.rb init

config.ymlというファイルが作成されるので、

---
- C:/ruby-2.3.3


となっているか確認します。
もし違っていたら、上記の内容に書き換えます。

devkitをインストールします。

C:\devkit> ruby dk.rb install
[INFO] Updating convenience notice gem override for 'C:/ruby-2.3.3'
[INFO] Installing 'C:/ruby-2.3.3/lib/ruby/site_ruby/devkit.rb'

gem searchで最新の5.0.xのバージョンを確認します。

> gem search -a "^rails$"
rails (5.1.4, 5.1.3, 5.1.2, 5.1.1, 5.1.0, 5.0.6, 5.0.5,...

5.0.6が最新である事が分かったので、インストールします。

> gem install --no-document rails -v 5.0.6

特にエラーもなくインストールが完了します。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Windows で Ruby の開発はおすすめしません。
Cloud9 https://c9.io/ にアカウントを作りましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

SugiTKさんの言うようにCloud9でやるのが一番簡単です。
あとは、Vagrantでlinuxの仮想サーバを構築する方法もありだと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.75%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    6726questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。