質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Android

    6540questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Eclipse

    1664questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

EclipseでAndroidの開発環境が作成できない

解決済

回答 4

投稿

  • 評価
  • クリップ 1
  • VIEW 3,579

shanxia

score 976

Android Studioへの移行がまだ行えない既存アプリのバージョンアップのため、EclipseでのAndroid開発環境を作成使用としたのですが、Android sdkとEclipseのADTプラグインを導入した後Eclipseを起動すると次のダイアログボックスが出力されてしまって、パッケージの作成ができません。

イメージ説明

「SDKマネージャーを開く」ボタンを押しても、SDKマネージャーは開きませんでした。
この画面は、プロジェクトを何も開いていない状態でもEclipseを起動する度に表示されます。

環境構築に参考にしたサイトは以下の物です。

リンク内容

バージョンは微妙に違います。

Java ー 1.8.0_144
Eclipse ー Mars (pleiadesは使用していません。)
ADT ー 23.0.7
Android SDK ー API level 16,21,22,26

Android SDKは、Android StudioのSDKマネージャーからインストールしました。
そちらは正常に動いています。

EclipseをMarsにしたのは、元々開発していたPCがMarsを使用していたためです。
Eclipseの環境設定でのSDKのパスしても正確な位置を指定して、SDKバージョン一覧も正常に表示されます。

いろいろ調べていると、Stack Overflowに似た質問があったので、ここで示されているとおりAndroid Studioとは別の場所にSDKをインストールして見ましたが、改善しませんでした。

stackoverflow

なお、SDKのみをダウンロードする方法が見つけられなかったため、SDKマネージャーで別のパスを指定してインストールしました。

ここまでやって行き詰まってしまったので、何か良い方法をご教授いただけないでしょうか。

OSは、macOS 10.12.6 を使用しています。

なお、ビルドできているEclipseをそのままコピーしても、症状は改善しませんでした。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 4

checkベストアンサー

+1

EclipseにAndroid Development Tools(ADT)を導入した環境でメニューに表示される「Android SDK Manager」や「Android Virtual Device Manager」は、それに対応するコマンドがAndroid SDK Tools r25.3で廃止されているため、メニューで選択しても反応してくれません。内部的にNot Foundなわけです。ですから、Android SDK Toolsがr25.3未満になるようにSDKを構築するしかありません。先の回答にあるように、SDK r24.4.1(含まれるSDK Toolsもr24.4.1)を入手するのは有効な手段でしょう。

ただ、それ以上に厳しいのが、Eclipseに対応するAndroid Support Libraryパッケージの入手が困難になっていることです。SDK Toolsを古いものにしてSDK Managerが開けるようになっても、そのリストの中にAndroid Support Libraryの項目自体が存在しません(Android Support RepositoryはAndroid Studio向けなので、Eclipseでは使えない)。Obsolete(廃止パッケージ)にチェックを入れても出てこないのですから、徹底しています(下図参照)。
旧型のAndroid SDK Manager

SDKのようにURLを直接叩いてダウンロードすることもできないようです(私がアドレスを知らないだけかも)。

Support Libraryが導入できないと、アプリ開発は非常に辛いです。まず、プロジェクトを新規作成するときのダイアログで、Themeの項目でNoneしか選ぶことができません。他を選んでプロジェクトを作成しても、作られた雛形はSupport Libraryの参照が必要なのでエラーだらけで使い物になりません。
EclipseのNew Android Applicationダイアログ

また、android.support.v4やandroid.support.v7のパッケージに属するAPIが全部使えません。これでは、過去の資産を開くことさえできないでしょう。

これを何とかする方法を探さなければ、Eclipseでまともにアプリ開発することはできないでしょう。これについては私も有効な情報を提供することができません。


ちょっと補足ですが、GoogleがADTの開発を打ち切ったのが2015年夏、サポートを打ち切ったのが2015年末です。ですから、質問に記されたリンクの記事が書かれたのは、ちょうどこの「絶妙な時期」なんですよね。それ以後、Googleは急速にAndroid Studioへの移行を推し進めるために、Eclipseの環境存続が難しい状況を意図的に作ってきたと考えられます。Support Libraryをリスト上からも抹消したこともその一つなのでしょう。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/23 11:16

    SupportLibraryについて、正当なやり方ができないのはご指摘の通り(というか、私も知らなんだ。情報感謝)ですが、無理やりな方法を紹介しておきます。

    Eclipseでaar形式のAndroidライブラリを取り込む方法(https://qiita.com/ksoichiro/items/f68e19e70d6635a7be18)


    キャンセル

  • 2017/09/25 11:47

    みなさま回答ありがとうございます。いただいたaar形式でAndroidライブラリを取り込む方法も試しましたが、gradleの設定を作るところで時間がかかりそうなのが分かりました。これだとAndroid Studioへの移行と変わらなさそうなので、やめておこうと思います。
    やはりモバイルの世界で、昔の環境をずっと引き継ぐのはよくありませんね。

    キャンセル

+1

AndroidStudioのバージョンが書かれていませんが、最新版(確か2.3以降?)ではSDKManagerが一新され、それに伴いSDKのディレクトリ構成もガラッと変わっています。
おそらくそれが原因だと思いますが。

掲示されているStackOverflowの質問のXngPro氏の回答に、古いSDKManagerを含むSDKのリンクがありますが、それもダメなんでしょうか。
linux版のSDKをダウンロードしてandroidスクリプトを実行したら、古いSDKManagerが立ち上がったので、間違いないと思うのですが。

もしくは、古いAndroidStudioでSDKをダウンロードしてみてください。

(追記: 上記ダウンロードアーカイブは、Windows用SDKバンドル版(android-studio-bundle-*.exe)以外はリンク切れのようです。)

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/25 11:50

    回答ありがとうございます。
    Android Studioのバージョンを忘れていました。v2.3を使用しています。AndroidStudioのバージョンには思い当たりませんでしたが、ビルドできている環境をそのままコピーしていたので、問題ないかと思っていました。
    一応Android sdkもコピーして、場所を変更しても同様でした。

    ちなみにご質問のXngPro氏のリンクですが、ダウンロードして展開しても必要なファイルが足りないらしく、ビルド操作すらできませんでした。

    キャンセル

+1

ANDROID STUDIO 2.X環境でANDROID 1.6 DONUTS(API-4)向けアプリをビルドする方法

を参考にAndroid の低レベルAPIを使えるようにする方が早そうだ?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/25 01:43

    この方法を採ることは不可能です。私の回答にも書きましたが、Android Support LibraryがObsoleteからすら抹消されているので、選択することができません。

    キャンセル

  • 2017/09/25 07:45

    ざっくり確認したら

    build.gradle を直接編集になるようですが

    compile group: 'com.google.android', name: 'support-v4', version: 'r7'

    は使える模様

    キャンセル

  • 2017/09/25 08:31 編集

    自分でも確認するんでここに記したコメントは取り消します。

    キャンセル

  • 2017/09/25 08:53

    記事の本筋の方法は使えなかったんで指摘はあってるけどね。。。

    キャンセル

+1

皆さんにいろいろ回答をいただいた後に恐縮ですが、元のビルドできていたPCのeclipseとAndroidStudioと、AndroidSDK(8GBありました)をそのままコピーする事でなんとか解決しました。
ありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/26 01:10

    実は、「現行でEclipseによるAndroidアプリ開発環境を維持しているマシンから、Support Libraryも含めたSDK一式をアーカイブして移植する」というのは、一番単純な解決法です。Stack Overflowの回答の中にも、私的にアーカイブしたと思われるものを置いたGoogle Driveの公開リンク先を示している人もいましたね。

    さすがに見ず知らずの人から分けてもらうのは非常に危険ですが、同業他社で懇意にしている人からの提供であってもコンプライアンスには反するかもしれません。ですから、私も承知していながら回答は躊躇っていました。

    自分の過去のPCに入っていたものであれば全く問題はなさそうですね。それで解決できたのなら何よりです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Android

    6540questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Eclipse

    1664questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。