質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.48%

  • PHP

    20912questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • WordPress

    7470questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。

ワードプレスのPHPバージョンを切り替えたらエラー表示が出てブログが見れなくなった

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 1,447

hokkaido0984

score 6

お世話になります。

エックスサーバーで、ワードプレスのPHPバージョンを最新のもの「PHP7.1.2」に切り替えたらエラー表示が出てブログがきちんと表示されなくなってしまいました。

http://fx-dakar.com/

変にいじると余計わからなくなるかとおもい、そのままにしている状態です。
どなたかアドバイスおねがいできますか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+3

wp-noteが原因の一つであると思います。

Fatal error: Uncaught Error: Call to undefined function eregi_replace() in /home/ic5351/fx-dakar.com/public_html/wp-content/plugins/wp-note/wp-note.php:43

eregi_replaceはPHP 7.0で削除されたので、作業用にいったんPHP 5.6にバージョンダウンするのも手ですね。
しかし、全体的にWordPress本体およびプラグインのバージョンが古いようですね。wp-noteは長くアップデートされていないようですし、いったんすべてのプラグインを削除した上で、WordPressのバージョンアップでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/17 23:54

    ありがとうございます。
    wp-noteは長くアップデートされていない
    >やってみます。

    他の方のアドバイスで解決しました。
    ご回答ありがとうございました。

    今後ともよろしくおねがいします。
    当方、本当に初心者なんです。

    キャンセル

checkベストアンサー

+2

有効になっているプラグインの名前とバージョンを提示してください。それとプラグインを全停止してみてください。
あ、いや、とりあえずPHPのバージョンを元に戻した方が良いですね。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/17 22:20

    お世話になります。
    早速ありがとうございます。

    元のPHPのバージョンはわからないです。
    なので、プラグインを全停止したほうがいいのでしょうか?

    キャンセル

  • 2017/09/17 22:28

    まぁ、どうしたいか、ですよね。エラーが出たままPHP7に合うようにするのか、とりあえずエラーを止めるのか。
    エラーを止めるならPHPのバージョンを5.6とかにしておけば止まるんじゃないかと思いますが。
    そのままPHP7に合わせるならアップデート可能なものは全てアップデートするしかないです。

    キャンセル

  • 2017/09/17 22:36

    なるほどです。
    最新版のPHP7.1.2にしたいんです。
    アップデート可能なものは全てアップデートするというのは、プラグインをアップデートするということなのでしょうか?
    プラグインが問題なのかとおもい、しらべたところ、キャッシュ系が問題である可能性が高いということをさきほど知りました。
    wp-note とかですかね?

    キャンセル

  • 2017/09/17 22:42

    WordPress 4.8.1 が利用可能です! 今すぐ更新してください。
    というのは管理画面に出てるんですよね。
    PHPだけバージョンアップしてWPがおっついてないみたいな話なんでしょうか?

    キャンセル

  • 2017/09/17 22:46 編集

    そうですね、本体とプラグインが古いはずなのでアップデート可能なものはアップデートすれば良いわけですが、WP-Noteというプラグインが何か知りませんが、エラーの原因の一つにWP-Noteも含まれているのですが、それに関してはバージョンアップされてないので、使えなくなるのを覚悟の上で全てアップデートしないといけません。、

    キャンセル

  • 2017/09/17 22:46

    WordPress 4.8.1 にしてみたら解決しました。
    ay03さん、ありがとうございました。
    コメントいただけなかったらこわくて手が出なかったです。

    キャンセル

  • 2017/09/17 22:48

    同時に書き込んでましたね、
    なるほどです。
    WP-noteはとりあえず停止しておきます。

    今後に生かしたいと思います。

    キャンセル

  • 2017/09/17 22:52

    更新可能なプラグインがあればそれも併せてアップデートしておいた方が良いかと思います。

    キャンセル

  • 2017/09/17 22:57

    わかりました。
    やってみます。

    キャンセル

関連した質問

同じタグがついた質問を見る

  • PHP

    20912questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • WordPress

    7470questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。

  • トップ
  • PHPに関する質問
  • ワードプレスのPHPバージョンを切り替えたらエラー表示が出てブログが見れなくなった