質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.35%

  • Linux

    4032questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Red Hat Enterprise

    116questions

    Red Hat Enterpriseは、レッドハット社により開発・サポートが行われている業務向けLinuxディストリビューションです。オープンソースで無償で利用することができ、バイナリ版の入手・サポートは有償です。商用ディストリビューションとして人気が高く、代表的なLinuxの選択肢の一つです。

CentOS7にて、セキュリティパッチの最新バージョンのみを抽出したい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,737

kk123

score 111

 タイトルの通りではありますが、、、

AmazonLinuxだと下記コマンドで最新パッケージのみを抽出できたのですが、
CentOS7だと、パッチ情報がすべて表示されてしまいます。

yum check-update --security

なにかうまいこと抽出する方法はありませんでしょうか?

 実際に自分がやってみたこと

 AmazonLinux

[hoge-y@ip-xx-xx-xx-xx ~]$ sudo yum check-update
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main                                                                                     | 2.1 kB  00:00:00
amzn-updates                                                                                  | 2.3 kB  00:00:00
2 packages excluded due to repository priority protections

authconfig.x86_64                                      6.2.8-30.31.amzn1                                 amzn-updates
aws-cfn-bootstrap.noarch                               1.4-21.13.amzn1                                   amzn-updates
aws-cli.noarch                                         1.11.132-1.47.amzn1                               amzn-updates
bash.x86_64                                            4.2.46-28.37.amzn1                                amzn-updates
curl.x86_64                                            7.51.0-9.75.amzn1                                 amzn-updates
glibc.x86_64                                           2.17-196.172.amzn1                                amzn-updates
glibc-common.x86_64                                    2.17-196.172.amzn1                                amzn-updates
glibc-devel.x86_64                                     2.17-196.172.amzn1                                amzn-updates
glibc-headers.x86_64                                   2.17-196.172.amzn1                                amzn-updates
kernel.x86_64                                          4.9.43-17.38.amzn1                                amzn-updates
libcurl.x86_64                                         7.51.0-9.75.amzn1                                 amzn-updates
python27-botocore.noarch                               1.5.95-1.65.amzn1                                 amzn-updates
system-release.noarch                                  2017.03-0.1                                       amzn-updates
wget.x86_64                                            1.18-3.27.amzn1                                   amzn-updates
yum.noarch                                             3.4.3-150.70.amzn1                                amzn-updates
[hoge-y@ip-xx-xx-xx-xx ~]$


上記の出力だと、パッケージに対して最新バージョンのみが出力されているように見える(理想)

 CentOS7

[hoge-y@ip-xx-xx-xx-xx ~]$ sudo yum check-update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.iweb.ca
 * extras: centos.mirror.iweb.ca
 * updates: centos.mirror.iweb.ca
 --> libdb-5.3.21-19.el7.i686 from base excluded (updateinfo)
 --> libcxgb4-static-1.3.5-3.el7.i686 from base excluded (updateinfo)
 --> libcxgb4-static-1.3.5-3.el7.x86_64 from base excluded (updateinfo)
 --> libcxgb3-static-1.3.1-8.el7.x86_64 from base excluded (updateinfo)
 --> libcxgb4-1.3.5-3.el7.x86_64 from base excluded (updateinfo)
:
200行ほど出力
:
 --> firefox-45.7.0-1.el7.centos.x86_64 from updates excluded (updateinfo)
 --> firefox-45.7.0-1.el7.centos.i686 from updates excluded (updateinfo)
 --> firefox-45.7.0-2.el7.centos.x86_64 from updates excluded (updateinfo)
 --> firefox-45.7.0-2.el7.centos.i686 from updates excluded (updateinfo)
 --> firefox-52.0-4.el7.centos.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-network-2.0.0-10.el7_3.2.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-storage-2.0.0-10.el7_3.2.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-storage-2.0.0-10.el7_3.4.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-secret-2.0.0-10.el7_3.5.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-secret-2.0.0-10.el7_3.9.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-kvm-2.0.0-10.el7_3.2.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-kvm-2.0.0-10.el7_3.4.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-storage-2.0.0-10.el7_3.5.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-driver-storage-2.0.0-10.el7_3.9.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-kvm-2.0.0-10.el7_3.5.x86_64 from updates excluded (updateinfo)
 --> libvirt-daemon-kvm-2.0.0-10.el7_3.9.x86_64 from updates excluded (updateinfo)
No packages needed for security; 53 packages available


明らかに同じパッケージに対して過去のバージョンのパッチも出力されているように見える。
これをAmazonLinuxみたいに出力させたい!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

CentOS7にもyum-plugin-securityがデフォルトで入っているので機能自体はあるのですが、CentOSのリポジトリにはセキュリティアップデート情報が無いので活用できていない状態なのです。

別途セキュリティ情報のリポジトリを導入することでAmazonLinuxのように機能するはずです。

参考:CentOS 7でyumからSecurityUpdateを行えるようにする

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/07 12:20

    回答していただきありがとうございます!
    確かにyum check-update --securityを実施した後の出力で、
    「No packages needed for security」と記載されていますね・・・

    キャンセル

同じタグがついた質問を見る

  • Linux

    4032questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Red Hat Enterprise

    116questions

    Red Hat Enterpriseは、レッドハット社により開発・サポートが行われている業務向けLinuxディストリビューションです。オープンソースで無償で利用することができ、バイナリ版の入手・サポートは有償です。商用ディストリビューションとして人気が高く、代表的なLinuxの選択肢の一つです。