質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.46%

  • Ruby

    9686questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    9088questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Rails5 rails server が起動しない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 891

kenny_sayama

score 987

 環境

  • RUby 2.4.0
  • Rails 5.1.2
  • Docker

前提・実現したいこと

rails5でAPIを作っているのですが、grape-jbuilderを入れるとなぜか、rails serverが起動しません

発生している問題・エラーメッセージ

/usr/local/bundle/gems/grape-jbuilder-0.2.0/lib/grape/jbuilder.rb:2:in `require': cannot load such file -- hashie/hash (LoadError)
    from /usr/local/bundle/gems/grape-jbuilder-0.2.0/lib/grape/jbuilder.rb:2:in `<top (required)>'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler/runtime.rb:96:in `require'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler/runtime.rb:96:in `rescue in block in require'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler/runtime.rb:73:in `block in require'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler/runtime.rb:66:in `each'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler/runtime.rb:66:in `require'
    from /usr/local/bundle/gems/bundler-1.15.3/lib/bundler.rb:108:in `require'
    from /myapp/config/application.rb:7:in `<top (required)>'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/commands/server/server_command.rb:129:in `require'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/commands/server/server_command.rb:129:in `block in perform'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/commands/server/server_command.rb:126:in `tap'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/commands/server/server_command.rb:126:in `perform'
    from /usr/local/bundle/gems/thor-0.19.4/lib/thor/command.rb:27:in `run'
    from /usr/local/bundle/gems/thor-0.19.4/lib/thor/invocation.rb:126:in `invoke_command'
    from /usr/local/bundle/gems/thor-0.19.4/lib/thor.rb:369:in `dispatch'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/command/base.rb:63:in `perform'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/command.rb:44:in `invoke'
    from /usr/local/bundle/gems/railties-5.1.2/lib/rails/commands.rb:16:in `<top (required)>'
    from /myapp/bin/rails:9:in `require'
    from /myapp/bin/rails:9:in `<top (required)>'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `load'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `call'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
    from /usr/local/bundle/gems/spring-2.0.2/bin/spring:49:in `<top (required)>'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `load'
    from /usr/local/bundle/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `<top (required)>'
    from /myapp/bin/spring:15:in `require'
    from /myapp/bin/spring:15:in `<top (required)>'
    from bin/rails:3:in `load'
    from bin/rails:3:in `<main>'

ログにはこのように出ていて、Gemfile以外は特に編集していません。

Gemfileは以下

source 'https://rubygems.org'

git_source(:github) do |repo_name|
  repo_name = "#{repo_name}/#{repo_name}" unless repo_name.include?("/")
  "https://github.com/#{repo_name}.git"
end


# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '~> 5.1.2'
# Use mysql as the database for Active Record
gem 'mysql2', '>= 0.3.18', '< 0.5'
# Use Puma as the app server
gem 'puma', '~> 3.7'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
# gem 'jbuilder', '~> 2.5'
# Use Redis adapter to run Action Cable in production
# gem 'redis', '~> 3.0'
# Use ActiveModel has_secure_password
# gem 'bcrypt', '~> 3.1.7'

# Use Capistrano for deployment
# gem 'capistrano-rails', group: :development

# Use Rack CORS for handling Cross-Origin Resource Sharing (CORS), making cross-origin AJAX possible
# gem 'rack-cors'

gem 'jbuilder'
gem 'grape'
gem 'grape-jbuilder'
gem 'hashie'

group :development, :test do
  # Call 'byebug' anywhere in the code to stop execution and get a debugger console
  gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
  gem 'hirb'
  gem 'hirb-unicode'
end

group :development do
  gem 'listen', '>= 3.0.5', '< 3.2'
  # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
  gem 'spring'
  gem 'spring-watcher-listen', '~> 2.0.0'
end

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

検索をしてもあまりめぼしいものが見当たらずご教授いただければと思います

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

一応の確認ですが、Gemfileの編集後にbundle installは行いましたでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/03 16:22

    回答ありがとうございます。
    もちろん行なっています!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.46%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby

    9686questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    9088questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。