質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • MySQL

    7006questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • CentOS

    3151questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • CakePHP

    2524questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。

cakephp mysqlが使えないというエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 3,235

navca

score 32

初心者で恐縮ですがよろしくお願いします。

環境 centos7 cakephp3 mysql5.7


追記しました。

出ているエラーはcakephpの
Database driver Cake\Database\Driver\Mysql cannot be used due to a missing PHP extension or unmet dependency
のみです。

windows上でのコマンドの結果は載せておりません。すべてcentos7上での結果です。


現在cakephpのエラーとして↓が出ています。
Database driver Cake\Database\Driver\Mysql cannot be used due to a missing PHP extension or unmet dependency

このエラー文で調べて、https://teratail.com/questions/22662

sudo yum install php56-php-mysqlnd


としましたが、解決できませんでした。(Apache再起動しました。)

mysqlのインストールはこちらの手順で行いました。↓
https://weblabo.oscasierra.net/installing-mysql57-centos7-yum

$ yum list installed | grep mysql
mysql-community-client.x86_64         5.7.19-1.el7                   @mysql57-community
mysql-community-common.x86_64         5.7.19-1.el7                   @mysql57-community
mysql-community-libs.x86_64           5.7.19-1.el7                   @mysql57-community
mysql-community-server.x86_64         5.7.19-1.el7                   @mysql57-community
mysql57-community-release.noarch      el7-10                         @mysql57-community
php56-php-mysqlnd.x86_64              5.6.31-1.el7.remi              @remi-safe


↓こちらも参照しましたが、OSが明示されてないため善し悪しがよくわからないのですが、
php.iniにextension="php_mysql.dll"という記述がありません。
http://www.phpbook.jp/tutorial/mysql/index1.html

又、xammp(自分のです。以前使っていた)のphp.iniを見るとmysql、mysqli、mysqlndといったディレクティブがありますが、centos上のphp.iniにはそれらがありません。

↓も参照しましたが
https://stackoverflow.com/questions/29403450/cakephp-3-is-not-able-to-connect-to-the-database-due-to-a-missing-php-extension

extension = php_intl.dll
extension = php_pdo_mysql.dll
intl.default_locale = en_utf8
intl.error_level = E_WARNING


を追記しても変わらずでした。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • navca

    2017/08/02 23:11

    >coba-cobaさん 回答ありがとうございます。  phpのバージョンは5.6です。 php -mの結果です----->]$ php -m PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_intl.dll' - /usr/lib64/php/modules/php_intl.dll: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_pdo_mysql.dll' - /usr/lib64/php/modules/php_pdo_mysql.dll: cannot open shared object file: No such file or directory in Unknown on line 0 [PHP Modules] bz2 calendar Core ctype curl date dom ereg exif fileinfo filter ftp gd gettext hash iconv intl json libxml mbstring mcrypt mhash openssl pcntl pcre PDO pdo_sqlite Phar readline Reflection session SimpleXML sockets SPL sqlite3 standard tokenizer wddx xml xmlreader xmlwriter xsl zip zlib [Zend Modules]

    キャンセル

  • navca

    2017/08/02 23:12

    phpインストール時のコマンドをhistoryコマンドで確認しました。sudo yum install --enablerepo=remi,remi-php56 php php-devel php-mbstring php-pdo php-gd php-xml php-mcrypt php-intl

    キャンセル

  • hotta

    2017/08/02 23:13

    ここに情報を書くのではなく、問題文を修正してください。

    キャンセル

回答 1

checkベストアンサー

+1

確かにphp -mの結果にmysqlndが入っていませんね。
でも、sudo yum install php56-php-mysqlndは少し違います。

そもそもremi,remi-php56リポジトリには2種類のパッケージが存在します。
PHPのインストールでは、PHPの指定はphpphp56で異なるパスにインストールされます。

navcaさんのPHPインストール時のコマンドはsudo yum install --enablerepo=remi,remi-php56 php php-devel php-mbstring php-pdo php-gd php-xml php-mcrypt php-intlですよね。

今回はPHPのインストール時にphpを指定しているので、mysqlndもそれに合わせてインストールします。
具体的には、yum --enablerepo=remi,remi-php56 install php-mysqlndのようにします。

(蛇足ですが、今からPHPをインストールするなら、特に理由がないならPHP7を使うべきだと思います。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/04 00:06

    回答ありがとうございます。できました!よく考えれば分かりそうなことでした。精進します。phpのバージョンについてはリポジトリの安全性について調べて5.6が妥当かと思ったのですが、7にしてみます。ありがとうございました。

    キャンセル

同じタグがついた質問を見る

  • MySQL

    7006questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

  • CentOS

    3151questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • CakePHP

    2524questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。