質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

tex verbatim エラーについて

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,257

tekondo

score 22

Macでtexshopを使っているのですがverbatimを用いるとエラーが出てきてうまくいきません、改善方法をご存知の方はいらっしゃいますか?メッセージは下の画像のように出てきます。フォントが読み込めないようなことが書かれていると思うのですが設定方法がわからなくて困っています、、、わかる方教えていただければ幸いです。イメージ説明

補足でインストールを行ったのですが設定が2016basicから新しいものに変更できません。どの部分の変更を行えばいいでしょうか?画像の部分を変更すればいいのかなと思うのですが、、よろしければ回答よろしくお願いいたします。
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

こちらに似たような事例が質問されていました: How can I fix the path to LaTeX fonts? 

ところで、MacTeXは2017へアップデートされているので、アップデートしてみてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/07/28 12:03

    事例を見て
    sudo tlmgr update --self --all
    sudo tlmgr install courier
    のコマンドを行なってコンパイルして見たのですが

    This is ptex2pdf[.lua] version 20170622.0.
    Processing procreport2.tex
    This is e-pTeX, Version 3.14159265-p3.7.1-161114-2.6 (utf8.euc) (TeX Live 2017) (preloaded format=platex)
    restricted \write18 enabled.
    ---! /Users/kondoutaisyou/Library/texlive/2016basic/texmf-var/web2c/eptex/platex.fmt made by different executable version
    (Fatal format file error; I'm stymied)
    ptex2pdf processing of procreport2.tex failed.

    のエラーが出てきてコンパイルできません。
    fmtutil –byfmt platex
    なども行なって見たのですがうまくいきません。何かご存知ではないですか?

    キャンセル

  • 2017/07/28 18:53 編集

    アップデートはされているようですが、Texのシステムディレクトリが切り替わっていないので、TeXShopの設定>エンジンから2017バージョンのディレクトリを指定してください。そのあと2016Basicを削除して再度試してみてください。

    キャンセル

  • 2017/07/31 13:32

    編集したので教えていただけると幸いです。

    キャンセル

  • 2017/07/31 14:19 編集

    基本的に質問内容が変わった場合は別途質問たてたほうが良いですよ。まぁ今回はしょうがないですが。。。

    Macなら基本的に異なるバージョンのMacTeXは/usr/local/texlive以下に個別に(2016basic/とか2017basicとかいうふうに)インストールされるので、2017basic/bin/x86_64-darwin/フォルダを指定してください。(どこにインストールされたかはチェックしているはずなので。)

    /Library/TeX/binはどこからへのエイリアスが入っているはずなので、直接パスを入れたほうが良いと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる