質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.48%

docker 上の ubuntu 16.04 に solr 6.1.0 をインストールしたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,350

score 9

前提・実現したいこと

docker 上の ubuntu 16.04 に solr 6.1.0 をインストールしたいのですが、
インストールスクリプトを実行すると以下のエラーメッセージが発生します。

発生している問題・エラーメッセージ

ERROR: Your Linux distribution (Linux version 4.9.27-moby (root@11fbdc1f630f) (gcc version 6.2.1 20160822 (Alpine 6.2.1) ) #1 SMP Thu May 11 04:01:18 UTC 2017) not supported by this script!
You'll need to setup Solr as a service manually using the documentation provided in the Solr Reference Guide.

該当のソースコード

pwd
/root

java -version
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-0ubuntu1.16.04.2-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

wget http://archive.apache.org/dist/lucene/solr/6.1.0/solr-6.1.0.tgz
./solr-6.1.0/bin/install_solr_service.sh solr-6.1.0.tgz

試したこと

root 以外のユーザで試すと、以下のエラーになります。

ERROR: This script must be run as root

補足情報(言語/FW/ツール等のバージョンなど)

  • Docker for Windows です。
cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"

解決法がお分かりになる方、どうかよろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

ERROR: Your Linux distribution (Linux version 4.9.27-moby (root@11fbdc1f630f) (gcc version 6.2.1 20160822 (Alpine 6.2.1) ) #1 SMP Thu May 11 04:01:18 UTC 2017) not supported by this script!
You'll need to setup Solr as a service manually using the documentation provided in the Solr Reference Guide.

この自動セットアップ用のスクリプトは Linux カーネルや動作環境をチェックし、サポート対象の動作環境であれば自動実行できるものようです。

画面に出ているメッセージから、このバージョンのUbuntuイメージでは、自動セットアップはできません。どうしてもこのイメージのバージョンを使う必要があれば、 Solr リファレンス・ガイドのドキュメントを読みながら、手動でせっとアップする必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/22 14:57

    ありがとうございます。返答が遅れて申し訳ございません。
    適切な対処ではないと思いますが,そのチェックの行をコメントアウトしたら
    うまく動作いたしました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.48%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る