質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.61%

wordpressのローカルサイトをサーバに移行出来ない。

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,587

前提・実現したいこと

ローカル環境(windows10)のwordpressで作成したwebサイトをサーバー環境に
移行しようとしていますが、errorが発生して上手く行きません。
ご教授下さい。

移行の方法と手順

移行はphpMyAdminによるエクスポートとインポートを使う方式です。
手順
1.XAMPP Controll PanelのMySQLのAdminから
・phpMyAdmin(バージョン現在は4.7.1 ← 以前の4.2.7.1でも駄目でした)を呼び。
・使用しているデータベース'wp01'を選択し出力されたTable群(12個)を
すべて選択。
・エキスポートに行き、詳細 - 可能なオプションをすべて表示をcheck、
DROP TABLE / VIEW / PROCEDURE / FUNCTION / EVENT / TRIGGER 
コマンドを追加する をcheck それ以外はディフォルトにて実行 → 保存
2.アップロード先のwordpressのwp-config.phpを修正
localのwordpressのwp-config.php
define('DB_NAME', 'wp01');
define('DB_USER', 'root');
define('DB_PASSWORD', 'smartworks');
define('DB_HOST', 'localhost');
define('DB_CHARSET', 'utf8mb4');
define('DB_COLLATE', ''); です。
アップロード先のwordpressのwp-config.php
define('DB_NAME', 'smartworks');
define('DB_USER', 'smartworks');
define('DB_PASSWORD', 'XXXXXXXXXXXX');
define('DB_HOST', 'localhost');
define('DB_CHARSET', 'utf8'); ← 以前は'utf8mb4' でした。
define('DB_COLLATE', ''); 以上です。
3.サーバのコントロールパネル(Value server)から
・サーバーのphpMyAdmin(バージョン4.4.11)にLogin
・使用しているデータベース'smartworks'を選択し出力されたTable群
(11個 ← Localの12個とは異なっている)をすべて選択。
・インポートに行き、アップロードファイルを参照から1.でエクスポートした
ファイルを指定して実行(パラメータ類はディフォルト)します。
4.インポート時にerror発生
エラー
SQL query: 
CREATE TABLE wp_commentmeta (
meta_id bigint(20) UNSIGNED NOT NULL,
comment_id bigint(20) UNSIGNED NOT NULL DEFAULT '0',
meta_key varchar(255) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL,
meta_value longtext COLLATE utf8mb4_unicode_520_ci
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci;
MySQL のメッセージ: ドキュメント 

1273 - Unknown collation: 'utf8mb4_unicode_520_ci'

上記のエラーメッセージが出力されて終わります。

この問題を解除するにはどうしたら良いのでしょう。
ご教授下さい。
1.のエキスポートする時点のデータベースTable群の照合順位の項をみると
すべてがutf8mb4_unicode_520_ciとなっていますが、これを変更する方法が
分りません。

以上


ここに質問したいことを詳細に書いてください
(例)PHP(CakePHP)で●●なシステムを作っています。
■■な機能を実装中に以下のエラーメッセージが発生しました。

発生している問題・エラーメッセージ

エラーメッセージ

該当のソースコード

ここにご自身が実行したソースコードを書いてください

試したこと

課題に対してアプローチしたことを記載してください

補足情報(言語/FW/ツール等のバージョンなど)

より詳細な情報

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • 退会済みユーザー

    2017/06/26 00:03

    複数のユーザーから「やってほしいことだけを記載した丸投げの質問」という意見がありました
    「質問を編集する」ボタンから編集を行い、調査したこと・試したことを記入していただくと、回答が得られやすくなります。

回答 2

+1

開発環境(Windows)と本番環境のMySQLのバージョンが合っているか確認してください。

おそらく本番環境のバージョンが古いものと思われます。アップデートするか、古いバージョンに合わせて開発環境のデータベースの形式を見直してみて下さい。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/25 19:27

    phpMyAdminのバージョンというよりMySQLのバージョンという
    ことでしょうか。その場合にサーバー側の変更をユーザサイドから
    実施するような機能は一般的に備わっているのでしょうか。

    キャンセル

  • 2017/06/25 20:22

    それはサーバーの管理者や、利用しているサービスのサポートに問い合わせて下さい。

    キャンセル

  • 2017/06/28 14:53

    サーバ側もサポート外ということで解決できていません。
    そのような理由で一般的にという質問で申し訳ないのですが、
    サーバ側のバージョンに揃えたローカル側環境の作成は出来るのかの質問
    でした。SQLのサーバ側が5.5.56でローカルが5.6.20なのですが、
    ローカル側を全く同じバージョンが見つからなければ5.5.XXとする
    のが良いのでしょうか。

    キャンセル

  • 2017/06/29 12:14

    はい、古い方(5.5)に合わせましょう。今回は MySQL 5.6 からサポートされた UCA 5.2.0 準拠の照合順序(xxx_unicode_520_ci) を使ったためにエラーとなったため、かったぱしから COLLATE を `xxx_unicode_520_ci` から `xxx_unicode_ci` に書き換えましょう。それでサーバー側でも動くはずです。

    キャンセル

0

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/25 21:53

    対処法をご教授頂きありがとうございます。但し、私の場合はWindowsですのでXAMPPになるのかと思ったのですが、PHP周辺に疎く殆ど周辺も含めて入っていくには相当の勇気が必要です。Windowsの場合のこの種の対処法についてのWebページなどをお教え頂けませんでしょうか。 以上

    キャンセル

  • 2017/06/26 10:51

    そんなのはネットで検索すればいくらでも情報があるので自身で調べてください。

    以上

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る