質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.82%

phpmyadminのインストール

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,531

sea1kiki1

score 10

AWS
Mysql ver7.0
phpMyAdmin install中に以下のようなエラーメッセージがでます。

対処方法をご存知の方がおられましたら回答をお願いいたします。

sudo yum install -y phpMyAdmin

Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main | 2.1 kB 00:00
amzn-updates | 2.3 kB 00:00
1004 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.0.10.19-1.el6 will be installed
--> Processing Dependency: php(language) < 7 for package: phpMyAdmin-4.0.10.19-1.el6.noarch
--> Processing Dependency: php(language) >= 5.2.17 for package: phpMyAdmin-4.0.10.19-1.el6.noarch
****** 略 ******
--> Running transaction check
---> Package php-common.x86_64 0:5.3.29-1.8.amzn1 will be installed
---> Package php-php-gettext.noarch 0:1.0.12-1.el6 will be installed
---> Package php-tcpdf.noarch 0:6.2.13-1.el6 will be installed
--> Processing Dependency: php-tidy for package: php-tcpdf-6.2.13-1.el6.noarch
--> Processing Dependency: php-posix for package: php-tcpdf-6.2.13-1.el6.noarch
****** 略 ******
--> Processing Conflict: php56-common-5.6.30-1.133.amzn1.x86_64 conflicts php-common < 5.5.22-1.98
--> Finished Dependency Resolution
Error: php70-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-process conflicts with php-process-5.3.29-1.8.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

エラーログとして、

Error: php70-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php56-process conflicts with php-process-5.3.29-1.8.amzn1.x86_64

が出力されておりますので、

「phpMyAdminをインストールする上でphp70-common, php56-commonなどのパッケージをPHPとしてインストールしようと試みたものの、すでにPHPはphp-common-5.3がインストールされているので、パッケージに競合が発生した」ということを意味しています。

これを回避するためには、一度PHPをアンインストールする方が良いでしょう。

$ sudo yum remove php

もし、何か理由があってアンインストールできない場合はコメントをお寄せください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/06 18:32

    ありがとうございます

    キャンセル

0

Amazon Linux に EPEL リポジトリの phpMyAdmin をインストールしようとしているのですね。

--> Processing Dependency: php(language) < 7 for package: phpMyAdmin-4.0.10.19-1.el6.noarch
--> Processing Dependency: php(language) >= 5.2.17 for package: phpMyAdmin-4.0.10.19-1.el6.noarch

上記のとおり、EPEL で提供されている phpMyAdmin-4.0.10.19-1.el6.noarch は php-7.0 では動作しないようです。
もし、php-7.0 で動かしたいのであれば、https://www.phpmyadmin.net/ から php-7.0 に対応したバージョンをインストールするといいと思います。

(参考)
Amazon Linux では、php (5.3.29), php54 (5.4.45), php55 (5.5.38), php56 (5.6.30), php70 (7.0.16) と複数のバージョンが提供されていますが、EPEL で提供されている phpMyAdmin が Amazon Linux 用に作られていないため、うまく依存関係を解決できないようです。

php-5.6 であれば、以下の方法で EPEL の phpMyAdmin をインストールすることができました。

  1. /etc/yum.conf に以下を設定
exclude=php-common php-bcmath php-cli php-process php-tidy
  1. yum --enablerepo=epel install phpMyAdmin
  2. alternatives --config php で /usr/bin/php-5.6 を選択

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.82%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る