質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

CentOS 6でBIND9のconfigureで undefined reference to `pthread_yield_np' が出る

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 917

ksakurai

score 11

現在、CentOS6でDNSサーバーのセットアップを行っています。

BIND9とOpenSSLをビルドしているのですが、
BIND9のconfigureを実行すると、失敗してしまい、下記のエラーが出ます。

checking for OpenSSL library... using OpenSSL from /usr/local/ssl/lib and /usr/local/ssl/include
checking whether linking with OpenSSL works... no
configure: error: Could not run test program using OpenSSL from
/usr/local/ssl/lib and /usr/local/ssl/include.
Please check the argument to --with-openssl and your
shared library configuration (e.g., LD_LIBRARY_PATH).

また、こちらがconfig.log内のエラー箇所です。
■config.logのエラー

configure:15488: checking for pthread_yield_np
configure:15488: gcc -o conftest -g -O2  -D_GNU_SOURCE  conftest.c -lpthread  >&5
/tmp/ccxYcOZo.o: In function `main':
/usr/local/src/bind-9.10.5/conftest.c:88: undefined reference to `pthread_yield_np'
collect2: error: ld returned 1 exit status
configure:15488: $? = 1

pthread_yield_np()が参照できないというエラー内容なのは理解できたのですが、
どのように対処したら良いか検討がつかない状態です。

以下は、BIND9とOpenSSLのバージョンとビルドの手順になります。

■openssl
・openssl-1.0.2l

# cd /usr/local/src
# wget http://www.openssl.org/source/openssl-1.0.2l.tar.gz
# tar xzvf openssl-1.0.2l.tar.gz
# cd openssl-1.0.2l
# ./config shared zlib
# make
# porg -lD "make install"
# mv /usr/bin/openssl /usr/bin/openssl.bak
# ln -s /usr/local/ssl/bin/openssl /usr/bin/openss


■BIND9(2バージョンで検証)
・bind-9.10.5
・bind-9-10-4-p8

./configure -enable-threads -with-openssl=/usr/local/ssl

エラーのが起きる原因と対策について、
何かご存知の方がいらっしゃいましたら、教えていただけますと幸いです。

何卒宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

yum install openssl-devel
を実行することで解決できました。
ご覧になって頂きありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる