質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

rbenvでのrubyインストールに失敗する(vagrant)

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 3,232

dare

score 27

vagrantでrubyの環境を構築しています。
rubyの2.4.0をインストールしようとrbenvコマンドを打ったのですが、結果がBUILD FAILEDとなり、インストールに失敗します。
※インストールに必要とされるライブラリについては概ね追加しています。

[vagrant@localhost ~]$ rbenv install 2.4.0
Downloading ruby-2.4.0.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.4/ruby-2.4.0.tar.bz2
error: failed to download ruby-2.4.0.tar.bz2

BUILD FAILED (CentOS Linux 7 using ruby-build 20170405-6-gc7a4f34)

以下のログからはプロコトルのバージョンが古くてインストールできないと記載されている様ですが、どのように対策を取ればいいのでしょうか?

/tmp/ruby-build.20170521154627.4432 ~
curl: (35) Peer reports incompatible or unsupported protocol version.


よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

こんにちは。
仮想環境はcentosですよね。
curlコマンドで直にダウンロード元のurlを叩くとどうなるでしょうか。
もし可能でしたら、yum updateでcurlのバージョンもあげてみてください。
また、wgetコマンドが入っていたら、そちらからもurlをたたいてみると如何でしょう。
どちらもダメならプロキシ環境下でないかもチェックしてみてくださいね。

[追記]
たまたまcurlをアップデートしていただいた形でダウンロードできるようになりましたが、おそらくCentOS7がデフォルトの状態だったか、そんなにパッケージの追加や更新がされていなかった状態でしょうか?
curlの動作に関連するライブラリに、脆弱性を含むバージョンが存在していたため、通信が拒否されたのかな?とも思います。もし仮想環境がセットアップ直後でしたら、その他のパッケージの脆弱性対応がリリースされていたりするので、アップデートもしておくと良いと思います。

※curlのバージョンが新しくてもダメだった場合、NSS error が出ていたら yum update nss nss-util nsprで対応で大丈夫と思います。詳しい方ご指摘コメントいただけると幸いです

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/22 10:06

    ありがとうございます。

    yum update で一発解決しました。
    通信系の問題かと思い込んでいましたので、update自体を選択肢として考えていませんでした。
    バージョンが古かっただけだとは・・。

    キャンセル

  • 2017/05/22 12:59

    インストールできたとのことで、何よりです。
    思い当たる理由を添えておきました。

    キャンセル

0

以前似たようなことが私にも起き、ネットで調べたコマンドで解決できました。

sudo apt-get install libffi-dev

で確認してみてください。
お役に立てば幸いです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/22 09:39

    ありがとうございます。
    sudo yum install -y libffi libffi-devel
    でインストールしてみましたが、既にインストール済みでした。

    キャンセル

0

rbenv install -l
で出てくるリストに2.4.0はありますか?
もしかしたらインストールできる候補にないのかもしれません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/22 09:26

    ありがとうございます。
    rbenv install -l
    の一覧には 2.4.0が入っています。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る