質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Ruby on Rails

    6987questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    318questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

5.1.0でjQueryが使いたい

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 4,380

rails 5.1.0でjQueryが使いたい

jQueryを動かしたいが、なぜか動かない
jQueryの依存がなくなったと思って、そもそも導入しないでしようしても
<script>...</script>の内容が反応しない

エラーコードがでる

couldn't find file 'jquery' with type 'application/javascript'
Checked in these paths: 
  /Users/Arthur-Lawrence/Downloads/Ruby on rails /PetsHug/app/assets/config
  /Users/Arthur-Lawrence/Downloads/Ruby on rails /PetsHug/app/assets/images
  /Users/Arthur-Lawrence/Downloads/Ruby on rails /PetsHug/app/assets/javascripts
  /Users/Arthur-Lawrence/Downloads/Ruby on rails /PetsHug/app/assets/stylesheets
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/jquery-turbolinks-2.1.0/vendor/assets/javascripts
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/coffee-rails-4.2.1/lib/assets/javascripts
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/actioncable-5.1.1/lib/assets/compiled
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/actionview-5.1.1/lib/assets/compiled
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/turbolinks-source-5.0.3/lib/assets/javascripts
  /Users/Arthur-Lawrence/Downloads/Ruby on rails /PetsHug/node_modules
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/assets/stylesheets
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/assets/javascripts
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/assets/fonts
  /Users/Arthur-Lawrence/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/assets/images


//

//= require jquery   左の部分が赤く表示される
//= require jquery_ujs
//= require_self
//= require rails-ujs

該当のソースコード

$(function(){
  $(".navbar").removeClass("navbar-devise");
  $(".navbar").addClass("navbar-default");
});

が動作しない

試したこと

検索ワード
ruby on rails javascriptが動かない
ruby on rails <script>が動かない
Ruby on rails ページ内でjavascriptを使用する
couldn't find file 'jquery' with type 'application/javascript’
rails javascriptでクラスを書き換える
ruby on rails5 jQuery 設定
//=require jquery エラー
Ruby on rails javascriptを使う

うまくいったように思えても、jQueryがうごきません

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+2

プロジェクトのGemfileにgem 'jquery-rails'を追加してみましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/17 21:52

    すいません、この回答を見る前に試行錯誤していたら、バグを潰せていました。ご協力ありがとうございました。結果的にjquery-railsもダウンロードしていたので、同じ結論に至れてよかったです。

    キャンセル

check解決した方法

+1

gem 'jquery-rails'
gem 'jquery-ui-rails'

を導入して、

application.jsを
//= require rails-ujs
//=require jquery
//= bootstrap-sprockets
//= require toastr
//=require jquery_ujs
//= require turbolinks
//=require_tree .

の順番に書き直したら、解決しました。
しかし、なぜかdropdownメニューが動きません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    6987questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    318questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。