質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • PHP

    20401questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CentOS

    2716questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • nginx

    843questions

    nginixは軽量で高性能なwebサーバーの1つです。BSD-likeライセンスのもとリリースされており、あわせてHTTPサーバ、リバースプロキシ、メールプロキシの機能も備えています。MacOSX、Windows、Linux、上で動作します。

CentOS7+phpenv+nginxで古いPHPを使いたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 369

Point

score 6

現在Docker環境にて
CentOS+phpenv+nginxでPHPのバージョン管理が可能な環境を
作る為に勉強中です。

勉強中の為、質問内容に不十分な点が多いかと思いますが、どうぞよろしくお願いいたします。

$phpenv install 7.0.7
$~/.phpenv/versions/7.0.7/sbin/php-fpm


上記のバージョンをインストールし7.0.7のphp-fpmを起動
phpinfo()で確認した所、問題なく動作を確認。

$phpenv install 5.2.17
    [Success]: Built 5.2.17 successfully.
$phpenv rehash
$phpenv global 5.2.17
$php -v
    PHP 5.2.17 (cli) (built: Apr 16 2017 09:51:31)


phpenvでのphpバージョンの切り替えは正常できており
php -vで5.2.17への変更を確認済み。

問題は下記2点です

問題① 7.0.7の時のように5.2.17のphp-fpm起動方法が分からない

7.0.7の時のように5.2.17にはsbinディレクトリが存在せず
php-fpmを起動する方法が分かりません。
その為、切り替えも出来るか分からない状態です。

問題② systemctlでphp-fpmの起動が出来ない

またphp-fpmの起動・再起動をsystemctlで行いたいので
/etc/systemd/system/php-fpm.service 
を作成し
systemctl start php-fpm
を実行しましたが下記エラーとなります。

Failed to start php-fpm.service: Unit is not loaded properly: Invalid argument.
See system logs and 'systemctl status php-fpm.service' for details.


php-fpm.service

[Unit]
Description=The PHP FastCGI Process Manager
After=syslog.target network.target

[Service]
Type=simple
PIDFile=/run/php-fpm.pid
ExecStart=~/.phpenv/versions/7.0.7/sbin/php-fpm --nodaemonize --fpm-config ~/.phpenv/versions/7.0.7/etc/php-fpm.conf
ExecReload=/bin/kill -USR2 $MAINPID

[Install]
WantedBy=multi-user.target

それではよろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

残念ながら、PHP-FPMがPHP本体に取り込まれたのはPHP 5.3以降で、PHP 5.2はソースにパッチを当てて作る必要がある、とのことです(PHP-FPMのサイト)。

…というより、いまからサーバを立ち上げるに当たってPHP 5.2を使う、という選択自体、あまりやるべきではないと思います。とっくにサポートも切れています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/04/16 22:42

    ご回答ありがとうございます。
    情報ありがとうございます。パッチを当てるのを試してみたいと思います!

    選択肢に使うべきではないのは重々承知なのですが
    どうも古いサーバーで作業する事が多く、PHPが動かない等の症状に悩まされるので
    手軽に試せる環境があったら良いなと思い勉強をし始めた次第です。

    パッチの事で、また躓きましたら再度質問を立てる事となると思いますが
    その際はまたよろしくお願い致します!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • PHP

    20401questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CentOS

    2716questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • nginx

    843questions

    nginixは軽量で高性能なwebサーバーの1つです。BSD-likeライセンスのもとリリースされており、あわせてHTTPサーバ、リバースプロキシ、メールプロキシの機能も備えています。MacOSX、Windows、Linux、上で動作します。