質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.35%

  • ネットワーク

    558questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

2つのVLANを持つL3SWをインターネットに接続する方法について

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,286

ryogaelbtn

score 34

前提・実現したいこと

Catalyst 3560-CX 12PC-Sで以下のようなネットワークを組みたい。

  • gi0/1-6はVLAN10、gi0/7-12はVLAN20
  • VLAN10のI/Fは192.168.10.1/24
  • VLAN20のI/Fは192.168.20.1/24
  • L3SWに接続するPCは、すべてstaticでIPアドレスを設定する。
  • gi0/1-12に接続されるPCからインターネットを見れるようにする。

現状

接続状況

  • gi0/5とサーバ1が接続されていて、192.168.10.10/24に設定してある。
  • gi0/12とサーバ2が接続されていて、192.168.20.20/24に設定してある。
  • gi0/14にDHCP機能を持つルータに接続している。192.168.0.3/24が割り当てられている。

show runの内容

Building configuration...

Current configuration : 1617 bytes
!
! Last configuration change at 23:56:48 UTC Wed Mar 29 2017
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
! 
!
!
!
!
!
!
!
!
interface GigabitEthernet0/1
 switchport access vlan 10
!
interface GigabitEthernet0/2
 switchport access vlan 10
!
interface GigabitEthernet0/3
 switchport access vlan 10
!
interface GigabitEthernet0/4
 switchport access vlan 10
!
interface GigabitEthernet0/5
 switchport access vlan 10
!
interface GigabitEthernet0/6
 switchport access vlan 10
!
interface GigabitEthernet0/7
 switchport access vlan 20
!
interface GigabitEthernet0/8
 switchport access vlan 20
!
interface GigabitEthernet0/9
 switchport access vlan 20
!
interface GigabitEthernet0/10
 switchport access vlan 20
!
interface GigabitEthernet0/11
 switchport access vlan 20
!
interface GigabitEthernet0/12
 switchport access vlan 20
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
 no switchport
 ip address dhcp
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 dhcp
!
!         
!
!
line con 0
line vty 5 15
!
!
end

確認できていること

  • Catalystから192.168.10.10, 192.168.20.20, 192.168.0.1とgi0/14の先につながる10.7.1.2にアクセスができている
  • サーバー1とサーバー2はVLANをまたいでpingが通っている

発生している問題・エラーメッセージ

  • サーバー1,2から192.168.0.1へpingが通らなく、インターネットを見ることができない。

試したこと

  • Catalystからtracerouteすると、192.168.0.1経由で10.7.1.2にアクセスしている。
  • サーバー1からtracerouteすると、192.168.10.1までは経路が確認できるが、その先は経路が不明(*の表示)になっている。

追加で行ったこと

回答を受け、少し変更した部分があるので、追記します。

no ip route 0.0.0.0 0.0.0.0 dhcp
ip route 0.0.0.0 0.0.0.0 [Router IP]

ここではRouter IPは、192.168.0.1としています。

Catalystから10.7.1.2、及び192.168.0.1へはpingが通るが、gi0/1-12に接続されているPCからは、引き続きこれらへのIPアドレスへのpingは通らない。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

CatalystはISP接続を担っているのでしょうか?
そうでなければ、スタティックルートの設定がおかしいです。

ip route 0.0.0.0 0.0.0.0 dhcp

上記をISP接続ルータ宛にするのが正解です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/03/30 09:36

    gi0/1-12に接続されるPCからインターネットに接続できるようにしたい。
    gi0/14にはDHCPでIPアドレスが割り当てられ、かつインターネットにつながるLANに接続してある。

    上のような状況のときにはどうしたらいいんでしょうか?
    ip route 0.0.0.0 0.0.0.0 gi0/14でいいのでしょうか?

    キャンセル

  • 2017/03/30 09:48

    まず、ISP接続ルータがありインターネットに接続できる環境でしょうか?
    gi0/14 に接続されているDHCP機能を持った機器がISP接続ルータですか?
    そうであれば、以下の設定が不足しています。

    1) ISP接続ルータとの接続インターフェース
    以下としているようですが、専用のVLANを作成の上、固定IPにする必要があります。
    interface GigabitEthernet0/14
    no switchport
    ip address dhcp

    2) スタティックルートの設定
    ip route 0.0.0.0 192.168.0.3

    3)ISP接続ルータ スタティックルートの設定
    ISP接続ルータにもスタティックルートを設定してあげる必要があります。
    機器がわからないので概念だけ以下に示します。
    192.168.10.1 255.255.255.0 → 1) で作成したVLANインターフェースに割り当てたIP
    192.168.20.1 255.255.255.0 → 1) で作成したVLANインターフェースに割り当てたIP

    4)DHCPリレーの設定
    192.168.10.0、192.168.20.0はDHCP管理にならないのであれば良いですが、こちらのセグメントもDHCP管理とするのであればDHCPリレーエージェントの設定も必要になります。

    キャンセル

  • 2017/03/30 09:56

    なるほどです。
    上位のルータにstaticでルーティングを設定してやる必要があるのですね。
    解決しました。

    キャンセル

同じタグがついた質問を見る

  • ネットワーク

    558questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。