質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.50%

Rails  json -v '1.8.2'のインストールについて

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 14K+

score 11

An error occurred while installing json (1.8.2), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.2'` succeeds before bundling.
現在、ネット上のRails入門サイトをみてRailsの学習をしているのですが上記のエラーが出ます。
解決の仕方を教えてください!お願いします!
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

0

ruby, rails, gem それぞれバージョンは幾つですか?
ruby -v
rails -v
gem -v
また、どのような操作をして、エラーが出ましたか??

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/02/25 01:22

    上記の内容を貼り付けてGemfileを作っての bundle install は...成功。
    バージョン指定してのjsonインストールも...成功。

    % gem install json -v '1.8.2'
    Building native extensions. This could take a while...
    Successfully installed json-1.8.2
    1 gem installed

    % gem list | grep json
    json (1.8.2, 1.8.1)
    multi_json (1.10.1)

    …何だろな?

    キャンセル

  • 2015/02/25 01:27

    gemのヴァージョンが新しいのが、何となく気になる。
    ちなみに自分は、ruby2.2 インストールで gem2.4.5 が付属、ruby2.1.4 インストールで gem2.2.2が付属 。いづれも正常に動いている。

    といぅ事わ「gem本体のバージョンを下げてみる。」

    ruby一式を再インストールする、もしくは gem を入れ替えるなどはどうでしょう?
    後者は多分下みたいなコマンド。

    gem update --system <version>

    キャンセル

  • 2015/02/25 16:06

    gemのバージョン2.1.0に下げたらインストールされました!
    いろいろと教えていただきありがとうございました!
    すごく助かりました!

    キャンセル

0

bundle update 
としてみては?

それでもだめな場合は、 Gemfile, Gemfile.lock を見てみたいです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/02/25 00:33

    ご回答ありがとうございます!
    bundle updateとやってみたのですがダメでした。

    Gemfileのないようです!

    source 'https://rubygems.org&#039;


    # Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
    gem 'rails', '4.1.1'
    # Use sqlite3 as the database for Active Record
    gem 'sqlite3'
    # Use SCSS for stylesheets
    gem 'sass-rails', '~> 4.0.3'
    # Use Uglifier as compressor for JavaScript assets
    gem 'uglifier', '>= 1.3.0'
    # Use CoffeeScript for .js.coffee assets and views
    gem 'coffee-rails', '~> 4.0.0'
    # See https://github.com/sstephenson/execjs#readme for more supported runtimes
    # gem 'therubyracer', platforms: :ruby

    # Use jquery as the JavaScript library
    gem 'jquery-rails'
    # Turbolinks makes following links in your web application faster. Read more: https://github.com/rails/turbolinks
    gem 'turbolinks'
    # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
    gem 'jbuilder', '~> 2.0'
    # bundle exec rake doc:rails generates the API under doc/api.
    gem 'sdoc', '~> 0.4.0', group: :doc

    # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
    gem 'spring', group: :development

    # Use ActiveModel has_secure_password
    # gem 'bcrypt', '~> 3.1.7'

    # Use unicorn as the app server
    # gem 'unicorn'

    # Use Capistrano for deployment
    # gem 'capistrano-rails', group: :development

    # Use debugger
    # gem 'debugger', group: [:development, :test]

    キャンセル

0

遅レス失礼します。
環境はもしかしてWindowsでVagrantでしょうか。その場合、共有フォルダにbundlerで特定の(Native Extentionな)gemをいれようとするとエラーになることがあるようです。
その場合、

bundle install --path vendor/bundle 

ではなく

bundle install --path ~/プロジェクト名/vendor/bundle 

のようにすると回避できます。

参考)Vagrant環境でのbundle installで失敗する https://tamosblog.wordpress.com/2015/02/22/bundle-install_on_vagrant/

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る