質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.76%

  • Ruby

    4627questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    4432questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Railsの全てのコマンドでsprockets-3.7.1のcan't dup NilClassエラーが出る

解決済

回答 1

投稿 2017/02/18 02:22 ・編集 2017/02/19 22:18

  • 評価
  • クリップ 0
  • VIEW 468

ken0625

score 31

railsでbundle install までした後にrails generateやrails s を実行したのですが、全て
[ルートdirectory]/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/utils.rb:40:in `dup': can't dup NilClass (TypeError)

のエラーで止まってしまい実行できません。

rubyは2.4.0-devで railsは5.0.1です

Gemfileは以下です

source 'https://rubygems.org'

gem 'rails',        '5.0.1'
gem 'puma',         '3.4.0'
gem 'sass-rails',   '5.0.6'
gem 'uglifier',     '3.0.0'
gem 'coffee-rails', '4.2.1'
gem 'jquery-rails', '4.1.1'
gem 'turbolinks',   '5.0.1'
gem 'jbuilder',     '2.4.1'

group :development, :test do
  gem 'sqlite3', '1.3.11'
  gem 'byebug',  '9.0.0', platform: :mri
end

group :development do
  gem 'web-console',           '3.1.1'
  gem 'listen',                '3.0.8'
  gem 'spring',                '1.7.2'
  gem 'spring-watcher-listen', '2.0.0'
end

group :test do
  gem 'rails-controller-testing', '0.1.1'
  gem 'minitest-reporters',       '1.1.9'
  gem 'guard',                    '2.13.0'
  gem 'guard-minitest',           '2.4.4'
end

group :production do
  gem 'pg', '0.18.4'
end
rails s
/Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/activesupport-5.0.1/lib/active_support/xml_mini.rb:51: warning: constant ::Fixnum is deprecated
/Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/activesupport-5.0.1/lib/active_support/xml_mini.rb:52: warning: constant ::Bignum is deprecated
/Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/utils.rb:40:in `dup': can't dup NilClass (TypeError)
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/utils.rb:40:in `hash_reassoc1'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/utils.rb:65:in `hash_reassoc'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/transformers.rb:142:in `compute_transformers!'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processing.rb:216:in `register_config_processor'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets/processing.rb:51:in `register_preprocessor'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets.rb:97:in `<module:Sprockets>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-3.7.1/lib/sprockets.rb:9:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-rails-3.2.0/lib/sprockets/railtie.rb:6:in `require'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/sprockets-rails-3.2.0/lib/sprockets/railtie.rb:6:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/all.rb:14:in `require'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/all.rb:14:in `block in <top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/all.rb:12:in `each'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/all.rb:12:in `<top (required)>'
    from /Users/sonekenichiro/development/ghiiko/test_app/config/application.rb:3:in `require'
    from /Users/sonekenichiro/development/ghiiko/test_app/config/application.rb:3:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands/commands_tasks.rb:88:in `require'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands/commands_tasks.rb:88:in `block in server'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands/commands_tasks.rb:85:in `tap'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands/commands_tasks.rb:85:in `server'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands/commands_tasks.rb:49:in `run_command!'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/railties-5.0.1/lib/rails/commands.rb:18:in `<top (required)>'
    from /Users/sonekenichiro/development/ghiiko/test_app/bin/rails:9:in `require'
    from /Users/sonekenichiro/development/ghiiko/test_app/bin/rails:9:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `load'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `call'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/client/command.rb:7:in `call'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/client.rb:30:in `run'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/bin/spring:49:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `load'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/gems/2.4.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `<top (required)>'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /Users/sonekenichiro/.rbenv/versions/2.4.0-dev/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /Users/sonekenichiro/development/ghiiko/test_app/bin/spring:15:in `<top (required)>'
    from /Users/sonekenichiro/development/ghiiko/test_app/bin/rails:3:in `load'
    from /Users/sonekenichiro/development/ghiiko/test_app/bin/rails:3:in `<main>'

何が原因でしょうか?

追記
rake assets::precompileをしても全く同じエラーが出ます...
これはなんのコマンドでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • moke

    2017/02/18 08:51 編集

    rake assets::precompileをしましたか?

    キャンセル

回答 1

checkベストアンサー

0

sprocket はjavascriptやstilesheetをまとめて管理し読み込みのラグを少なくするシステムの一部です。
それを明示的に行うのがrake assets::precompileなのです。(正確ではないですが一応の理解でOK)

本家のコードを見てきました
どうやらバグのようです。
sprocketsを4.0.0bata1以上にするか
rubyのversionを2.3に下げてください。

rubyは後方互換性よりもプログラマの生産性を重視する意欲的なアップデートを行います。
なので、各ライブラリのアップデードが間に合わない場合があります。
これはrubyに限らず一般的に言えることなのですが。
初心者のうちは、よっぽど使いたい機能がない限り、安定してくるまで、最新のものより一つ前のヴァージョンを利用することをお勧めします。

投稿 2017/02/20 14:25

編集 2017/02/20 14:30

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

  • 2017/02/20 15:19

    詳しい解説ありがとうございます!
    逆にsprocketsのバージョンを3.6.0まで下げたら動きました!
    rackというライブラリとのバージョン互換性に問題があるみたい?
    というのがわかって下げてみたら動いたのですがrubyに問題があったんですね。

    バージョンには気をつけます。ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.76%

関連した質問

同じタグがついた質問を見る

  • Ruby

    4627questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    4432questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。