質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • AWS(Amazon Web Services)

    2162questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Bugzilla

    5questions

    Bugzillaは、Mozilla Foundationが開発・使用してきたWebベースのバグトラッキングシステムです。汎用性が高く、検索機能や統計機能、複数プロジェクト対応など多くの機能を持ちます。

Amazon Linux AMI release 2016.09 にBugzillaの設定

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 478

hyskyo

score 68

Amazon Linux AMI release 2016.09環境にてBugzillaを入れたくてインストール中に下記で確認しょうとうるとそのファイルないとか怒られたり、
最初からできるまでの方法を知っていれば教えてくださいませ、
ネットではたくさん調べたができません。

./checksetup.pl
-bash: ./checksetup.pl: No such file or directory

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

perlモジュールのinstallにcpanmでhttp://bugzilla.readthedocs.io/en/latest/installing/linux.htmlを参考にして
できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

https://bugzilla.readthedocs.io/en/latest/installing/linux.html

このページに従ってやると、細かい手順は抜けています。
私はtarballをダウンロードして ./checksetup.pl を実行してみましたが、以下のような感じです。

tar zxf bugzilla-5.0.3.tar.gz
cd bugzilla-5.0.3
./checksetup.pl

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/02/17 16:09

    下記のエラーで進めません、

    ```
    [root@ip-000000000 bugzilla-4.4]# /usr/bin/perl install-module.pl --all
    Checking for CPAN (v1.81) ok: found v1.98
    Checking for YAML (any) ok: found v1.22
    Checking for ExtUtils-MakeMaker (v6.31) ok: found v7.24
    Reading '/root/.cpan/Metadata'
    Database was generated on Fri, 17 Feb 2017 04:53:58 GMT
    Installing GD version 2.56...
    Running install for module 'GD'
    Running make for L/LD/LDS/GD-2.56.tar.gz
    Checksum for /root/.cpan/source/authors/id/L/LD/LDS/GD-2.56.tar.gz ok
    Uncompressed /root/.cpan/source/authors/id/L/LD/LDS/GD-2.56.tar.gz successfully
    Using Tar:/bin/tar xf "GD-2.56.tar":
    Couldn't untar GD-2.56.tar
    Package seems to come without Makefile.PL.
    (The test -f "/root/.cpan/build/LDS-2Rf9og/Makefile.PL" returned false.)
    Writing one on our own (setting NAME to GD)
    Had problems unarchiving. Please build manually
    Skipping test because of notest pragma
    Running make install
    Make had some problems, won't install
    Installing Chart::Lines version 2.004010...
    Chart::Lines is up to date (2.4.10).
    Installing Template::Plugin::GD::Image version 1.56...
    Template::Plugin::GD::Image is up to date (1.56).
    Installing GD::Text version 0.86...
    GD::Text is up to date (0.86).
    Installing GD::Graph version 1.54...
    GD::Graph is up to date (1.54).
    Installing XML::Twig version 3.52...
    XML::Twig is up to date (3.52).
    Installing Net::SMTP::SSL version 1.04...
    Net::SMTP::SSL is up to date (1.04).
    Installing Encode::Detect version 1.01...
    Running install for module 'Encode::Detect'
    Running make for J/JG/JGMYERS/Encode-Detect-1.01.tar.gz
    Checksum for /root/.cpan/source/authors/id/J/JG/JGMYERS/Encode-Detect-1.01.tar.gz ok
    Uncompressed /root/.cpan/source/authors/id/J/JG/JGMYERS/Encode-Detect-1.01.tar.gz successfully
    Using Tar:/bin/tar xf "Encode-Detect-1.01.tar":
    Couldn't untar Encode-Detect-1.01.tar
    Package seems to come without Makefile.PL.
    (The test -f "/root/.cpan/build/JGMYERS-sw3qJD/Makefile.PL" returned false.)
    Writing one on our own (setting NAME to EncodeDetect)
    Had problems unarchiving. Please build manually
    Skipping test because of notest pragma
    Running make install
    Make had some problems, won't install
    Installing Apache2::SizeLimit version 0.96...
    Running install for module 'Apache2::SizeLimit'
    Running make for P/PH/PHRED/Apache-SizeLimit-0.96.tar.gz
    Checksum for /root/.cpan/source/authors/id/P/PH/PHRED/Apache-SizeLimit-0.96.tar.gz ok
    Uncompressed /root/.cpan/source/authors/id/P/PH/PHRED/Apache-SizeLimit-0.96.tar.gz successfully
    Using Tar:/bin/tar xf "Apache-SizeLimit-0.96.tar":
    Couldn't untar Apache-SizeLimit-0.96.tar
    Package seems to come without Makefile.PL.
    (The test -f "/root/.cpan/build/PHRED-Ok4KMc/Makefile.PL" returned false.)
    Writing one on our own (setting NAME to Apache2SizeLimit)
    Had problems unarchiving. Please build manually
    Skipping test because of notest pragma
    Running make install
    Make had some problems, won't install
    Installing DBD::SQLite version 1.54...
    Running install for module 'DBD::SQLite'
    Running make for I/IS/ISHIGAKI/DBD-SQLite-1.54.tar.gz
    Checksum for /root/.cpan/source/authors/id/I/IS/ISHIGAKI/DBD-SQLite-1.54.tar.gz ok
    Uncompressed /root/.cpan/source/authors/id/I/IS/ISHIGAKI/DBD-SQLite-1.54.tar.gz successfully
    Using Tar:/bin/tar xf "DBD-SQLite-1.54.tar":
    Couldn't untar DBD-SQLite-1.54.tar
    Package seems to come without Makefile.PL.
    (The test -f "/root/.cpan/build/ISHIGAKI-MCThqG/Makefile.PL" returned false.)
    Writing one on our own (setting NAME to DBDSQLite)
    Had problems unarchiving. Please build manually
    Skipping test because of notest pragma
    Running make install
    Make had some problems, won't install
    [root@ip-0000000000 bugzilla-4.4]#
    ```

    キャンセル

  • 2017/02/17 19:04

    untarが失敗する事象が私の環境でも出ました。

    perl -MCPAN -e "install 'Bundle::CPAN'"
    してあげてから
    perl install-module.pl --all
    すれば取り敢えず先にすすめました。
    がんばってください!

    キャンセル

  • 2017/02/20 21:21

    できるいい方法ないんですかね!!

    キャンセル

  • 2017/02/21 11:40

    頑張ってここまできました。
    これはどういう意味ですか?何を編集すればいいですか?
    ```
    Reading ./localconfig...

    This version of Bugzilla contains some variables that you may want to
    change and adapt to your local settings. The following variables are
    new to ./localconfig since you last ran checksetup.pl:

    create_htaccess, webservergroup, use_suexec, db_driver, db_host,
    db_name, db_user, db_pass, db_port, db_sock, db_check, index_html,
    cvsbin, interdiffbin, diffpath, site_wide_secret

    Please edit the file ./localconfig and then re-run checksetup.pl
    to complete your installation.
    ```

    キャンセル

  • 2017/02/21 11:56

    なんと、頑張ってできました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • AWS(Amazon Web Services)

    2162questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Bugzilla

    5questions

    Bugzillaは、Mozilla Foundationが開発・使用してきたWebベースのバグトラッキングシステムです。汎用性が高く、検索機能や統計機能、複数プロジェクト対応など多くの機能を持ちます。