質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Ruby on Rails

    7238questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2433questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

railsなのにjavaと出てくる

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 1,810

sunagakannta

score 13

やろうとしていること

現在soliduを使ってecサイトの勉強をしています。

教えて欲しいこと

bundle exec rails g spree:install --migrate=false --sample=false --seed=false


このコマンドを実行したいのですが、実行すると、

Could not locate Gemfile or .bundle/ directory


このように表示されてしまいます。これを解決したいです。
gemファイルは存在しています。

rails new 

した時にこのようなメッセージが表示されます。
これが原因と考えているのですが、どうすれば対処できるでしょうか?

The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.

やってみたこと

bundle install,bundle update, gem installを演ってみましたがだめでした。

ご教授お願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

以下は実施しましたか?

bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/02/17 08:19

    実行しまいしましたら、
    このようなエラーが表示されます

    Bundler could not find compatible versions for gem "i18n":
    In snapshot (Gemfile.lock):
    i18n (= 0.8.0)

    In Gemfile:
    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    activemerchant (~> 1.48.0) x86-mswin32 was resolved to 1.48.0, which depends on
    i18n (>= 0.6.9)

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    activemerchant (~> 1.48.0) x86-mswin32 was resolved to 1.48.0, which depends on
    i18n (>= 0.6.9) x86-mingw32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    activemerchant (~> 1.48.0) x86-mswin32 was resolved to 1.48.0, which depends on
    i18n (>= 0.6.9) x86-mswin32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    activemerchant (~> 1.48.0) x86-mswin32 was resolved to 1.48.0, which depends on
    i18n (>= 0.6.9) x64-mingw32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    activemerchant (~> 1.48.0) x86-mswin32 was resolved to 1.48.0, which depends on
    i18n (>= 0.6.9) java

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    monetize (~> 1.1) was resolved to 1.1.0, which depends on
    money (~> 6.5.0) was resolved to 6.5.0, which depends on
    i18n (<= 0.7.0, >= 0.6.4) java

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    monetize (~> 1.1) was resolved to 1.1.0, which depends on
    money (~> 6.5.0) was resolved to 6.5.0, which depends on
    i18n (<= 0.7.0, >= 0.6.4)

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    monetize (~> 1.1) was resolved to 1.1.0, which depends on
    money (~> 6.5.0) was resolved to 6.5.0, which depends on
    i18n (<= 0.7.0, >= 0.6.4) x86-mingw32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    monetize (~> 1.1) was resolved to 1.1.0, which depends on
    money (~> 6.5.0) was resolved to 6.5.0, which depends on
    i18n (<= 0.7.0, >= 0.6.4) x86-mswin32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    monetize (~> 1.1) was resolved to 1.1.0, which depends on
    money (~> 6.5.0) was resolved to 6.5.0, which depends on
    i18n (<= 0.7.0, >= 0.6.4) x64-mingw32

    rails-i18n was resolved to 5.0.3, which depends on
    i18n (~> 0.7) x86-mingw32

    rails-i18n was resolved to 5.0.3, which depends on
    i18n (~> 0.7) x86-mswin32

    rails-i18n was resolved to 5.0.3, which depends on
    i18n (~> 0.7) x64-mingw32

    rails-i18n was resolved to 5.0.3, which depends on
    i18n (~> 0.7) java

    rails-i18n was resolved to 5.0.3, which depends on
    i18n (~> 0.7)

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    ransack (~> 1.6.0) was resolved to 1.6.6, which depends on
    i18n java

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    ransack (~> 1.6.0) was resolved to 1.6.6, which depends on
    i18n

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    ransack (~> 1.6.0) was resolved to 1.6.6, which depends on
    i18n x86-mingw32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    ransack (~> 1.6.0) was resolved to 1.6.6, which depends on
    i18n x86-mswin32

    solidus x86-mingw32 was resolved to 1.0.0, which depends on
    solidus_core (= 1.0.0) x86-mswin32 was resolved to 1.0.0, which depends on
    ransack (~> 1.6.0) was resolved to 1.6.6, which depends on
    i18n x64-mingw32

    Running `bundle update` will rebuild your snapshot from scratch, using only
    the gems in your Gemfile, which may resolve the conflict.

    bundle updateをしてみると
    Bundler could not find compatible versions for gem "rails":
    In Gemfile:

    と表示されてしまいます

    キャンセル

check解決した方法

-2

なんでかわかりませんが、治っていました・・・

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    [Ruby on Rails]bundle install でのエラー解決方法

    bundle install でエラー Railsチュートリアルを行っている最中なのですが、 下記エラーが発生し困っております。 解決方法をググって色々探し、試してみたの

  • 解決済

    composer installでエラーが発生する

    composer installが失敗します。 $ cat composer.json { "require-dev": { "phpmd/phpmd

  • 受付中

    rails server コマンドでエラーがでます(cannnot load such file)

    railsでアプリを作ろうとしています。 rails new で新しいフォルダを作成まではできるのですが、そのディレクトリに移動してrails -vや、 rails -sコマンド

  • 受付中

    ruby on railsでrake が実行できません

    前提・実現したいこと ruby on rails実装中に以下のエラーメッセージが発生しました。 発生している問題・エラーメッセージ A\railscamp\blog>ra

  • 解決済

    railsのインストールが完了しません。

    railsのインストールが完了しません。 プログラミング初心者です。(基礎的なことができてなかったらすいません。) ネット記事を参考にrailsをインストールしていたのですが、

  • 解決済

    rmagick /ImageMagickでの画像圧縮方法に関してRails

     前提・実現したいこと>  Railsで練習でQ&Aサイトのようなものを作っています。 現在困っているのが、 ユーザーのプロフィール画像をアップロードされた際にリサイズを行い 画像

  • 解決済

    bundle install と gem install 違い

    bundle installとgem installの違いがよくわかりません。 結局bundle install したものもローカル環境にダウンロードされるのなら別にgem ins

  • 解決済

    Rails s エラーが出て困っています。

     前提・実現したいこと railsの動作確認を行おうとしています。 $rails s を実行しようとすると下記の様に表示されて困っています。 どなたか教えて頂けませんでしょうか

同じタグがついた質問を見る

  • Ruby on Rails

    7238questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2433questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。