質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Ruby on Rails 4

    2434questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

An error occurred while installing rmagick (2.15.4),

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 561

kotakota

score 3

ボールドテキスト###前提・実現したいこと
An error occurred while installing rmagick (2.15.4), and Bundler cannot
continue.
Make sure that gem install rmagick -v '2.15.4' succeeds before bundling.

これを解決したいです。

Koji-no-MacBook-Air:app-front miyako$ bundle install
Fetching gem metadata from https://rubygems.org/......
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Using rake 11.3.0
Using CFPropertyList 2.3.2
Using aasm 4.11.0
Using i18n 0.8.0
Using json 1.8.6
Using minitest 5.10.1
Using thread_safe 0.3.5
Using builder 3.2.3
Using erubis 2.7.0
Using mini_portile2 2.1.0
Using rack 1.6.5
Using mime-types-data 3.2016.0521
Using active_decorator 0.8.0
Using arel 6.0.3
Using addressable 2.4.0
Using ast 2.3.0
Using execjs 2.7.0
Using bcrypt 3.1.11
Using coderay 1.1.1
Using debug_inspector 0.0.2
Using sass 3.4.23
Using bootstrap_form 2.3.0
Using uniform_notifier 1.10.0
Using byebug 9.0.5
Using callsite 0.0.11
Using cancancan 1.15.0
Using mimemagic 0.3.1
Using ffi 1.9.10
Using cocoon 1.2.9
Using coffee-script-source 1.10.0
Using thor 0.19.4
Using concurrent-ruby 1.0.2
Using deep_merge 1.1.1
Using database_cleaner 1.5.3
Using orm_adapter 0.5.0
Using devise-bootstrap-views 0.0.8
Using devise-i18n 1.1.0
Using devise-i18n-views 0.3.7
Using diff-lcs 1.2.5
Using docile 1.1.5
Using unf_ext 0.0.7.2
Using dotenv 2.1.1
Using enum_help 0.0.15
Using excon 0.51.0
Using multipart-post 2.0.0
Using formatador 0.2.5
Using multi_json 1.12.1
Using ipaddress 0.8.3
Using xml-simple 1.1.5
Using inflecto 0.0.2
Using trollop 2.1.2
Using geocoder 1.3.7
Using git-version-bump 0.15.1
Using rb-fsevent 0.9.7
Using ruby_dep 1.3.1
Using lumberjack 1.0.10
Using nenv 0.3.0
Using shellany 0.0.1
Using method_source 0.8.2
Using slop 3.6.0
Using guard-compat 1.2.1
Using rspec-support 3.4.1
Using tilt 2.0.5
Using hashie 3.4.6
Using hpricot 0.8.6
Using jwt 1.5.6
Using multi_xml 0.6.0
Using nested_form 0.3.2
Using netrc 0.11.0
Using newrelic_rpm 3.18.0.329
Using oj 2.12.14
Using pg 0.18.4
Using powerpack 0.1.1
Using yard 0.8.7.6
Using puma 3.7.0
Using rack-cors 0.4.1
Using rack-timeout 0.4.2
Using bundler 1.14.4
Using rails_serve_static_assets 0.0.5
Using rails_stdout_logging 0.0.5
Using remotipart 1.2.1
Using safe_yaml 1.0.4
Using rainbow 2.1.0
Installing rmagick 2.15.4 with native extensions
Using ruby-progressbar 1.8.1
Using unicode-display_width 1.1.0
Using rubyzip 1.2.0
Using websocket 1.2.3
Using simplecov-html 0.10.0
Using temple 0.7.7
Using spring 1.7.1
Using timecop 0.8.1
Using fission 0.5.0
Using faker 1.6.3
Using rdoc 4.2.2
Using tzinfo 1.2.2
Using nokogiri 1.7.0.1
Using rack-test 0.6.3
Using warden 1.2.6
Using mime-types 3.1
Using launchy 2.4.3
Using parser 2.3.1.2
Using autoprefixer-rails 6.7.0
Using uglifier 3.0.0
Using better_errors 2.1.1
Using binding_of_caller 0.7.2
Using childprocess 0.5.9
Using rb-inotify 0.9.7
Using coffee-script 2.4.1
Using sprockets 3.6.2
Using unf 0.1.4
Using faraday 0.9.2
Using fog-core 1.42.0
Using rollbar 2.14.0
Using rack-contrib 1.4.0
Using notiffany 0.1.0
Using pry 0.10.3
Using rspec-core 3.4.4
Using rspec-expectations 3.4.0
Using rspec-mocks 3.4.1
Using haml 4.0.7
Using omniauth 1.3.1
Using html2slim 0.2.0
Using rails_12factor 0.0.3
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/Users/miyako/.rvm/gems/ruby-2.3.1/gems/rmagick-2.15.4/ext/RMagick
/Users/miyako/.rvm/rubies/ruby-2.3.1/bin/ruby -r
./siteconf20170215-2757-1qrj9jp.rb extconf.rb
checking for gcc... yes
checking for Magick-config... no
checking for pkg-config... yes
checking for outdated ImageMagick version (<= 6.4.9)... no
checking for Ruby version >= 1.8.5... yes
checking for stdint.h... yes
checking for sys/types.h... yes
checking for wand/MagickWand.h... no

Can't install RMagick 2.15.4. Can't find MagickWand.h.
* extconf.rb failed *
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
--with-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/Users/miyako/.rvm/rubies/ruby-2.3.1/bin/$(RUBY_BASE_NAME)

To see why this extension failed to compile, please check the mkmf.log which can
be found here:

/Users/miyako/.rvm/gems/ruby-2.3.1/extensions/x86_64-darwin-16/2.3.0/rmagick-2.15.4/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in
/Users/miyako/.rvm/gems/ruby-2.3.1/gems/rmagick-2.15.4 for inspection.
Results logged to
/Users/miyako/.rvm/gems/ruby-2.3.1/extensions/x86_64-darwin-16/2.3.0/rmagick-2.15.4/gem_make.out

An error occurred while installing rmagick (2.15.4), and Bundler cannot
continue.
Make sure that gem install rmagick -v '2.15.4' succeeds before bundling.

該当のソースコード

Rails  

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

rmagick入れる前にインストールが必要なものがあるので、
それが入っていないと思われます。

sudo yum install ImageMagick ImageMagick-devel -y

上記をインストールしてから、

gem install rmagick -v '2.15.4'

を実行してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/02/15 18:58

    お忙しい中、解答してくださりありがとうございます!!sudo: yum: command not found と返ってきてしまいます。sudo: yum:の両方ともインストールしたはずなのですが、なぜこうなってしまうのか。。お時間ができ、答えていただけたらとても助かります

    キャンセル

  • 2017/02/16 10:56

    あっ、ごめんなさい。もしかして、OSってmacですか?

    キャンセル

0

質問に記載されているエラーメッセージ通りの回答しかできませんが。。。

Make sure that gem install rmagick -v '2.15.4' succeeds before bundling.
(バンドルする前にgem install rmagick -v '2.15.4'が成功していることを確認してください。)

メッセージどおりgem install rmagick -v '2.15.4'を実行し正常にinstallが完了してからbundle installを実行してください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails 4

    2434questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。