質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • CentOS

    3075questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

CentOS6(さくらVPS)へのS3QLインストールエラーについて

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 589

TakakiSato

score 62

こんにちは。

CentOS6 (さくらのVPS)にS3QLをインストールしようとしています。
インストールを試したバージョンは以下で、全て以下に記載する同様の事象が発生しています。
・s3ql-2.21
・s3ql-2.15

手順としては以下を参考にしています。
https://goo.gl/WGb13E
http://knowledge.sakura.ad.jp/tech/3208/
http://hacknote.jp/archives/3952/

ですが、S3QLのインストールを実施した時に以下のエラーが発生し、インストールを完了することができません。

# python3 setup.py build_ext --include-dirs='/usr/local/sqlite-3.9/include' --library-dirs='/usr/local/sqlite-3.9/lib' --inplace
Traceback (most recent call last):
  File "setup.py", line 39, in <module>
    import s3ql
  File "/usr/local/src/s3ql-2.21/src/s3ql/__init__.py", line 13, in <module>
    from llfuse import ROOT_INODE
ImportError: /usr/lib64/python3.4/site-packages/llfuse.cpython-34m.so: undefined symbol: fuse_lowlevel_notify_store


fuseというライブラリに関連するところでエラーになっているようですが、
どのようなエラーなのか理解できていません。
インストールしてあるfuseのバージョンはfuse-2.9.3です。

このエラーの原因解消方法についてお分かりになる方教えていただけないでしょうか?
また、CentOS6(さくらのVPS)上にインストールされた方いらっしゃれば、
・S3QLのバージョン
・fuseのバージョン(付随していれたモジュールも)
について教えて頂けないでしょうか?

以上よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

fuse_lowlevel_notify_store が無いバージョンの libfuse.so.2 を見ているのではないでしょうか?
ldd /usr/lib64/python3.4/site-packages/llfuse.cpython-34m.so で libfuse.so.2 のリンク先を確認ください。

ちなみに、CentOS 6.8, python3.3, fuse-2.9.3 では以下のようになりました。

# ldd /usr/lib/python3.3/site-packages/llfuse-1.1.1-py3.3-linux-x86_64.egg/llfuse.cpython-33m.so
        linux-vdso.so.1 =>  (0x00007ffc0813a000)
        libpython3.3m.so.1.0 => /usr/lib64/libpython3.3m.so.1.0 (0x00007f06ec7e3000)
        libfuse.so.2 => /usr/local/lib/libfuse.so.2 (0x00007f06ec5a8000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f06ec38a000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f06ec182000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f06ebdee000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f06ebbe9000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007f06eb9e6000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f06eb762000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f06ecef0000)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

わたしの環境でも同様の問題があり、

 しかし、回避の方法がわからず困っています。

# ldd /usr/lib/python3.3/site-packages/llfuse-1.2-py3.3-linux-x86_64.egg/llfuse.cpython-33m.so
        linux-vdso.so.1 =>  (0x00007ffe4ad03000)
        libpython3.3m.so.1.0 => /usr/lib64/libpython3.3m.so.1.0 (0x00007f270d679000)
        libfuse.so.2 => /lib64/libfuse.so.2 (0x00007f270d443000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f270d225000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f270d01d000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f270cc89000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f270ca84000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007f270c881000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f270c5fd000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003599600000)

確かに古いバージョンである「/lib64/libfuse.so.2」を見ていました。

しかし、この先どのように修正したらいいかがわかりません。

# ldconfig -p | grep fuse
        libfuse3.so.3 (libc6,x86-64) => /usr/lib/libfuse3.so.3    ※
        libfuse3.so (libc6,x86-64) => /usr/lib/libfuse3.so
        libfuse.so.2 (libc6,x86-64) => /lib64/libfuse.so.2
        libfuse.so.2 (libc6,x86-64) => /usr/lib/libfuse.so.2
        libfuse.so (libc6,x86-64) => /lib64/libfuse.so
        libfuse.so (libc6,x86-64) => /usr/lib/libfuse.so

※のように、ldconfig 自体は最新のlibfuse3.so.3 等を認識しているようです。私が調べた範囲でわかったことはこれだけです。

この先をどのように進めたらよいでしょうか。
ご存じの方がいらっしゃいましたらぜひご教授ください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/09 17:50

    失礼しました、ここは質問を書くべき場所ではありませんでした。
    別の質問として立ち上げました。https://teratail.com/questions/87566

    キャンセル

同じタグがついた質問を見る

  • CentOS

    3075questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。