質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Ruby

    9214questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8638questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

railsのbundle install時のエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 885

nimi0370

score 39

Githubから開発のためcloneダウンロードしたrailsなのですが、rails sを実行したところでエラーが出ました。
bundle installが必要とのことだったので、bundle installすると次のようなエラーが出て困っています。

Errno::EPERM: Operation not permitted @ chmod_internal - /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/json-2.0.2/tests/test_helper.rb
An error occurred while installing json (2.0.2), and Bundler cannot continue.
Make sure that `gem install json -v '2.0.2'` succeeds before bundling.

色々ググってみましたが、良い回答が得られなかったのでご教授いただければ幸いです。

gem -v 2.5.1
ruby -v 
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin15]

rails -v

<追記>
sudo gem install -n /usr/local/bin json -v '2.0.2'
を実行すると

Building native extensions.  This could take a while...
ERROR:  Error installing json:
ERROR: Failed to build gem native extension.

current directory: /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/json-2.0.2/ext/json/ext/generator
/Users/futamidaiki/.rbenv/versions/2.3.0/bin/ruby -r ./siteconf20170121-6816-1gizp4.rb extconf.rb
creating Makefile

current directory: /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/json-2.0.2/ext/json/ext/generator
make "DESTDIR=" clean
make: error: unable to find utility "make", not a developer tool or in PATH

current directory: /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/json-2.0.2/ext/json/ext/generator
make "DESTDIR="
make: error: unable to find utility "make", not a developer tool or in PATH

make failed, exit code 72

Gem files will remain installed in /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/json-2.0.2 for inspection.
Results logged to /Users/futamidaiki/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/extensions/x86_64-darwin-15/2.3.0-static/json-2.0.2/gem_make.out

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+3

エラーメッセージは権限不足で書き込みができていないような感じですが、インストール先はホームディレクトリの下のようなので、sudo付きの操作を行って権限のないディレクトリを作成してしまっている可能性が考えられます。
エラーメッセージにあるファイル/ディレクトリのパーミッションを確認してください。

【例】

パーミッション確認

$ find ~/.rbenv -exec ls -l {} \; > tmp.txt
$ less tmp.txt

オーナー変更

$ chown -R {ユーザ名}:{グループ名} /Users/futamidaiki/.rbenv/

オーナがrootになっているものがあるのが原因であれば、オーナー変更のコマンド実行するだけで問題解決しますが、原因を明確にするために先にパーミッションの確認を行っておいたほうが良いです。
「よくわからんけど直ったからいいや」ということのないように。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    9214questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8638questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。