質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.35%

  • PHP

    21256questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CakePHP

    2386questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。

CakePHP3でFriendsOfCakeのインストール時エラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 667

kenkbou

score 143

Cakephp3.3系でcomposerを使用してFriendsOfCakeをインストールした際に以下のエラーが発生しました。

実行コード

"require": {
        "php": ">=5.5.9",
        "cakephp/cakephp": "~3.3",
        "mobiledetect/mobiledetectlib": "2.*",
        "cakephp/migrations": "~1.0",
        "friendsofcake/search": "*",
        "cakephp/plugin-installer": "*",
        "cakephp/acl": "dev-master",
        "jcpires/cakephp3-aclmanager": "dev-master"
}
Fatal error: Call to undefined method Cake\Network\Response::getBody() in ROOT/vendor/cakephp/debug_kit/src/ToolbarService.php on line 213

以前は発生しなかったので、経験されたことがある方いらっしゃいましたらご教示いただけると助かります。
また、composer.jsonから『"friendsofcake/search": "*"』を削除をしても同じエラーが残ってしまい困っています。

こちらも対処方法ご存知でしたら教えたいただけますと助かります。

追記
あのあと調ていて、
同じくdebug kitがおかしいのでは?と思いました。
Cakephp3をインストールするときはエラーにならなかったのですが、
friendsofcakeを入れたタイミングで発生しました。
debug kitのバージョンは3.5.1です。
いまは取り急ぎでbootstrap.phpのプラグインのdebug kitの読み込み部分をコメントアウトしています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • popobot

    2017/01/13 22:36

    エラーを見る限り、friendsofcake/searchは関係なさそうですけどね。composer updateとかしましたか? composer.lockを見て、cakephp/cakephpとcakephp/debug_kitのバージョンを調べてみてください。

    キャンセル

  • popobot

    2017/01/13 22:38

    インストール時のエラーとありますが、エラーはどういうときに発生するのでしょうか。

    キャンセル

  • kenkbou

    2017/01/13 23:43

    ありがとうございます。更新させていただきました。

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2017/01/14 09:23

    require-dev など require が接頭辞となっている場所はほかにありませんか (jsonふぁいる)

    キャンセル

回答 1

checkベストアンサー

0

debug_kigのリリース版の最新は3.5.0なので、たぶん開発中のコードをインストールしてしまったんだと思います。
composer.jsonのdebug_kigのバージョン指定を"~3.0"とかにしてcomposer updateし直せば治るのではないかと。

cakephp/debug_kit

なお、確かに1月13日にgetBody()を使うようにするコミットが入っていますね。まだ開発版なのでバグがあるのかもしれません。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/14 13:38

    バージョンを下げることで直りました!ありがとうございます

    キャンセル

同じタグがついた質問を見る

  • PHP

    21256questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CakePHP

    2386questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。