質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.46%

  • PHP

    20929questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CakePHP

    2368questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。

CakePHP3で simple HTML DOM Parserを使うことは可能でしょうか?

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,122

shishishi

score 25

前提・実現したいこと

CakePHP3でスクレイピングに関連するプログラムを作りたいと思っています。
CakePHP2で simple HTML DOM Parserを利用しているサンプルプログラムを見つけたので、それを参考にしながら作ろうと思っています。
ですが、CakePHP3 では仕様が大きく変わっているため simple HTML DOM Parserの「SimpleHtmlDom.php」をどうやって利用できるようになるのかが理解できませんでした。

CakePHP2では
/app/Controller/AppController.php

App::import('Vendor', 'SimpleHtmlDom');
と書いて、必要な箇所で関数を記述するものかと思っていますが、CakePHP3ではどのように記述すればいいのでしょうか?

CakePHP2も詳しくはないのですが、どうせ勉強するならと思い CakePHP3で作り始めたところです。
よろしくお願いいたします。

発生している問題・エラーメッセージ

エラーは下記の様になっています。
Fatal error: Class 'App\Controller\App' not found in C:\xampp\htdocs\cake\src\Controller\AppController.php on line 20

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

利用できますよ。使用したこともあります。
Simple Dom ParserをComposerからインストールできるようにしたものがあるのでそれを使えばいいと思います。
sunra/php-simple-html-dom-parser

composer.json

"require": {
    "sunra/php-simple-html-dom-parser": "1.5.2"
}

Cakephpからは、以下のようにuseで宣言すればどこからでも使えます。

use Sunra\PhpSimple\HtmlDomParser;
$dom = HtmlDomParser::str_get_html( $str );

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/12 19:07

    回答ありがとうございます。
    ご回答いただいた内容を基にして
    https://github.com/sunra/php-simple-html-dom-parser
    上記から zipファイルをダウンロードして、解凍したフォルダを「php-simple-html-dom-parser-master」から「php-simple-html-dom-parser」に変更し、「/vendor」にコピーして「/vendor/php-simple-html-dom-parser-master/」という状態です。
    その後、「/composer.json」を変更し、「/src/Controller/AppController.php」に「use Sunra\PhpSimple\HtmlDomParser;」を追記しました。
    この方法で何か間違っていますでしょうか?

    キャンセル

  • 2017/01/12 19:12 編集

    通常、composer.jsonに記載して、composer installとか実行すれば自動的に/vendorにインストールされますよ。composerを使っていないんですか?

    キャンセル

  • 2017/01/12 19:59

    コメントありがとうございます。
    composerの使い方をよくわかっていなかったもので、使わずに何とかなるものかと思っていました。
    composerを使ってインストールしたら動くようになりました。
    ライブラリがインストールされるのに合わせて、「composer.lock」も更新されるんですね。
    何時間も悩んでいましたので非常に助かりました。
    コンポーザーの使い方も理解できました。ありがとうございました!!

    キャンセル

  • 2017/01/12 22:45

    そうだったんですね。composerはPHPにおける依存パッケージ管理のスタンダードですし、とても便利なので、是非使うことをオススメします! cakephp本体や関連パッケージもcomposerで管理できます。

    キャンセル

関連した質問

同じタグがついた質問を見る

  • PHP

    20929questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • CakePHP

    2368questions

    CakePHPは、PHPで書かれたWebアプリケーション開発用のフレームワークです。 Ruby on Railsの考え方を多く取り入れており、Railsの高速性とPHPの機動性を兼ね備えています。 MVCやORMなどを「規約優先の考え方」で利用するため、コードを書く手間を省くことができます。 外部のライブラリに依存しないので、単体での利用が可能です。