質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.87%

  • MacOS(OSX)

    1689questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • Vim

    450questions

    VimとはUnix / Linux 系のOSに標準搭載されているターミナル上で動くテキストエディタです。

Vim入門したいのですが.......

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 645

ruins

score 1

今日の夕方今まで使ったSublimeからVimに乗り換えようとし、入門記事などを漁って基本的な操作方法は覚えました。
しかし、プラグインのインストールで幾つかコケたので質問させていただきます

  1. Dein.vimでプラグイン管理するのがオススメとのことで導入してみました。早速CoffeeScritのコードに色をつけたくて、vim-coffee-scriptのインストールを試みました。.vimrcdein#add(~~~)などと記述し、:call dein#install()をvimで実行するとインストールが無事完了したことを伝える文章が出てきたのでCoffeeScriptのコードをVimで開いてみたのですが色が付いておらず、白い文字のままです。

  2. 1の問題を後回しにしようと次はvim-pugをインストールしようとdein#add(~~~)の文章を書き、いざ:call dein#install()を実行すると次は何故か「[dein] You may have used the wrong plugin name, or all of the plugins are already installed.」とエラーが出てしましました。

  3. 上の2点を解決しようと打開策を探しているとMacに標準で入ってるVimよりHomebrewでインストールしなおしたものの方が良い、との情報を得ました。なのでbrew install vimを実行してみたのですが以下のようなエラーを吐かれてしまいました

==> Installing dependencies for vim: perl, readline, libyaml, openssl, ruby, sqlite, gdbm, python
==> Installing vim dependency: perl
==> Downloading https://homebrew.bintray.com/bottles/perl-5.24.0_1.el_capitan.bo
Warning: Failed to create the file 
Warning: /Users/user_name/Library/Caches/Homebrew/perl-5.24.0_1.el_capitan
Warning: .bottle.1.tar.gz.incomplete: Permission denied

curl: (23) Failed writing body (0 != 16024)
Error: Failed to download resource "perl"
Download failed: https://homebrew.bintray.com/bottles/perl-5.24.0_1.el_capitan.bottle.1.tar.gz
Warning: Bottle installation failed: building from source.
==> Using the sandbox
==> Downloading http://www.cpan.org/src/5.0/perl-5.24.0.tar.xz
Warning: Failed to create the file 
Warning: /Users/user_name/Library/Caches/Homebrew/perl-5.24.0.tar.xz.incom
Warning: plete: Permission denied

curl: (23) Failed writing body (0 != 1402)
Trying a mirror...
==> Downloading https://mirrors.ocf.berkeley.edu/debian/pool/main/p/perl/perl_5.

curl: (22) The requested URL returned error: 404 Not Found
Error: Failed to download resource "perl"
Download failed: https://mirrors.ocf.berkeley.edu/debian/pool/main/p/perl/perl_5.24.0.orig.tar.xz

こちらも必死に検索していたのですが解決策は見つからず.....。

VimやHomebrewに詳しい方々、ぜひご教授いただけると幸いです。

+ 追記
2の時点での.vimrcです
vimのバージョンは7.3です

set nowrap

set hlsearch
set ignorecase
set smartcase

set autoindent

set ruler
set number
set list
set wildmenu
set showcmd

set listchars=tab:\ \ ,eol:¬
set shiftwidth=4
set softtabstop=4
set expandtab
set tabstop=4
set smarttab

set clipboard=unnamed

if &compatible
  set nocompatible               " Be iMproved
endif

set runtimepath+=/Users/ishizakatomoya/.vim/bundle/repos/github.com/Shougo/dein.vim

if dein#load_state('/Users/ishizakatomoya/.vim/bundle')
  call dein#begin('/Users/ishizakatomoya/.vim/bundle')


  call dein#add('/Users/ishizakatomoya/.vim/bundle/repos/github.com/Shougo/dein.vim')


  call dein#add('Shougo/neosnippet.vim')
  call dein#add('Shougo/neosnippet-snippets')
  call dein#add('kchmck/vim-coffee-script')
  call dein#add('digitaltoad/vim-pug')
  call dein#add('Shougo/vimshell', { 'rev': '3787e5' })


  call dein#end()
  call dein#save_state()
endif


filetype plugin indent on
syntax enable

if dein#check_install()
  call dein#install()
endif

au BufRead,BufNewFile,BufReadPre *.coffee   set filetype=coffee
syntax on
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • thinca

    2017/01/08 22:25

    Vim のバージョンや、使用した vimrc の全文などの情報があるとアドバイスしやすいです。個人的には Mac で使うなら MacVim がおすすめです。brew で入れたい場合はこちらを参照してください→ https://github.com/macvim-dev/homebrew-macvim

    キャンセル

  • ruins

    2017/01/08 22:40

    ご指摘ありがとうございます 追記いたしました!! MacVim試してみます!

    キャンセル

回答 1

checkベストアンサー

+2

dein.vim の help にも書かれていますが、dein.vim は Vim 7.4 以降に対応しています。
Vim 7.4 以降、できれば最新である Vim 8.0 を使うと良いと思います。
先ほど紹介した MacVim-dev を brew で入れれば最新版が入ると思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/09 18:30

    ありがとうございます!!!
    vimを8.0にしたらdein.vimも動きました!!!

    homebrewは再インストールしたら動くようになりました!!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.87%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • MacOS(OSX)

    1689questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • Vim

    450questions

    VimとはUnix / Linux 系のOSに標準搭載されているターミナル上で動くテキストエディタです。