質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.48%

  • rpm

    31questions

    rpmコマンドは、UNIX系OSのroot権限でのみ利用可能なコマンドで、 RPMパッケージのインストールなどができます。

jdk-8u111-linux-x64.rpmのインストールについて

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,026

to_me_the

score 1

linux ubuntuをつかっています。
jdk8u111-linux-x64.rpmをダウンロードして、/rootに移動させたあと、
rpm -i /root/jdk8u111-linux-x64.rpm
とターミナルで打ち込んだところ
rpm: RPM should not be used directly install RPM packages,  use Alien instead!
rpm: However assuming you know what you are doing...
エラー:依存性の欠如
とでてその下に
/bin/basename はjdk1.8.0_111-2000:1.8.0_111-fcs.x86_64に必要とされている
というような文章が23行つづいているのですが、どうすればエラーを取り除き、インストールを実行できるようになるのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

一応、rpmコマンドに"-nodeps"オプションをつければ依存性を無視して目的のrpmをインストールすることはできますがお勧めできません。

「依存性の欠如」とは目的のrpmをインストールするのに必要とされるコマンド・ライブラリです。
一つ一つのファイルがどのrpmに含まれるかを確認し、yumやrpmでインストールしていくしかないです。
※yumの方が「依存の依存」という部分で悩まされることはないかと思います。

例えば"/bin/basename"はcoreutilsというrpmに含まれています。
対象の機器にインストールされていないファイルがどのrpmに含まれているかを調べるには、https://www.rpmfind.net/などで調べるしかないと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/01 16:17

    ubuntuでしたね。
    yumはデフォルトでは入っていませんね。大変失礼しました。

    キャンセル

0

Ubuntuでしたら、apt-getを使えば依存性の解決をしてパッケージインストールができます。
なぜrpmを使いたいのかよくわかりませんが、apt-getの使用をご検討ください。
UbuntuにOracle JDK8をインストール
というページが参考になるかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • rpm

    31questions

    rpmコマンドは、UNIX系OSのroot権限でのみ利用可能なコマンドで、 RPMパッケージのインストールなどができます。