質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

phpMyAdmin

phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

Q&A

解決済

1回答

5567閲覧

CentOS7、Apache2.4、PHP7、MySQL5.7にてphpMyAdminがインストールされません

hidepon

総合スコア206

MySQL

MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

phpMyAdmin

phpMyAdminはオープンソースで、PHPで書かれたウェブベースのMySQL管理ツールのことです。

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

0グッド

0クリップ

投稿2016/11/30 07:54

編集2016/11/30 08:03

CentOS7、Apache2.4、PHP7、MySQL5.7にてphpMyAdminがインストールされません
いろいろと調査しながらインストールを試みていますが、何度やってもうまくいきません。
現在確認できているのは
Apacheのインストールの起動と表示
PHPのインストールと起動(phpinfoを表示)
MySQLのインストールと起動(コマンドから問題なし)

この状況で
yum install phpmyadmin
としてインストールを試みると下記のようなエラーが出ます。

Error:

1 Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 3 php-common(x86-64) = 7.0.13-1.el7.remi 4 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 5 php-common(x86-64) = 5.4.16-36.el7_1 6 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 7 php-common(x86-64) = 5.4.16-36.1.el7_2.1 8 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 9 php-common(x86-64) = 5.4.16-36.3.el7_2 10Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) 11 Requires: php(api) = 20100412-64 12 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 13 php(api) = 20151012-64 14 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 15 php(api) = 20100412-64 16 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 17 php(api) = 20100412-64 18 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 19 php(api) = 20100412-64 20Error: Package: php-bcmath-5.4.16-36.3.el7_2.x86_64 (updates) 21 Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 22 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 23 php-common(x86-64) = 7.0.13-1.el7.remi 24 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 25 php-common(x86-64) = 5.4.16-36.el7_1 26 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 27 php-common(x86-64) = 5.4.16-36.1.el7_2.1 28 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 29 php-common(x86-64) = 5.4.16-36.3.el7_2 30Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) 31 Requires: php(zend-abi) = 20100525-64 32 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 33 php(zend-abi) = 20151012-64 34 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 35 php(zend-abi) = 20100525-64 36 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 37 php(zend-abi) = 20100525-64 38 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 39 php(zend-abi) = 20100525-64 40Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) 41 Requires: php-zip 42 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 43 php-zip 44 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 45 php-zip 46 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 47 php-zip 48 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 49 Not found 50Error: Package: php-xml-5.4.16-36.3.el7_2.x86_64 (updates) 51 Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 52 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 53 php-common(x86-64) = 7.0.13-1.el7.remi 54 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 55 php-common(x86-64) = 5.4.16-36.el7_1 56 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 57 php-common(x86-64) = 5.4.16-36.1.el7_2.1 58 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 59 php-common(x86-64) = 5.4.16-36.3.el7_2 60Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) 61 Requires: php-simplexml 62 Available: php-common-5.4.16-36.el7_1.x86_64 (base) 63 php-simplexml 64 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) 65 php-simplexml 66 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) 67 php-simplexml 68 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) 69 Not found 70Error: Package: php-mysqlnd-5.4.16-36.3.el7_2.x86_64 (updates) 71 Requires: php-pdo(x86-64) = 5.4.16-36.3.el7_2 72 Installed: php-pdo-7.0.13-1.el7.remi.x86_64 (@remi-php70) 73 php-pdo(x86-64) = 7.0.13-1.el7.remi 74 Available: php-pdo-5.4.16-36.el7_1.x86_64 (base) 75 php-pdo(x86-64) = 5.4.16-36.el7_1 76 Available: php-pdo-5.4.16-36.1.el7_2.1.x86_64 (updates) 77 php-pdo(x86-64) = 5.4.16-36.1.el7_2.1 78 Available: php-pdo-5.4.16-36.3.el7_2.x86_64 (updates) 79 php-pdo(x86-64) = 5.4.16-36.3.el7_2

どのように対処すればよいのかわかりません。
宜しくお願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

退会済みユーザー

退会済みユーザー

2016/11/30 08:00

ご自身の投稿は、ちゃんと確認しましょうよ。
guest

回答1

0

ベストアンサー

bash

1yum --enablerepo=remi install phpmyadmin

投稿2016/11/30 08:04

退会済みユーザー

退会済みユーザー

総合スコア0

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hidepon

2016/11/30 08:55

ご返答を頂き有難うございます。 同様のエラーがまだたくさん出ている状況です・・・orz。 http://qiita.com/100/items/8e9d9540845cc23e6111 とか参考にしていますが、うまくいきません。 今までのPHP7、Mysql5.7との相性が悪いんでしょうか?
退会済みユーザー

退会済みユーザー

2016/11/30 08:57

エラーメッセージというのは解決のための重要な情報です。
hidepon

2016/11/30 09:05

スミマセン。。。初歩的なことをしてしまいまして・・・ Error: Package: php-process-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) Requires: php(api) = 20100412-64 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php(api) = 20151012-64 Available: php-common-5.4.16-36.el7_1.x86_64 (base) php(api) = 20100412-64 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php(api) = 20100412-64 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php(api) = 20100412-64 Error: Package: php-bcmath-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) Requires: php(zend-abi) = 20100525-64 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php(zend-abi) = 20151012-64 Available: php-common-5.4.16-36.el7_1.x86_64 (base) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php(zend-abi) = 20100525-64 Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) Requires: php-zip Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-zip Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-zip Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-zip Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) Not found Error: Package: php-xml-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) Requires: php-simplexml Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-simplexml Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-simplexml Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-simplexml Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) Not found Error: Package: php-mysqlnd-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-pdo(x86-64) = 5.4.16-36.3.el7_2 Installed: php-pdo-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-pdo(x86-64) = 7.0.13-1.el7.remi Available: php-pdo-5.4.16-36.el7_1.x86_64 (base) php-pdo(x86-64) = 5.4.16-36.el7_1 Available: php-pdo-5.4.16-36.1.el7_2.1.x86_64 (updates) php-pdo(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-pdo-5.4.16-36.3.el7_2.x86_64 (updates) php-pdo(x86-64) = 5.4.16-36.3.el7_2
退会済みユーザー

退会済みユーザー

2016/11/30 09:17

yum --enablerepo=remi update yum --enablerepo=remi install phpmyadmin
hidepon

2016/11/30 09:37

たびたびのご返答を頂き有難うございます。 インストールが進んで改善するかと思ったのですが、下記のエラーがまだ出ています。 当方でもいろいろと調べてみます。 本当に有難うございます。 Error: Package: php-process-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) Requires: php(api) = 20100412-64 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php(api) = 20151012-64 Available: php-common-5.4.16-36.el7_1.x86_64 (base) php(api) = 20100412-64 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php(api) = 20100412-64 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php(api) = 20100412-64 Error: Package: php-bcmath-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: php-tidy-5.4.16-7.el7.x86_64 (epel) Requires: php(zend-abi) = 20100525-64 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php(zend-abi) = 20151012-64 Available: php-common-5.4.16-36.el7_1.x86_64 (base) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php(zend-abi) = 20100525-64 Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) Requires: php-zip Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-zip Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-zip Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-zip Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) Not found Error: Package: php-xml-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-common(x86-64) = 5.4.16-36.3.el7_2 Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-common(x86-64) = 7.0.13-1.el7.remi Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-common(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-common(x86-64) = 5.4.16-36.3.el7_2 Error: Package: phpMyAdmin-4.4.15.8-2.el7.noarch (epel) Requires: php-simplexml Available: php-common-5.4.16-36.el7_1.x86_64 (base) php-simplexml Available: php-common-5.4.16-36.1.el7_2.1.x86_64 (updates) php-simplexml Available: php-common-5.4.16-36.3.el7_2.x86_64 (updates) php-simplexml Installed: php-common-7.0.13-1.el7.remi.x86_64 (@remi-php70) Not found Error: Package: php-mysqlnd-5.4.16-36.3.el7_2.x86_64 (updates) Requires: php-pdo(x86-64) = 5.4.16-36.3.el7_2 Installed: php-pdo-7.0.13-1.el7.remi.x86_64 (@remi-php70) php-pdo(x86-64) = 7.0.13-1.el7.remi Available: php-pdo-5.4.16-36.el7_1.x86_64 (base) php-pdo(x86-64) = 5.4.16-36.el7_1 Available: php-pdo-5.4.16-36.1.el7_2.1.x86_64 (updates) php-pdo(x86-64) = 5.4.16-36.1.el7_2.1 Available: php-pdo-5.4.16-36.3.el7_2.x86_64 (updates) php-pdo(x86-64) = 5.4.16-36.3.el7_2
退会済みユーザー

退会済みユーザー

2016/11/30 09:39

yum --enablerepo=remi-php70 update yum --enablerepo=remi-php70 install phpmyadmin
hidepon

2016/12/01 00:13

上記のコマンドでエラーなくインストール処理できたようですが、 どこにインストールされたか・・・ find . -type d -name "php" で引っかかりません・・・orz
退会済みユーザー

退会済みユーザー

2016/12/01 01:23 編集

which php php -v
hidepon

2016/12/01 03:00

何度も何度もスミマセン・・・・m(_ . _)m Loaded plugins: fastestmirror, langpacks, priorities Loading mirror speeds from cached hostfile * base: ftp.iij.ad.jp * epel: ftp.riken.jp * epel-debuginfo: ftp.riken.jp * epel-source: ftp.riken.jp * extras: ftp.iij.ad.jp * remi: mirrors.tuna.tsinghua.edu.cn * remi-safe: mirrors.tuna.tsinghua.edu.cn * remi-test: mirrors.tuna.tsinghua.edu.cn * updates: ftp.iij.ad.jp 2857 packages excluded due to repository priority protections Package phpMyAdmin-4.4.15.8-2.el7.noarch already installed and latest version Nothing to do となってインストールされたようですが、どこのディレクトリにも見当たりません。 find コマンドでも探しましたが、・・・ 申し訳ございませんが、ご教授頂けるでしょうか。
退会済みユーザー

退会済みユーザー

2016/12/01 03:10

php -v でインストール済みのPHPのバージョンを確認してください。
hidepon

2016/12/01 03:16

有難うございます。 バージョン情報は下記の通りで7.0.13です。 PHP 7.0.13 (cli) (built: Nov 8 2016 20:16:29) ( NTS ) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
退会済みユーザー

退会済みユーザー

2016/12/01 03:18

インストールには成功していますね。 インストール先のディレクトリは通常知らなくても問題ないはずですが、それを知りたい理由はなんですか?
date

2016/12/01 03:18

見つからないのはphpではなくphpMyAdminの方ですか
hidepon

2016/12/01 03:22

phpMyAdminのディレクトリが分からないんです・・・
退会済みユーザー

退会済みユーザー

2016/12/01 03:28

これで表示されます。 rpm -ql phpMyAdmin
hidepon

2016/12/01 03:44

表示されました。有難うございました。 そんなところにインストールされるとは・・・ とても勉強になりました。有難うございました
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問