質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Ruby

    9189questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

rbenv install 2.2.2 でエラー

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 662

nasubi256

score 12

前提・実現したいこと

1.本当にやりたいことは、railsのインストール。
2.しかし、rubyのバージョンを2.2.2にしないといけないとエラーが出まして
3.現在、rubyのバージョン切替で躓いてます。

発生している問題・エラーメッセージ

1.本当にやりたいことは、railsのインストール。
2.しかし、rubyのバージョンを2.2.2にしないといけないとエラーが出る

[vagrant@localhost exec]$ gem install rails
ERROR:  Error installing rails:
        activesupport requires Ruby version >= 2.2.2.

3.rubyのバージョン切替で躓いてます。

[vagrant@localhost exec]$ rbenv install 2.2.2
Downloading ruby-2.2.2.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.2.tar.bz2
error: failed to download ruby-2.2.2.tar.bz2

BUILD FAILED (CentOS release 6.8 (Final) using ruby-build 20160913-13-g8ef0c34)

試したこと

エラーメッセージでぐぐると出てくる、パッケージインストール(不発)

[vagrant@localhost exec]$ sudo yum -y install zlib zlib-devel openssl openssl-devel
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: ftp.riken.jp
 * extras: ftp.iij.ad.jp
 * remi-safe: rpms.remirepo.net
 * updates: ftp.iij.ad.jp
パッケージ zlib-1.2.3-29.el6.x86_64 はインストール済みか最新バージョンです
パッケージ zlib-devel-1.2.3-29.el6.x86_64 はインストール済みか最新バージョンです
パッケージ openssl-1.0.1e-48.el6_8.3.x86_64 はインストール済みか最新バージョンです
パッケージ openssl-devel-1.0.1e-48.el6_8.3.x86_64 はインストール済みか最新バージョンです
何もしません

以上です。勉強が進められず、困っております。
必要な情報があれば、載せます。
よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

メッセージだけみると単純にRubyのダウンロードに失敗しているみたいですね。
これだけだと正直ちょっとわからないですが・・・
一応、メッセージとかググってみたらこんなのが出てきました。

あと、Vagrantを使っているようなので
もし環境構築を0から作りたいとかosはcentosじゃないと嫌とかいうのでなければrails-dev-boxを使うのも手かなと思います。
これをローカルに落としてきてvagrant upとやればRailsとかDBとかがすでにinstallされた状態のVMが出来上がります。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    9189questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。