質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.46%
Cloud9

Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

Devise

Deviseとは、Ruby-on-Railsの認証機能を追加するプラグインです。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Q&A

解決済

2回答

9280閲覧

Deiviceにてrails g device:installを実行後エラー

SNAKE1185

総合スコア10

Cloud9

Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

Devise

Deviseとは、Ruby-on-Railsの認証機能を追加するプラグインです。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

0グッド

0クリップ

投稿2016/10/15 17:22

###発生してる問題
railsにて作っているサービスにlogin機能を追加しようと思い、テストがてら新しいプロジェクトをつくり
deviceをインストールしrails g device:installを実行したところエラーが出ました。

###エラーメッセージ

Running via Spring preloader in process 3322 Could not find generator 'device:install'. Maybe you meant 'generator', 'coffee:assets' or 'assets' Run `rails generate --help` for more options.

###エラーまでの経緯
1、Gemfileにgem'device'を記述

2、bundle install実行(インストールは成功)

3、rails g device:install実行時に上記のエラー

###試したこと
'spring'のバージョンを1.6.3に指定し再度実行→エラー(下記参照)
プロジェクトの初期化上記と同エラー

There is a version mismatch between the spring client and the server. You should restart the server and make sure to use the same version. CLIENT: 1.6.4, SERVER: 1.7.2

###補足情報
Ruby version :ruby 2.3.0p0
rails version :Rails 4.2.5
関係ないとは思われますが諸事情でcloud9を利用して開発を行っています。
設定等は変更しておりません。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

このエラーは「device:installというgeneratorは見つかりませんよ」というようなエラーです。

ruby

1Could not find generator 'device:install'.

deviseのinstallは

ruby

1rails g device:install

ではなく正しくは

ruby

1rails g devise:install

で、devi"c”eではなくdevi"s"eです。

投稿2016/10/15 23:02

cameluby

総合スコア891

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

複数バージョンのspringを使用していると

There is a version mismatch between the spring client and the server.
You should restart the server and make sure to use the same version.

このエラーが発生するようです。
spring stopで停止させてみてはどうでしょうか。
なお、上記では駄目な場合もあり、その場合は、アップデートでバージョンを統一したり、アンインストールすることで対応した人もいるようです。

参考URL:
https://github.com/rails/spring/issues/295

投稿2016/10/15 18:55

編集2016/10/15 18:57
matsu

総合スコア702

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.46%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問