質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.35%

  • Linux

    4680questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    3310questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • VMware

    265questions

    VMwareとは、 ハードウェアで動作するOS上で仮想マシンを作成、実行するソフトウェアです。 Windows上でUNIX系OSを動作させたり、他のOS上で別の仮想OSを動作することが可能です。

  • yum

    184questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

[CentOS] yumのインストールが依存関係が原因でできない

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 4,482

ryo_se

score 72

お世話になっております。
現在下記のようなCentOS6.5(64bit)環境を構築しております。

①仮想環境上(VMWare)に、物理ハードにインストールされていたCentOSを移植。

②抽出した環境はCUIベースであったが、GUIベースにも対応できるようにGUI関係パッケージインストールを試みる。

③ネットワークには接続されていない環境であるため、CentOSのCDイメージをVMWareに読み込み、
/media/CentOS/にマウントしてyumのリポジトリとして利用。

④下記コマンドで各種パッケージをインストール。
(バージョンによってGUIパッケージが異なるようなので、とりあえず試したものを全て羅列しています)

yum --disablerepo=\* --enablerepo=media_default groupinstall ~~~

"X Window System"
"GNOME Desktop Environment"
"Desktop"
"General Purpose Desktop"
"Desktop Platform"
"Legacy X Window System Compatibility"
"Japanese Support"

ですがそれぞれインストールしようとすると、パッケージはそれぞれ違えど依存関係のエラーが生じます。
(Japanese Supportのみ正常にインストールできました)

[一例]
Error: Package: glibc-2.12-1.80.e16.i686 (media_default)
Requires: glibc-common = 2.12-1.80.e16
Installed: glibc-common-2.12-1.132.e16.x86_64 (@base)
glibc-common = 2.12-1.132.e16
Available: glibc-common-2.12-1.80.e16.x86_64 (media_default)
glibc-common = 2.12-1.80.e16

ちなみに「startX」や「X -configure」はcommand認識されていないため、GUIパッケージのインストールはそもそもできていないかと思われます。


色々調査してみて各種解決方法等を試してみましたがうまくいきません。

①古いバージョンにダウングレードしてみる
yum --disablerepo=\* --enablerepo=media_default downgrade glibc-2.12-1.80.e16.x86_64 glibc-common-2.12-1.80.e16.x86_64
結果↓
No package glibc-2.12-1.80.e16.x86_64" available
No package glibc-common-2.12-1.80.e16.x86_64" available

下記も試してみたが同様
yum --disablerepo=\* --enablerepo=media_default downgrade "X Window System"

②一旦現在インストールされているものをアンインストールする
yum --disablerepo=\* --enablerepo=media_default remove glibc-2.12-1.132.e16.x86_64 glibc-common-2.12-1.132.e16.x86_64
結果↓
No Match for argument: glibc-2.12-1.132.e16.x86_64
Loading mirror speeds from cached hostfile

No Match for argument: glibc-common-2.12-1.132.e16.x86_64
Loading mirror speeds from cached hostfile

下記も試してみたが同様
yum --disablerepo=\* --enablerepo=media_default remove "X Window System"


なぜかどちらも存在していないようなメッセージが表示されます。

お手数お掛けしますが、解決方法のご教授をお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

 依存関係のエラーについて

インストールしようとしているパッケージの中に、glibc-*.i686 を必要とするものがあるようです。
現在インストールされているバージョン・リリースは glibc-2.12-1.132.el6 で、おそらく x86_64 のみインストールされていて、i686 はインストールされていない。
glibc-*.i686 をインストールしようとリポジトリを探すと glibc-2.12-1.80.e16.i686 が見つかるが、インストール済みの glibc-2.12-1.132.el6.x86_64 とバージョン・リリースが合わない。
リポジトリにある glibc-2.12-1.80.e16.x86_64 はバージョン・リリース番号が小さいため、差し替えられず、エラー。

 yum downgrade

"e16" (イーじゅうろく)ではなく "el6" (イーエルろく)です。
yum downgrade で指定するのは「パッケージ名-バージョン-リリース.アーキテクチャ」と全部指定してもいいですし、「パッケージ名.アーキテクチャ」や「パッケージ名」だけでもよきに計らってくれます。

yum --disablerepo="*" --enablerepo=media_default downgrade glibc.x86_64 glibc-common


でも、ちょっと待って。  

 CD/DVD の CentOS 6.x のバージョンは?

"media_default" リポジトリにある glibc-2.12-1.80.el6 は CentOS 6.3 ではないですか?
CentOS 6.5 またはそれ以上(6.6 〜 6.8)の CD/DVD を使えば、yum downgrade しなくてもいいはず。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/01 17:56

    確かに対象のOSバージョンが6.5で読み込んでいたメディアは6.3でした。
    バージョンが6.5のイメージでインストールしてみたところ無事完了することができました!
    ありがとうございます!

    キャンセル

0

yum groupinstall "X Window System" "GNOME Desktop Environment"

でどうですかねー

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

直接の回答でなくて恐縮ですが、X-windowなどの依存関係が複雑なものを後から入れるのはおすすめしません。
私も同じ経験がありますが、その時解決できても、後日、更新ができなくなってまた悩むことになります。

結論としてはこの際0からインストールしなおしたほうが良いと思います。

ご参考まで

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Linux

    4680questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    3310questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • VMware

    265questions

    VMwareとは、 ハードウェアで動作するOS上で仮想マシンを作成、実行するソフトウェアです。 Windows上でUNIX系OSを動作させたり、他のOS上で別の仮想OSを動作することが可能です。

  • yum

    184questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。