質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

node.jsのepel installでトランザクションの確認エラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,407

score 464

yum install nodejs npm --enablerepo=epel


を実行したところ「トランザクションの確認エラー」とでて

file /usr/lib/node_modules/npm/bin/node-gyp-bin/node-gyp conflicts between attempted installs of npm-1.3.6-5.el6.noarch and nodejs-0.10.46-1nodesource.el6.x86_64


上記のようなエラーがjsファイルやnode_modulesディレクトリ内のファイルで大量に吐き出されます。
共通している部分は以下となり

conflicts between attempted installs of npm-1.3.6-5.el6.noarch and nodejs-0.10.46-1nodesource.el6.x86_64


何かが競合しているというのは翻訳サイトでなんとなくわかりましたが
そのあと具体的に何をすれば解決につながるか見つけられずこちらにまいりました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

CentOSのバージョンはわかりませんが、こちらと同じ症状では?

node.js・npm のインストールでのエラー

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/08/20 12:10 編集

    申し訳ありません、こちらと同じだったかもしれません。
    centosのバージョンは6.8です。

    ベストアンサー様のsudo yum removeを自分のバージョンに置き換えて
    実行した結果エラーが出てしまいました。

    sudo yum remove nodejs-0.10.46-1nodesource.el6.x86_64
    読み込んだプラグイン:fastestmirror
    削除処理の設定をしています
    引数に一致しません: nodejs-0.10.46-1nodesource.el6.x86_64
    Loading mirror speeds from cached hostfile
    * base: ftp.iij.ad.jp
    * epel: www.ftp.ne.jp
    * extras: ftp.iij.ad.jp
    * remi-safe: rpms.remirepo.net
    * updates: ftp.iij.ad.jp
    パッケージ nodejs-0.10.46-1nodesource.el6.x86_64 は利用できますが、インストールしませんでした。
    削除と設定したパッケージはありません。

    質問内容が変わってきてしまいましたので
    あらためて自分で調査してみます。
    ありがとうございました。

    キャンセル

  • 2016/08/20 12:46

    この質問を閉じたい場合は、自分で回答を投稿してそれをベストアンサーにすれば行けると思います(私のは解決に至ってないのでBAでなくてよいです)。

    一点気になるのは、nodejs-0.10.46 というのはもう古すぎるバージョンですので、
    もう少し新しいバージョンをインストールする方法を探した方が良いと思います。

    候補は
    0.12.7以降 (ながらく使われていた版なのでみつかりやすいかも) か
    4.x (現状のLongTermSupport版)か
    6.x (10月からLongTermSupportになるはず)

    です。
    6が入るなら6で問題ないとは思います。

    この辺とかさんこうになるかも(0.12書いてないですね、無いのかな。)
    https://nodejs.org/en/download/package-manager/#enterprise-linux-and-fedora

    キャンセル

  • 2016/08/21 00:55

    度々ありがとうございます!
    質問を改めて投稿しそちらにもご回答いただきありがとうございましたm(_)m
    おかげさまで無事インストール、動作確認まで成功しました。
    続きはこちら
    https://teratail.com/questions/44959?whotofollow

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る