質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
docker-compose

docker-composeとは、複数のコンテナで構成されるサービスを提供する手順を自動的し管理を簡単にするツール。composeファイルを使用しコマンド1回で設定した全サービスを作成・起動することが可能です。

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Docker

Dockerは、Docker社が開発したオープンソースのコンテナー管理ソフトウェアの1つです

解決済

dockerでrails newをするもエラーがでてしまう

higakijin
higakijin

総合スコア0

docker-compose

docker-composeとは、複数のコンテナで構成されるサービスを提供する手順を自動的し管理を簡単にするツール。composeファイルを使用しコマンド1回で設定した全サービスを作成・起動することが可能です。

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Docker

Dockerは、Docker社が開発したオープンソースのコンテナー管理ソフトウェアの1つです

1回答

0評価

0クリップ

458閲覧

投稿2021/12/27 07:00

前提・実現したいこと

Docker初心者です。
AWSとDockerの勉強がしたくて、こちらのサイトのChapter1をすすめていたのですが、rails newでエラーがでてしまったので、エラーの意味と解消法をご教授願いたいです。

Nuxt.js + Ruby on Rails + AWS Fargate の開発・デプロイチュートリアル

発生している問題・エラーメッセージ

$ docker-compose run backend rails new . --api --force --database=mysql --skip-bundle [+] Running 1/0 ⠿ Container db Running 0.0s [+] Running 0/1 ⠿ backend Error 6.7s [+] Building 8.2s (9/11) => [internal] load build definition from Dockerfile 0.0s => => transferring dockerfile: 296B 0.0s => [internal] load .dockerignore 0.0s => => transferring context: 2B 0.0s => [internal] load metadata for docker.io/library/ruby:2.6.6 3.5s => [1/7] FROM docker.io/library/ruby:2.6.6@sha256:ee53ac01b7ec7d8d42f53175ed33c39474d40d4af43cccc13cb3370cef586845 0.0s => [internal] load build context 0.0s => => transferring context: 352B 0.0s => CACHED [2/7] RUN mkdir /app 0.0s => CACHED [3/7] WORKDIR /app 0.0s => CACHED [4/7] ADD Gemfile /app/Gemfile 0.0s => ERROR [5/7] RUN apt-get update -qq && apt-get install -y build-essential libpq-dev sudo gem install bundler:2.0.1 4.6s ------ > [5/7] RUN apt-get update -qq && apt-get install -y build-essential libpq-dev sudo gem install bundler:2.0.1: #9 4.118 Reading package lists... #9 4.448 Building dependency tree... #9 4.516 Reading state information... #9 4.582 E: Unable to locate package install #9 4.582 E: Unable to locate package bundler:2.0.1 #9 4.582 E: Couldn't find any package by glob 'bundler:2.0.1' #9 4.582 E: Couldn't find any package by regex 'bundler:2.0.1' ------ failed to solve: rpc error: code = Unknown desc = executor failed running [/bin/sh -c apt-get update -qq && apt-get install -y build-essential libpq-dev sudo gem install bundler:2.0.1]: exit code: 100

該当のソースコード

# backend/Gemfile source "https://rubygems.org" git_source(:github) { |repo_name| "https://github.com/#{repo_name}" } gem 'rails', '6.0.3'
# backend/Dockerfile FROM ruby:2.6.6 ENV LANG C.UTF-8 ENV TZ Asia/Tokyo RUN mkdir /app WORKDIR /app ADD Gemfile /app/Gemfile RUN apt-get update -qq && \ apt-get install -y build-essential \ libpq-dev \ sudo \ gem install bundler:2.0.1 RUN bundle install ADD . /app
# docker-compose.yml version: "3" services: db: container_name: db image: mysql:5.7.30 environment: TZ: Asia/Tokyo MYSQL_ALLOW_EMPTY_PASSWORD: "yes" volumes: - mysql_data:/var/lib/mysql ports: - 3307:3306 networks: app_net: ipv4_address: '172.20.0.2' backend: container_name: backend build: ./backend/ image: backend command: bundle exec rails server -b 0.0.0.0 tty: true stdin_open: true volumes: - ./backend:/app:cached - bundle_data:/usr/local/bundle:cached - /app/vendor - /app/tmp - /app/log - /app/.git environment: TZ: Asia/Tokyo depends_on: - db ports: - 5000:3000 # ポートフォワード networks: app_net: ipv4_address: '172.20.0.3' networks: app_net: driver: bridge ipam: driver: default config: - subnet: 172.20.0.0/24 volumes: mysql_data: bundle_data:

試したこと

Gemfileの

RUN

apt-get install -y build-essential \ libpq-dev \ sudo \ gem install bundler:2.0.1

の部分でエラーがでていたみたいなので、2.0.1を消して実行をしましたが、変化がなかったです。

補足情報(FW/ツールのバージョンなど)

Macbook airのM1を使っているのでそれ関連のエラーの可能性もありますが、調べてもわからないので質問させていただきます。

macOS Monterery 12.1
Docker version 20.10.11, build dea9396
Docker Compose version v2.2.1

よろしくお願いします。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

docker-compose

docker-composeとは、複数のコンテナで構成されるサービスを提供する手順を自動的し管理を簡単にするツール。composeファイルを使用しコマンド1回で設定した全サービスを作成・起動することが可能です。

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Docker

Dockerは、Docker社が開発したオープンソースのコンテナー管理ソフトウェアの1つです