質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.46%
Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Q&A

3回答

3823閲覧

rails new でフォルダが作成されない

iyonegaki

総合スコア19

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

0グッド

0クリップ

投稿2021/12/14 18:04

編集2021/12/14 18:12

前提・実現したいこと

rails newコマンドでdbフォルダlibフォルダなどが作成されない

発生している問題・エラーメッセージ

/Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/message_encryptor.rb:173:in `auth_data=': couldn't set additional authenticated data (OpenSSL::Cipher::CipherError) from /Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/message_encryptor.rb:173:in `_encrypt' from /Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/message_encryptor.rb:151:in `encrypt_and_sign' from /Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/encrypted_file.rb:76:in `encrypt' from /Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/encrypted_file.rb:50:in `write' from /Library/Ruby/Gems/2.6.0/gems/activesupport-6.0.3.6/lib/active_support/encrypted_configuration.rb:29:in `write' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/generators/rails/credentials/credentials_generator.rb:30:in `add_credentials_file_silently' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/generators/rails/app/app_generator.rb:177:in `credentials' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/generators/app_base.rb:155:in `build' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/generators/rails/app/app_generator.rb:332:in `create_credentials' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:134:in `block in invoke_all' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:134:in `each' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:134:in `map' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:134:in `invoke_all' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/group.rb:232:in `dispatch' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/base.rb:485:in `start' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/commands/application/application_command.rb:26:in `perform' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command' from /Library/Ruby/Gems/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/command/base.rb:69:in `perform' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/command.rb:46:in `invoke' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/lib/rails/cli.rb:18:in `<top (required)>' from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /Library/Ruby/Gems/2.6.0/gems/railties-6.0.3.6/exe/rails:10:in `<top (required)>' from /usr/local/bin/rails:23:in `load' from /usr/local/bin/rails:23:in `<main>'

試したこと

エラーについて調べましたが,ステージングや本番環境,AWSのことなど関係がなさそうなことしか検索にかからず原因が掴めませんでした.

補足情報(FW/ツールのバージョンなど)

OS: mac (m1)
ruby: ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]
rails: Rails 6.0.3.6

プログラミングというよりは環境構築に関する質問ですがよろしくお願いします.

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

winterboum

2021/12/14 23:18

1. どの folder で rails new しましたか 2. rails new なんとか としたと思いますが、その 「なんとか」folderはありませんか 3. その「なんとか」folderの中は確認しましたか?
ASOBU_dev

2021/12/14 23:41 編集

↑補足で追記依頼です 4. 上記ターミナルで、入力したコマンドを追記してください。(コピペしてください)
iyonegaki

2021/12/16 16:55 編集

回答を求めた立場にも関わらず返信が遅くなってしまい大変申し訳ございませんでした, また,追記依頼ありがとうございます. 以下のようにコマンドを打ち込みました. 1. どの folder で rails new しましたか /Users/ユーザー名/program/uber-eats-like 2. rails new なんとか としたと思いますが、その 「なんとか」folderはありませんか rails new backend --api と打ち込みuser-eats-like下にbackendフォルダは作成されました. 3. その「なんとか」folderの中は確認しましたか? backend下には以下のフォルダとファイルが作成されました. Gemfile Rakefile bin config.ru README.md app config 返信が遅くなってしまったこと,重ね重ねお詫び申し上げます. またご助言いただけたら幸いです.
winterboum

2021/12/16 21:07

う〜〜む やってることに間違いはなさそう。 なぜだ。
iyonegaki

2021/12/17 21:17

エラー文を検索かけても似たような症状は出てこず全く手がかりが掴めない状態です,, APIモードでなくても途中までしかファイルとフォルダが作成されない状態です.
guest

回答3

0

失礼します。
私も全く同じエラーが出ていまして、どのように解決されましたか?

投稿2022/03/24 08:25

scum

総合スコア5

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

/Libraryはroot管理者領域なので、扱いにくいでしょう。
homebrew + rbenv
で一般ユーザ領域でruby環境構築をお勧めします。

$ brew -v Homebrew 3.3.8 Homebrew/homebrew-core (git revision aa7ddd3ecc7; last commit 2021-12-19) $ rbenv versions system * 2.6.8 (set by /Users/owner/.rbenv/version) 2.7.5 3.0.3 $ ruby -v ruby 2.6.8p205 (2021-07-07 revision 67951) [arm64-darwin21]

投稿2021/12/22 17:21

technocore

総合スコア7247

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

よくわかりませんが、
couldn't set additional authenticated data (OpenSSL::Cipher::CipherError)
について調べたところ
https://stackoverflow.com/questions/69761113/rails-new-command-giving-errors
を見つけました

回答者の回答をみると、ruby3.0.3で入れなおす等すると治った模様です。

投稿2021/12/22 14:56

編集2021/12/22 14:58
youtubeuta

総合スコア150

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.46%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問