質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
Yarn

Yarnは、Facebook/Exponent/Google/Tildeが開発したJavaScriptのパッケージマネージャ。npmよりもインストールが速く、厳密にモジュールのバージョンを固定できるなど、npmの問題を解決。npmと互換性があり、同じpackage.jsonを使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

Q&A

解決済

1回答

5962閲覧

yarn のインストールでエラーとなる

bkprg

総合スコア16

Yarn

Yarnは、Facebook/Exponent/Google/Tildeが開発したJavaScriptのパッケージマネージャ。npmよりもインストールが速く、厳密にモジュールのバージョンを固定できるなど、npmの問題を解決。npmと互換性があり、同じpackage.jsonを使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

0グッド

0クリップ

投稿2021/11/26 13:03

yarn installコマンドを打つと下記のようなエラーが出ます。

error eslint@8.1.0: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "14.16.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

nodeのバージョンを
"^12.22.0 || ^14.17.0 || >=16.0.0".
にしろというエラーかと思い、14.17.0をインストールし、そちらを使うように変更しました。
node -v コマンドで確認したところ14.17.0となっていますが、yarn install時は同じエラーが出てしまいます。

どうしたら宜しいでしょうか?

環境
mac

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

自己解決

上記のコマンドはターミナルから実行していましたが、開発環境としてはVSCodeのターミナルを使用していたので、VS Code上から同じ動作をしました。
また、下記のリンク内の②パスを通すを実行してVSCode上のバージョンも変更され、yarn installができるようになりました。
https://qiita.com/whiteraccoon/items/0e12daa3ddd6eb816007

投稿2021/11/26 14:03

bkprg

総合スコア16

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問