質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.22%

bundle installでのrackエラー

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,365

takehiro_pink

score 29

railsアプリを作成するために、
$ rails new example
で作って、
$ bundle install --path vender/bundle
したら
Bundler::GemspecError: Could not read gem at /Users/example/Source/MyApp/depot/vender/bundle/ruby/2.1.0/cache/rack-1.4.5.gem. It may be corrupted.
An error occurred while installing rack (1.4.5), and Bundler cannot continue.
Make sure that `gem install rack -v '1.4.5'` succeeds before bundling.
rackでつまった。
なので、
$ gem install rack --version '1.4.5'
したらrackのインストールは成功した。
なのでもう一度
$ bundle install --path vender/bundle
したらまた同じエラーが出たので、解決策を教えていただきたいです。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

わたしのマシン (Mac 10.10.1) では ruby 2.1.5p273, rails (4.1.8), bundler (1.7.6) のような環境ですが、
gem list rack とすると rack (1.5.2) となります。

どんな環境 (OS, ruby バージョン, gem list の結果...) で作業をなさっていますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2014/11/24 20:13

    bundle updateした結果、

    Bundler::GemspecError: Could not read gem at /Users/takehiro/Source/MyApp/depot/vender/bundle/ruby/2.1.0/cache/rack-1.4.5.gem. It may be corrupted.
    An error occurred while installing rack (1.4.5), and Bundler cannot continue.
    Make sure that `gem install rack -v '1.4.5'` succeeds before bundling.

    が出てupdateすらも出来ませんでした。

    キャンセル

  • 2014/11/24 20:19

    次の2つが version 固定になってますね。
       gem 'rails', '3.2.21'
      gem 'rack','1.4.5'

    rails は 4 系でなくて、 3 系であることが必要ですか?
    3 系があることが必要なら gem 'rails', '~>3.2.21' としてみては。
    4 系でもよけrば、単に gem 'rails' との指定に。

    rack もバージョン指定を 無くして gem 'rack' とだけの指定に。

    そのうえで bundle install を再実行してみてください。

    キャンセル

  • 2014/11/24 20:21

    Gemfile.lock を削除してから、 bundle install したほうが良いかもしれません。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る