質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • ネットワーク

    547questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

  • ルーティング

    47questions

    ルーティングとは、TCP/IPネットワークにおいて、目的のホストまでパケットを送る為のパス選定のプロセスを言います。

アライドテレシスのL3スイッチ VLAN間で通信できるようにしたい

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,467

sauhor

score 1

前提・実現したいこと

研究で,アライドテレシスのx600-24TsというL3スイッチの設定を行っています.
複数のVLANを作成して,VLAN間で互いに通信したいです.
また,学内LAN用のVLAN(vlan5)を通して,VLAN10,VLAN20をインターネットにアクセスできるようにしたいです.
また,研究室内LAN用のVLAN(VLAN6)をとおして,研究室内にもアクセスできるようにしたいです.

発生している問題・エラーメッセージ

VLAN間での通信ができることを確認するため,VLAN10とVLAN20にそれぞれ1台ずつPC(PC1,PC2)を接続し,互いにコマンドプロンプト上でpingにより疎通確認を行ったところ,「要求がタイムアウトしました」となり,通信できません.確認のためほかのホストにもpingを行いました.

PC名   IPアドレス/サブネットマスク   デフォルトGW   所属VLAN   L3スイッチ物理ポート  
PC1 192.168.10.80/24 192.168.10.1 vlan10 port1.0.9
PC2 192.168.20.81/24 192.168.20.1 vlan20 port1.0.15
**[PC1]**
C:¥Users¥user02>ping 192.168.20.81

192.168.20.81 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

192.168.20.81 の ping 統計:
    パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)

C:¥Users¥user02>ping 192.168.20.1

192.168.20.1 に ping を送信しています 32 バイトのデータ:
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.20.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user02>ping 192.168.10.1

192.168.10.1 に ping を送信しています 32 バイトのデータ:
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.10.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user02>ping 8.8.8.8
C:¥Users¥user02>ping 192.168.20.81

192.168.20.81 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

192.168.20.81 の ping 統計:
    パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)

C:¥Users¥user02>ping 192.168.20.1

192.168.20.1 に ping を送信しています 32 バイトのデータ:
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.20.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user02>ping 192.168.10.1

192.168.10.1 に ping を送信しています 32 バイトのデータ:
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.10.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user02>ping 

8.8.8.8 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

8.8.8.8 の ping 統計:
    パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、


**[PC2]**
C:¥Users¥user04>ping 192.168.10.80

192.168.10.80 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

192.168.10.80 の ping 統計:
    パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

C:¥Users¥user04>ping 192.168.10.1

192.168.10.1 に ping を送信しています 32 バイトのデータ:
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.10.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.10.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user04>ping 192.168.20.1

192.168.20.1 に ping を送信しています 32 バイトのデータ:
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.20.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.20.1 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 0ms、最大 = 0ms、平均 = 0ms

C:¥Users¥user04>ping 8.8.8.8

8.8.8.8 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

8.8.8.8 の ping 統計:
    パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

実行した設定コマンド

マニュアルを参考に設定しました.
念のため,erase startup-configを実行し,初期状態で設定しました.

AlliedWare Plus (TM) 5.4.2 12/13/12 14:56:11

awplus>enable
awplus#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
awplus(config)#vlan database
awplus(config-vlan)#vlan 5,6,10,20
awplus(config-vlan)#exit
awplus(config)#interface port1.0.1
awplus(config-if)#switchport mode access
awplus(config-if)#switchport access vlan 5
awplus(config-if)#exit
awplus(config)#interface port1.0.2
awplus(config-if)#switchport mode access
awplus(config-if)#switchport access vlan 6
awplus(config-if)#exit
awplus(config)#interface port1.0.7-1.0.12
awplus(config-if)#switchport mode access
awplus(config-if)#switchport access vlan 10
awplus(config-if)#exit
awplus(config)#interface port1.0.13-1.0.16
awplus(config-if)#switchport mode access
awplus(config-if)#switchport access vlan 20
awplus(config-if)#exit
awplus(config)#interface vlan5
awplus(config-if)#ip address dhcp
awplus(config-if)#exit
awplus(config)#interface vlan6
awplus(config-if)#ip address dhcp
awplus(config-if)#exit
awplus(config)#interface vlan10
awplus(config-if)#ip address 192.168.10.1/24
awplus(config-if)#exit
awplus(config)#interface vlan20
awplus(config-if)#ip address 192.168.20.1/24
awplus(config-if)#exit
awplus(config)#do show ip interface
Interface             IP-Address         Status          Protocol
lo                    unassigned         admin up        running
vlan1                 unassigned         admin up        down
vlan5                 172.16.22.233/22   admin up        running
vlan6                 192.168.11.173/24  admin up        running
vlan10                192.168.10.1/24    admin up        running
vlan20                192.168.20.1/24    admin up        down
awplus(config)#do show ip route
Codes: C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       * - candidate default

Gateway of last resort is 172.16.20.1 to network 0.0.0.0

S*      0.0.0.0/0 [1/0] via 172.16.20.1, vlan5
                  [1/0] via 192.168.11.1, vlan6
C       172.16.20.0/22 is directly connected, vlan5
C       192.168.10.0/24 is directly connected, vlan10
C       192.168.11.0/24 is directly connected, vlan6

設定ファイル

現在の設定ファイルを示します.

awplus#show running-config
!
service password-encryption
!
no banner motd
!
username manager privilege 15 password 8 $1$bJoVec4D$JwOJGPr7YqoExA0GVasdE0
!
no service ssh
!
service telnet
no service telnet ipv6
!
service http
!
clock timezone JST plus 9:00
!
no snmp-server ipv6
!
aaa authentication enable default local
aaa authentication login default local
!
ip domain-lookup
!
no service dhcp-server
!
no ip multicast-routing
!
spanning-tree mode rstp
!
no ipv6 mld snooping
!
switch 1 provision x600-24
!
vlan database
 vlan 5-6,10,20 state enable
!
interface port1.0.1
 switchport
 switchport mode access
 switchport access vlan 5
!
interface port1.0.2
 switchport
 switchport mode access
 switchport access vlan 6
!
interface port1.0.3-1.0.6
 switchport
 switchport mode access
!
interface port1.0.7-1.0.12
 switchport
 switchport mode access
 switchport access vlan 10
!
interface port1.0.13-1.0.16
 switchport
 switchport mode access
 switchport access vlan 20
!
interface port1.0.17-1.0.24
 switchport
 switchport mode access
!
interface vlan5-6
 ip address dhcp
!
interface vlan10
 ip address 192.168.10.1/24
!
interface vlan20
 ip address 192.168.20.1/24
!
!
line con 0
line vty 0 4
!
end

awplus#

よろしくお願いいたします.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • over

    2016/05/25 09:17

    実際の設定されているコンフィグを提示されてはいかがでしょうか? デフォルトで有効になっている設定も表示されるかと思います。 以下で取得できるのではないでしょうか? > show running-config なお、別セグメントからpingの応答があるということは、L3スイッチルーティング、端末のデフォルトゲートウェイの設定は問題ないと考えます。

    キャンセル

回答 3

checkベストアンサー

0

設定ファイルを見た限りでは問題ないように見えます。
「情報の追加・修正の依頼をする」にも記載させて頂きましたが、PC1、PC2それぞれからpingを実行して、違うセグメントからの応答があるのであれば、L3スイッチにてルーティングが行われていると考えてよいと思います。
また、端末に設定したデフォルトゲートウェイの設定も間違いないということだと思います。

ちなみに、この環境は検証環境とかで、提示された登場人物以外は存在しない環境ですか?
IPが重複しているとかなければ、端末のサブネットマスクの設定が正しいか確認してみては如何でしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/25 17:42

    回答ありがとうございます!
    この環境は検証環境です.IPの重複,サブネットマスクの設定の確認を行いましたが,問題なく正常に設定されていました.
    リセットスイッチを押してハードリセットも行いましたが,結果は変わりませんでした.
    担当教官にも相談しましたが,解決できず...
    今回は諦めて,別の機器(ルータ)を使ってVLAN間の通信を行うようにしたいと思います.
    回答ありがとうございました!

    キャンセル

0

ciscoならip routingが必要だけどrouting tableを見る限りでは不要かな?PCがping無視設定にはなってないよね?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/24 08:47

    回答ありがとうございます!
    ciscoの製品はあまり触ったことがないのでよくわからないのですが,アライドの製品にもip routingに対応するようなコマンドはあるのでしょうか?

    PCのping設定ですが,ご指摘の通り無視するようになっていました!
    pingに応答するように設定を変更し,L3スイッチからpingした結果を示します.

    しかし,VLAN間(PC間)ではpingはとおりませんでした...

    ```
    awplus(config)#do ping 192.168.10.80
    PING 192.168.10.80 (192.168.10.80) 56(84) bytes of data.
    64 bytes from 192.168.10.80: icmp_seq=1 ttl=128 time=1.53 ms
    64 bytes from 192.168.10.80: icmp_seq=2 ttl=128 time=1.48 ms
    64 bytes from 192.168.10.80: icmp_seq=3 ttl=128 time=1.48 ms
    64 bytes from 192.168.10.80: icmp_seq=4 ttl=128 time=1.47 ms
    64 bytes from 192.168.10.80: icmp_seq=5 ttl=128 time=1.48 ms

    --- 192.168.10.80 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 4003ms
    rtt min/avg/max/mdev = 1.477/1.493/1.534/0.040 ms
    awplus(config)#do ping 192.168.20.81
    PING 192.168.20.81 (192.168.20.81) 56(84) bytes of data.
    64 bytes from 192.168.20.81: icmp_seq=1 ttl=128 time=1.57 ms
    64 bytes from 192.168.20.81: icmp_seq=2 ttl=128 time=1.46 ms
    64 bytes from 192.168.20.81: icmp_seq=3 ttl=128 time=1.47 ms
    64 bytes from 192.168.20.81: icmp_seq=4 ttl=128 time=1.49 ms
    64 bytes from 192.168.20.81: icmp_seq=5 ttl=128 time=1.49 ms

    --- 192.168.20.81 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 4006ms
    rtt min/avg/max/mdev = 1.466/1.500/1.570/0.044 ms
    ```

    キャンセル

  • 2016/05/25 02:21

    google検索したらenable ipとかenable ip forwardingというコマンドが出てきましたが、これですかねぇ・・・ただ、デフォルトで有効という資料も散見します・・・

    キャンセル

0

なかなか解決できないので,今回は諦めて,別の機器(ルータ)を使ってVLAN間の通信を行うようにしたいと思います.

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

関連した質問

同じタグがついた質問を見る

  • ネットワーク

    547questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

  • ルーティング

    47questions

    ルーティングとは、TCP/IPネットワークにおいて、目的のホストまでパケットを送る為のパス選定のプロセスを言います。