質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • ネットワーク

    642questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品

Cisco 1812J VLANに接続したPCからインターネット接続できない

解決済

回答 5

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 6,079

yotsuba

score 12

<追記5/31>
・interface Dialer 1 へ access-list 100 を適用
・VLAN 1 へ access-list 1 を適用
・access-list 1 permit 192.168.11.0 0.0.0.255
  を追加
↑この時点でVLAN間PING応答できるようになり、インターネット接続できた。

<追記5/22>
・VLAN100 に ip nat inside を追加設定
・以下3つの結果をを追記しました。
 show ip route 
 show interfaces Dialer1
 show ip interface brief
・コンソールからのPING結果
  ping 192.168.0.1      NG
  ping 192.168.11.100      OK
  ping www.google.co.jp  OK


初心者です。よろしくお願いします。

自宅ルータをBuffalo無線ルータからCisco1812Jに交換して設定しています。

PPPoEの認証はうまくいき、グローバルIPは取得できました。
スイッチポートFe2(VLANなし)に接続したPCはDHCPでIPアドレス・DNS設定され、インターネット接続できることを確認しました。

しかし、Fe9にVLANを設定し、PCをつなぐとインターネットに接続できません。

VLAN間ルーティングができていないと思い、
Router01(config)#ip routing
を実行しましたが、状況に変化はありません。

どんな設定を追加・修正すればよいのでしょうか。

<概要>
PC 192.168.11.123/24
VLAN1 192.168.0.1/24
VLAN100 192.168.11.100/24  ( Fe9 )

PC → VLAN1 192.168.0.1/24  : PING NG 
PC → VLAN100 192.168.11.100/24 : PING OK

イメージ説明

以下、show run の結果を載せます。
※コードは「C#」としてますが、強調表示させないためのものです。

Current configuration : 3574 bytes
!
! Last configuration change at 16:31:49 UTC Sat May 21 2016
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router01
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 *************
enable password 7 *************
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.0.1 192.168.0.100
!
ip dhcp pool dhcplan01
 import all
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 lease 0 4
!
!
!
ip cef
ip domain name myhome.com
ip name-server *************
ip name-server *************
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1812-J/K9 sn *************
username ************ password 7 ****************
!
!
ip ssh version 2
!
!
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
 shutdown
!
interface FastEthernet4
 no ip address
 shutdown
!
interface FastEthernet5
 no ip address
 shutdown
!
interface FastEthernet6
 no ip address
 shutdown
!
interface FastEthernet7
 no ip address
 shutdown
!
interface FastEthernet8
 no ip address
 shutdown
!
interface FastEthernet9
 switchport access vlan 100
 no ip address
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan100
 ip address 192.168.11.100 255.255.255.0
 ip access-group 1 in
 ip nat inside
 ip virtual-reassembly in

!
interface Dialer1
 mtu 1454
 ip address negotiated
 ip access-group 100 in
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 dialer idle-timeout 0
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname *********@******.ne.jp
 ppp chap password 7 ********************
 ppp ipcp dns request accept
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 deny   ip 0.0.0.0 0.255.255.255 any
access-list 100 deny   ip 10.0.0.0 0.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 deny   ip 169.254.0.0 0.0.255.255 any
access-list 100 deny   ip 172.16.0.0 0.15.255.255 any
access-list 100 deny   ip 192.0.2.0 0.0.0.255 any
access-list 100 deny   ip 192.168.0.0 0.0.0.255 any
access-list 100 deny   ip 224.0.0.0 15.255.255.255 any
access-list 100 deny   ip 240.0.0.0 15.255.255.255 any
access-list 100 deny   tcp any any range 137 139
access-list 100 deny   tcp any range 137 139 any
access-list 100 deny   udp any any range netbios-ns netbios-ss
access-list 100 deny   udp any range netbios-ns netbios-ss any
access-list 100 deny   tcp any any eq 445
access-list 100 deny   tcp any eq 445 any
access-list 100 deny   udp any any eq 445
access-list 100 deny   udp any eq 445 any
access-list 100 deny   tcp any any eq telnet
access-list 100 permit ip any any
dialer-list 1 protocol ip permit
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 password 7 *************
 logging synchronous
 login
line aux 0
 password 7 *************
 login
line vty 0 4
 password 7 *************
 login local
 transport input ssh
!
end
Router01#show interfaces Dialer1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is 219.126.41.36/32
  MTU 1454 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 01:01:27
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     62 packets input, 4974 bytes
     1610 packets output, 83047 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1454 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Stopped: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:06, output never, output hang never
  Last clearing of "show interface" counters 01:01:22
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     495 packets input, 11065 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1617 packets output, 83195 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Router01#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.11.0/24 is directly connected, Vlan100
L        192.168.11.100/32 is directly connected, Vlan100
      219.126.41.0/32 is subnetted, 1 subnets
C        219.126.41.36 is directly connected, Dialer1
      220.148.136.0/32 is subnetted, 1 subnets
C        220.148.136.242 is directly connected, Dialer1
Router01#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
BRI0                       unassigned      YES NVRAM  administratively down down
BRI0:1                     unassigned      YES unset  administratively down down
BRI0:2                     unassigned      YES unset  administratively down down
Dialer1                    219.126.41.36   YES IPCP   up                    up
FastEthernet0              unassigned      YES NVRAM  down                  down
FastEthernet1              unassigned      YES NVRAM  up                    up
FastEthernet2              unassigned      YES unset  down                  down
FastEthernet3              unassigned      YES unset  administratively down down
...
FastEthernet8              unassigned      YES unset  administratively down down
FastEthernet9              unassigned      YES unset  up                    up
NVI0                       unassigned      YES unset  administratively down down
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
Vlan1                      192.168.0.1     YES NVRAM  up                    up
Vlan100                    192.168.11.100  YES NVRAM  up                    up
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • Stripe

    2016/05/22 12:36

    ちなみに、試験用のPCは何台持ってますか?

    キャンセル

  • yotsuba

    2016/05/22 12:41

    疎通確認に使っているPCは1台で、図にある Fe2 と Fe9 に接続するPCとして設定を切り替えながら使っています。

    試験用とは別にコンソールポート接続&ネット接続のPCが1台あります。

    キャンセル

  • Stripe

    2016/05/22 13:00

    Fe2がリンクダウンすると、VLAN1もダウンします。Fe9がリンクダウンするとVLAN100もダウンします。

    キャンセル

  • yotsuba

    2016/05/22 13:21

    ありがとうございます。
    コンソール接続用のPCを Fe2 に接続してVLAN1のUPを確認しました。

    現在はVLAN100(Fe9)もUPを維持していますが、Fe9に接続しているPCは外部へ通信していない状況です。

    キャンセル

回答 5

checkベストアンサー

+1

アクセスリストで
access-list 1 permit 192.168.0.0 0.0.0.255
しか許可されていないのでVLAN100についても追加したほうがいいとは思います。ちなみにaccess-list 100については定義だけされていて適用されている場所がわかりません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/24 10:11

    ありがとうございます。
    ちょっと検証の時間が取れていないので、確認/設定できたら結果を記載しますので、またよろしくお願いします。

    キャンセル

+1

ルータのことはよくわかりませんが

PC 192.168.11.123/24 
VLAN1 192.168.0.1/24 
VLAN100 192.168.11.100/24  ( Fe9 )

サブネットマスクを見れば分かるように、
PC と VLAN1 は別ネットワークですよね。
そことつなぐならデフォルトゲートウェイ的な
ものを設定する必要があるのではないでしょうか。

http://d.hatena.ne.jp/clmind/20080707/1215433523

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/22 11:56

    コメントありがとうございます。

    PCとVLAN1は別ネットワークです。
    PCのデフォルトGWは「192.168.11.100」「192.168.0.1」どちらに設定しても通信できませんでした。

    ルータにデフォルトルートを設定するとできるかと思い、下のコマンドを試しましたが怒られてしまいました。
    Router01(config)#ip route 192.168.11.0 255.255.255.0 192.168.0.1
    %Invalid next hop address (it's this router)

    「VLAN間ルーティングできていない」と思ったのは、ご指摘のページを読んでの感想です。

    キャンセル

0

端末のデフォルトゲートウェイとルータのshow ip routeの結果を見てみるといいと思いますよ

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/22 11:38

    コメントありがとうございます。

    show ip route の結果を追記しました。

    Dialer1のGlobalIP割当が2つあるように見えるのが不思議ですが、DHCP接続したPCから見ると「219.126.41.36」で外部に接続していました。

    VLAN100に接続したPCの場合、デフォルトGWは「192.168.11.100」「192.168.0.1」どちらの場合も外部へは通信できませんでした。

    キャンセル

0

自宅ルータをCisco1812Jにするとは…自宅L3スイッチをCatalyst3560CGにする私より通ですね。Ciscoシリーズは設定したことがあるのですが、PPPoEは設定したことが無いので、ちょっとしたアドバイスだけしかできません。ごめんなさい。

もし、おかしいとしたらInterface Dialer1のPPPoE設定部分だと思われます。PPPoEへの接続は正常にできていますでしょうか?次のコマンドで状態を確認してみてください。

# show interfaces Dialer1
-> up になっているか? IPアドレスが割り当てられているか
# show ip route
-> 0.0.0.0/0 が Dialer1 になっているか?


Dialer1 のIPアドレスがわかればそこにPINGが行くかどうかを確認してみてください。後気になる点としては、Interface Vlan100 にも ip nat inside がいるような気がします。PPPoEが正常に動作しているようであれば、こちらも試して見てください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/22 12:04

    コメントありがとうございます。

    # show interfaces Dialer1
     -> up / グローバルIPアドレス取得
    # show ip route
     -> 0.0.0.0/0 : Dialer1 connected

    教えて頂いたコマンドの結果は上の追記の通り、問題なさそうでした。
    ただ、VLAN1(192.168.0.1)へのPING応答しない原因はわかっていません。
    この状況でもDHCPでは外部へ通信できています。

    VLAN100への ip nat inside を設定しましたが、状況は変わらずです。

    気になるのは show ip interface brief の結果でVLAN1のProtocol「down」
    になっている点です。。。

    キャンセル

  • 2016/05/22 13:23

    Stripeさんのアドバイスに従って、Fe2にPCを接続しVLAN1のProtocol「up」になりましたが、Fe9に接続したPCは外部へ通信できていない状況です。

    キャンセル

0

皆様、回答ありがとうございました。少し時間が経ってしまいましたが、解決しました。

質問上部に追記している通り、3つの修正を加えました。
・interface Dialer 1 へ access-list 100 を適用 
・VLAN 1 へ access-list 1 を適用 
・access-list 1 permit 192.168.11.0 0.0.0.255  を追加 

3番目の修正を加えた時点でVLAN間PING応答できるようになり、インターネット接続できました。
そもそも、VLAN100に設定したIPアドレス【192.168.11.100】に対してPCからPING応答がない時点で
アクセスリストと気づくべきだったと反省しています。

また機会がありましたら、よろしくお願いします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • ネットワーク

    642questions

    ネットワークとは、複数のコンピューター間を接続する技術です。インターネットが最も主流なネットワークの形態で、TCP/IP・HTTP・DNSなどの様々なプロトコルや、ルータやサーバーなどの様々な機器の上に成り立っています。

  • Cisco

    117questions

    シスコ(Cisco Systems,Inc.)は、アメリカ合衆国に本社を置く、世界最大のコンピュータネットワーク機器開発会社及び同社の製品