質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.42%
npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

nodist

nodistは、Windows向けのNode.jsのバージョン管理ツール。各バージョンを指定したインストール/アンインストールや、バージョンの切り替えが容易になります。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

GitHub

GitHubは、Gitバージョン管理システムを利用したソフトウェア開発向けの共有ウェブサービスです。GitHub商用プランおよびオープンソースプロジェクト向けの無料アカウントを提供しています。

JavaScript

JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

Q&A

解決済

2回答

4886閲覧

nodistでnpmをインストールできない

_akasa

総合スコア5

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

nodist

nodistは、Windows向けのNode.jsのバージョン管理ツール。各バージョンを指定したインストール/アンインストールや、バージョンの切り替えが容易になります。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

GitHub

GitHubは、Gitバージョン管理システムを利用したソフトウェア開発向けの共有ウェブサービスです。GitHub商用プランおよびオープンソースプロジェクト向けの無料アカウントを提供しています。

JavaScript

JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

0グッド

0クリップ

投稿2021/07/12 11:10

前提・実現したいこと

npmをインストールをしてその後vue CLIをインストールしたいです。原因が分からいので

発生している問題・エラーメッセージ

C:\Program Files (x86)\Nodist\bin>nodist npm 6.14.13 npm 6.14.13 {"message":"Bad credentials","documentation_url":"https://docs.github.com/rest"}. Sorry.

試したこと

npmをインストールするときにはnodejsのリリース一覧をみてnodejsに対応するnpmをインストールしています。
documentation_urlに記載されてるページに飛んだんですけど、同じエラーメッセージが書いてある記述が見当たりませんでした。
githubのrest apiを使うときに何か必要なものがあるのか調べましたが特になさそうでした。
https://slash-mochi.net/?p=3911 このサイトをみたりしましたがコマンドnpm -vを実行しても下のエラーがでます。

Sorry, there's a problem with nodist. Couldn't resolve npm version spec 6.14.12 : Couldn't find any matching version

補足情報(FW/ツールのバージョンなど)

windows 10
chrome
コマンドプロンプト使用

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答2

0

自己解決

自己解決しました。上のようにバージョンを指定するコマンドは理由は分かりませんがうまく機能しません。
コマンド nodist npm matchでnpmをインストールしようとしたらできました。

投稿2021/09/02 11:32

_akasa

総合スコア5

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

こちらの記事にあるように、Nodistは数年間更新がなく、最新のNodeに対応していませんので、Node.js公式からインストールするか、Dockerを使うか、あるいはWSL2を用いてLinux上で別のバージョン管理アプリをインストールするかのどれかで試してみてください。

投稿2021/07/16 06:09

kaito3desuyo

総合スコア143

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.42%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問