質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Realm

RealmとはSQLiteやCore Dataに代わるモバイルデータベースです。iOSとAndroidの両方でサポートされています。

Android Studio

Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

Kotlin

Kotlinは、ジェットブレインズ社のアンドリー・ブレスラフ、ドミトリー・ジェメロフが開発した、 静的型付けのオブジェクト指向プログラミング言語です。

受付中

android studio kotlinでrealm導入エラーを解決したい

gan_
gan_

総合スコア2

Realm

RealmとはSQLiteやCore Dataに代わるモバイルデータベースです。iOSとAndroidの両方でサポートされています。

Android Studio

Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

Kotlin

Kotlinは、ジェットブレインズ社のアンドリー・ブレスラフ、ドミトリー・ジェメロフが開発した、 静的型付けのオブジェクト指向プログラミング言語です。

2回答

0評価

0クリップ

1425閲覧

投稿2021/05/26 14:59

編集2022/01/12 10:55

前提・実現したいこと

androidアプリ開発初心者です。書籍とネットをしながら少しずつ進めています。
データベースの使い方を学ぼうと思い、以下の参考ページを見ながらrealmを試そうと思っています。
https://qiita.com/orimomo/items/bc1f2065f44104176f7f

行ったことはrealm導入として、以下の2項目を追加しただけです。

build.gradle(project:)のdepenciesに以下を追加。

kotlin

dependencies { classpath "io.realm:realm-gradle-plugin:6.0.2" }

build.gradle(:app)に以下を追加。

kotlin

apply plugin: 'kotlin-kapt' apply plugin: 'realm-android'

発生している問題・エラーメッセージ

以下のような、エラーが発生しました。

A problem occurred configuring root project 'MyMemo'. > Could not resolve all artifacts for configuration ':classpath'. > Could not find io.realm:realm-gradle-plugin:6.0.2. Searched in the following locations: - https://dl.google.com/dl/android/maven2/io/realm/realm-gradle-plugin/6.0.2/realm-gradle-plugin-6.0.2.pom - https://repo.maven.apache.org/maven2/io/realm/realm-gradle-plugin/6.0.2/realm-gradle-plugin-6.0.2.pom Required by: project : Possible solution: - Declare repository providing the artifact, see the documentation at https://docs.gradle.org/current/userguide/declaring_repositories.html

該当のソースコード

build.gradel(:app)は以下です。

kotlin

plugins { id 'com.android.application' id 'kotlin-android' } apply plugin: 'kotlin-kapt' apply plugin: 'realm-android' android { compileSdkVersion 30 buildToolsVersion "30.0.3" defaultConfig { applicationId "com.example.mymemo" minSdkVersion 19 targetSdkVersion 30 versionCode 1 versionName "1.0" testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro' } } kotlinOptions { jvmTarget = '1.8' } buildFeatures { viewBinding true } } dependencies { implementation "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" implementation 'androidx.core:core-ktx:1.5.0' implementation 'androidx.appcompat:appcompat:1.3.0' implementation 'com.google.android.material:material:1.3.0' implementation 'androidx.constraintlayout:constraintlayout:2.0.4' implementation 'androidx.navigation:navigation-fragment-ktx:2.3.5' implementation 'androidx.navigation:navigation-ui-ktx:2.3.5' testImplementation 'junit:junit:4.+' androidTestImplementation 'androidx.test.ext:junit:1.1.2' androidTestImplementation 'androidx.test.espresso:espresso-core:3.3.0' }

build.gradle(project:)は以下です。

kotlin

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { ext.kotlin_version = "1.5.0" repositories { google() mavenCentral() } dependencies { classpath "com.android.tools.build:gradle:4.2.0" classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" classpath 'io.realm:realm-gradle-plugin:6.0.2' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { google() mavenCentral() jcenter() // Warning: this repository is going to shut down soon } } task clean(type: Delete) { delete rootProject.buildDir }

試したこと

エラーメッセージやrealmの導入方法をググって対処方法を探してみましたが、探しきれませんでした・・・。

補足情報(FW/ツールのバージョンなど)

android studio 4.2

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

hoshi-takanori

2021/05/26 18:07

build.gradle (:app と書いてあるけど、こっちが Project のような…) の buildscript の repositories にも jcenter() が必要かも。
gan_

2021/06/02 14:02 編集

ご指摘ありがとうございます。build.gradleの修正しました。 buildscript の repositories に jcenter() を加えてみましたが、別のエラー ``` Build file 'C:\Users\****\AndroidStudioProjects\MyMemo\app\build.gradle' line: 7 A problem occurred evaluating project ':app'. > Failed to apply plugin 'realm-android'. > Configuration with name 'kapt' not found. ``` なる(もともとのエラーが解決したかどうかわかりませんが・・・)投稿と違うエラーが出てしまいました。
hoshi-takanori

2021/05/31 18:52

'io.realm:realm-gradle-plugin:6.0.2' ってだいぶ古いですね。最新 (10.5.0) なら jcenter() も不要みたいです。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Realm

RealmとはSQLiteやCore Dataに代わるモバイルデータベースです。iOSとAndroidの両方でサポートされています。

Android Studio

Android Studioは、 Google社によって開発された、 Androidのネイティブアプリケーション開発に特化した統合開発ツールです。

Kotlin

Kotlinは、ジェットブレインズ社のアンドリー・ブレスラフ、ドミトリー・ジェメロフが開発した、 静的型付けのオブジェクト指向プログラミング言語です。