質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.46%
npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

Q&A

解決済

1回答

7016閲覧

npm install実行時のエラー

KU112

総合スコア1

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

0グッド

0クリップ

投稿2021/04/17 16:23

お世話になります。Node.js周りの初心者です。

SkyWayさんのSkyWay Conferenceを動作させようとしています。
https://github.com/skyway/skyway-conf

環境:
npm -v
-> 7.10.0
node -v
-> v12.13.1

ReadMeの1番、2番までは順調に設定を行うことができました。

しかし3番の
$ npm install
を行うと以下のように大量にエラーが出てしまいます。

npm ERR! code 1 npm ERR! git dep preparation failed npm ERR! command /usr/local/bin/node /usr/local/lib/node_modules/npm/bin/npm-cli.js install --force --cache=/Users/k/.npm --prefer-offline=false --prefer-online=false --offline=false --no-progress --no-save --no-audit npm ERR! > enum@2.3.0 prepublish npm ERR! > gulp npm ERR! npm WARN using --force Recommended protections disabled. npm ERR! npm WARN deprecated request@2.11.4: request has been deprecated, see https://github.com/request/request/issues/3142 npm ERR! npm WARN deprecated forEachAsync@2.2.1: Please use 'foreachasync' instead. See https://www.npmjs.com/package/foreachasync npm ERR! npm WARN deprecated natives@1.1.6: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x. npm ERR! npm WARN deprecated left-pad@0.0.3: use String.prototype.padStart() npm ERR! npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated npm ERR! npm WARN deprecated to-iso-string@0.0.2: to-iso-string has been deprecated, use @segment/to-iso-string instead. npm ERR! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated line-numbers@0.2.0: Copy its ~20 LOC directly into your code instead. npm ERR! npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js npm ERR! npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated npm ERR! npm WARN deprecated cryptiles@0.2.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm ERR! npm WARN deprecated chokidar@1.7.0: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. npm ERR! npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5 npm ERR! npm WARN deprecated boom@0.4.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm ERR! npm WARN deprecated sntp@0.2.4: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues. npm ERR! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2. npm ERR! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm ERR! npm WARN deprecated mkdirp@0.3.0: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.) npm ERR! npm WARN deprecated mkdirp@0.3.5: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.) npm ERR! npm WARN deprecated mkdirp@0.3.5: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.) npm ERR! npm WARN deprecated gulp-util@2.2.20: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5 npm ERR! npm WARN deprecated gulp-util@2.2.20: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5 npm ERR! npm WARN deprecated hoek@0.9.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial). npm ERR! npm WARN deprecated node-uuid@1.4.8: Use uuid module instead npm ERR! npm WARN deprecated mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.) npm ERR! npm WARN deprecated request@2.46.0: request has been deprecated, see https://github.com/request/request/issues/3142 npm ERR! npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years. npm ERR! npm WARN deprecated hawk@1.1.1: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues. npm ERR! npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade npm ERR! npm WARN deprecated istanbul@0.2.16: This module is no longer maintained, try this instead: npm ERR! npm WARN deprecated npm i nyc npm ERR! npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives. npm ERR! npm WARN deprecated highlight.js@7.5.0: Version no longer supported. Upgrade to @latest npm ERR! npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead: npm ERR! npm WARN deprecated npm i nyc npm ERR! npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives. npm ERR! npm WARN deprecated buffer@2.1.13: This version of 'buffer' is out-of-date. You must update to v2.8.3 or newer npm ERR! npm WARN deprecated core-js@0.6.1: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3. npm ERR! npm WARN deprecated connect@2.12.0: connect 2.x series is deprecated npm ERR! fs.js:27 npm ERR! const { Math, Object } = primordials; npm ERR! ^ npm ERR! npm ERR! ReferenceError: primordials is not defined npm ERR! at fs.js:27:26 npm ERR! at req_ (/Users/k/.npm/_cacache/tmp/git-clone-c2a6067a/node_modules/natives/index.js:143:24) npm ERR! at Object.req [as require] (/Users/k/.npm/_cacache/tmp/git-clone-c2a6067a/node_modules/natives/index.js:55:10) npm ERR! at Object.<anonymous> (/Users/k/.npm/_cacache/tmp/git-clone-c2a6067a/node_modules/vinyl-fs/node_modules/graceful-fs/fs.js:1:37) npm ERR! at Module._compile (internal/modules/cjs/loader.js:959:30) npm ERR! at Object.Module._extensions..js (internal/modules/cjs/loader.js:995:10) npm ERR! at Module.load (internal/modules/cjs/loader.js:815:32) npm ERR! at Function.Module._load (internal/modules/cjs/loader.js:727:14) npm ERR! at Module.require (internal/modules/cjs/loader.js:852:19) npm ERR! at require (internal/modules/cjs/helpers.js:74:18) npm ERR! npm ERR! code 1 npm ERR! npm ERR! path /Users/k/.npm/_cacache/tmp/git-clone-c2a6067a npm ERR! npm ERR! command failed npm ERR! npm ERR! command sh -c gulp npm ERR! npm ERR! npm ERR! A complete log of this run can be found in: npm ERR! npm ERR! /Users/k/.npm/_logs/2021-04-17T14_26_53_167Z-debug.log npm ERR! A complete log of this run can be found in: npm ERR! /Users/k/.npm/_logs/2021-04-17T14_26_57_629Z-debug.log

調べてみると以下のようなコマンドも出てきて試しましたが状況変わらずでした。
npm cache clean --force

調べているのですが原因と解決策が良く分かっておりません。どなたかお分かりになる方がいらっしゃいましたらご教示いただけますと大変助かります。
(不足している情報などありましたらお申し付けください。)

お忙しい所大変申し訳ありませんが、よろしくお願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hoshi-takanori

2021/04/17 23:49

npm install の代わりに yarn install したら成功しました。動かしてませんが…。
meg_

2021/04/18 01:54

ログは確認されましたか?より詳細なエラー原因が載っていないでしょうか?
KU112

2021/04/19 08:17

(順番前後してしまいすみません) megさん、ありがとうございます。一応ログを見てみましたが、コンソールに表示されている内容と同じものがログファイルに書き込まれているように見えました。
KU112

2021/04/19 08:18

hoshi-takanoriさん、ありがとうございます! yarn installの方であればその先のrun devの手順まで含めて正常に動作することができました! 先に進めそうです。 お二方とも本当にありがとうございました。大変助かりました。
guest

回答1

0

自己解決

npm installの代わりにyarn installを使用することで正常に動作することができました。

投稿2021/04/19 08:19

KU112

総合スコア1

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.46%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問