質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.36%

google chromeをDocker環境にインストールしたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,374

score 1

前提・実現したいこと

現在docker-compose にて開発環境構築を行っています。
しかしgoogle chromeが依存パッケージエラーにてインストールされずbuildできない状態です。

この依存パッケージエラーを解消し、docker-compose にてbuildを行たいです。

またDockerのバージョンがプレビュー版のため、エラーがmacのCPU(ARM64とAMD64)によるものなのか、単に依存パッケージが悪いのか同様の症状がでてエラーを解消した方がいたらコメントいただきたいです。

google-chromeにはcpuの互換性があるかどうかもご教示願いたいです。

バージョン: 11.1 Big Sur
CPU M1チップ、ARM64

発生している問題・エラーメッセージ

The following packages have unmet dependencies:
#12 277.2  google-chrome-stable:amd64 : Depends: libasound2:amd64 (>= 1.0.16) but it is not installable
#12 277.2                               Depends: libatk-bridge2.0-0:amd64 (>= 2.5.3) but it is not installable
#12 277.2                               Depends: libatk1.0-0:amd64 (>= 2.2.0) but it is not installable
#12 277.2                               Depends: libatspi2.0-0:amd64 (>= 2.9.90) but it is not installable
#12 277.2                               Depends: libc6:amd64 (>= 2.16) but it is not installable
#12 277.2                               Depends: libcairo2:amd64 (>= 1.6.0) but it is not installable
#12 277.2                               Depends: libcups2:amd64 (>= 1.4.0) but it is not installable
#12 277.2                               Depends: libdbus-1-3:amd64 (>= 1.5.12) but it is not installable
#12 277.2                               Depends: libdrm2:amd64 (>= 2.4.38) but it is not installable
#12 277.2                               Depends: libexpat1:amd64 (>= 2.0.1) but it is not installable
#12 277.2                               Depends: libgbm1:amd64 (>= 8.1~0) but it is not installable
#12 277.2                               Depends: libgcc1:amd64 (>= 1:3.0) but it is not installable
#12 277.2                               Depends: libgdk-pixbuf2.0-0:amd64 (>= 2.22.0) but it is not installable
#12 277.2                               Depends: libglib2.0-0:amd64 (>= 2.39.4) but it is not installable
#12 277.2                               Depends: libgtk-3-0:amd64 (>= 3.9.10) but it is not installable
#12 277.2                               Depends: libnspr4:amd64 (>= 2:4.9-2~) but it is not installable
#12 277.2                               Depends: libnss3:amd64 (>= 2:3.22) but it is not installable
#12 277.2                               Depends: libpango-1.0-0:amd64 (>= 1.14.0) but it is not installable
#12 277.2                               Depends: libx11-6:amd64 (>= 2:1.4.99.1) but it is not installable
#12 277.2                               Depends: libxcb1:amd64 (>= 1.9.2) but it is not installable
#12 277.2                               Depends: libxcomposite1:amd64 (>= 1:0.3-1) but it is not installable
#12 277.2                               Depends: libxdamage1:amd64 (>= 1:1.1) but it is not installable
#12 277.2                               Depends: libxext6:amd64 but it is not installable
#12 277.2                               Depends: libxfixes3:amd64 but it is not installable
#12 277.2                               Depends: libxkbcommon0:amd64 (>= 0.4.1) but it is not installable
#12 277.2                               Depends: libxrandr2:amd64 but it is not installable
#12 277.2                               Depends: libxshmfence1:amd64 but it is not installable
#12 277.2                               Recommends: libu2f-udev:amd64
#12 277.2                               Recommends: libvulkan1:amd64 but it is not installable
#12 277.2 E: Unable to correct problems, you have held broken packages.

該当のソースコード

&& wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | apt-key add - \
&& wget -q https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb \
&& apt-get install -y ./google-chrome-stable_current_amd64.deb \

試したこと

・rosetta2のインストール
・該当ソースコードの下に

&& apt install gdebi -y \
&& apt install ./foobar.deb \


を記述

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • otterminalk

    2021/03/17 15:07

    違いがよくわかってないのもありますが、実務のDockerfileなのでいじらないようにローカル側でなとかしたい気持ちはあります。

    キャンセル

  • t_obara

    2021/03/17 15:10

    M1ではない環境ではうまくいっているのですか?

    キャンセル

  • otterminalk

    2021/03/17 15:12

    M1ではない環境ではうまくいっています

    キャンセル

回答 1

check解決した方法

0

dpkg --add-architecture amd64
dpkg --print-foreign-architectures

上記コマンドにてdockerのdebian環境にてamd64アーキテクチャを適用することによって依存パッケージをインストールすることができて無事コンテナを立ち上げることができました。

apt-get install -y libappindicator1
apt-get clean && apt-get update
apt-get -y upgrade

エラーが出るが、一度叩いて依存パッケージのログを取る。Dockerfileに記載する場合は一度走らせてスキップ必要。(exit 0)
dpkg -i --force-depends google-chrome-stable_current_amd64.deb

単体で叩いても何もインストールされないため、上記のコマンドの後に叩く
apt-get -y install -f
dpkg -i --force-depends google-chrome-stable_current_amd64.deb

完了

コマンドの順番とか、不要コマンドがあるかもしれませんが僕はこの環境で構築できました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る