質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

ChromebookとColabでBeautifulsoupが上手く動かない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 746

score 16

前提・実現したいこと

Beautifulsoupをインストールしたい

発生している問題・エラーメッセージ

Requirement already satisfied: gspread in /usr/local/lib/python3.6/dist-packages (3.0.1)
Requirement already satisfied: requests>=2.2.1 in /usr/local/lib/python3.6/dist-packages (from gspread) (2.23.0)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.6/dist-packages (from requests>=2.2.1->gspread) (2020.12.5)
Requirement already satisfied: chardet<4,>=3.0.2 in /usr/local/lib/python3.6/dist-packages (from requests>=2.2.1->gspread) (3.0.4)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.6/dist-packages (from requests>=2.2.1->gspread) (1.24.3)
Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python3.6/dist-packages (from requests>=2.2.1->gspread) (2.10)
Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages (2.23.0)
Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python3.6/dist-packages (from requests) (2.10)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.6/dist-packages (from requests) (2020.12.5)
Requirement already satisfied: chardet<4,>=3.0.2 in /usr/local/lib/python3.6/dist-packages (from requests) (3.0.4)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.6/dist-packages (from requests) (1.24.3)
Requirement already satisfied: bs4 in /usr/local/lib/python3.6/dist-packages (0.0.1)
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python3.6/dist-packages (from bs4) (4.6.3)
Requirement already satisfied: oauth2client in /usr/local/lib/python3.6/dist-packages (4.1.3)
Requirement already satisfied: pyasn1-modules>=0.0.5 in /usr/local/lib/python3.6/dist-packages (from oauth2client) (0.2.8)
Requirement already satisfied: rsa>=3.1.4 in /usr/local/lib/python3.6/dist-packages (from oauth2client) (4.6)
Requirement already satisfied: six>=1.6.1 in /usr/local/lib/python3.6/dist-packages (from oauth2client) (1.15.0)
Requirement already satisfied: pyasn1>=0.1.7 in /usr/local/lib/python3.6/dist-packages (from oauth2client) (0.4.8)
Requirement already satisfied: httplib2>=0.9.1 in /usr/local/lib/python3.6/dist-packages (from oauth2client) (0.17.4)
--2021-01-12 13:55:59--  https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
Resolving dl.google.com (dl.google.com)... 108.177.119.136, 108.177.119.190, 108.177.119.93, ...
Connecting to dl.google.com (dl.google.com)|108.177.119.136|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 77271596 (74M) [application/x-debian-package]
Saving to: ‘google-chrome-stable_current_amd64.deb.24’

google-chrome-stabl 100%[===================>]  73.69M   221MB/s    in 0.3s    

2021-01-12 13:56:00 (221 MB/s) - ‘google-chrome-stable_current_amd64.deb.24’ saved [77271596/77271596]

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'google-chrome-stable' instead of './google-chrome-stable_current_amd64.deb'
google-chrome-stable is already the newest version (87.0.4280.141-1).
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.
src/tcmalloc.cc:283] Attempt to free invalid pointer 0x34acae46da20 
mkdir: cannot create directory ‘/usr/local/chromedriver’: File exists
mv: cannot stat 'chromedriver': No such file or directory
chmod: cannot access '/usr/local/chromedriver/chromedriver': No such file or directory
Requirement already satisfied: selenium in /usr/local/lib/python3.6/dist-packages (3.141.0)
Requirement already satisfied: urllib3 in /usr/local/lib/python3.6/dist-packages (from selenium) (1.24.3)
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-27-dea06cef90dc> in <module>()
     31 
     32 # HTMLから必要な情報を得る為にBeautifulSoupをimport
---> 33 from bs4 import beautifulsoup
     34 # グーグルスプレッドシートを操作する為にimport
     35 import gspread

ImportError: cannot import name 'beautifulsoup'

---------------------------------------------------------------------------
NOTE: If your import is failing due to a missing package, you can
manually install dependencies using either !pip or !apt.

To view examples of installing some common dependencies, click the
"Open Examples" button below.
---------------------------------------------------------------------------

該当のソースコード

!pip install gspread
!pip install requests
!pip install bs4
#!sudo apt-get install python3-bs4
#!sudo apt-get install python3-requests
#!cat /etc/ssl/certs/ca-certificates.crt
#!sudo update-ca-certificates
!pip install oauth2client
#!pip3 list

!wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
!sudo apt install ./google-chrome-stable_current_amd64.deb
!google-chrome -version
!sudo mkdir /usr/local/chromedriver
!sudo mv chromedriver /usr/local/chromedriver
!sudo chmod ugo+x /usr/local/chromedriver/chromedriver
!pip install selenium


# ブラウザを自動操作するためseleniumをimport
from selenium import webdriver

# seleniumでヘッドレスモードを指定するためにimport
from selenium.webdriver.chrome.options import Options

# seleniumでEnterキーを送信する際に使用するのでimport
from selenium.webdriver.common.keys import Keys

# HTTPリクエストを送る為にrequestsをimport
import requests

# HTMLから必要な情報を得る為にBeautifulSoupをimport
from bs4 import beautifulsoup
# グーグルスプレッドシートを操作する為にimport
import gspread
# グーグルスプレッドシートの認証情報設定の為にimport
from oauth2client.server_account import ServiceAccountCredentials

試したこと

#!sudo apt-get install python3-bs4
#!sudo apt-get install python3-requests
#!cat /etc/ssl/certs/ca-certificates.crt
#!sudo update-ca-certificates


いろいろなサイトを見て以上のように入れて試験してみましたが解決しませんでした。

補足情報(FW/ツールのバージョンなど)

Chromebook
Googlecolab

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

ぜんぶ小文字になっているからではないでしょうか。
下記試してみてください。

!pip install gspread
!pip install requests
!pip install bs4
#!sudo apt-get install python3-bs4
#!sudo apt-get install python3-requests
#!cat /etc/ssl/certs/ca-certificates.crt
#!sudo update-ca-certificates
!pip install oauth2client
#!pip3 list

!wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
!sudo apt install ./google-chrome-stable_current_amd64.deb
!google-chrome -version
!sudo mkdir /usr/local/chromedriver
!sudo mv chromedriver /usr/local/chromedriver
!sudo chmod ugo+x /usr/local/chromedriver/chromedriver
!pip install selenium


# ブラウザを自動操作するためseleniumをimport
from selenium import webdriver

# seleniumでヘッドレスモードを指定するためにimport
from selenium.webdriver.chrome.options import Options

# seleniumでEnterキーを送信する際に使用するのでimport
from selenium.webdriver.common.keys import Keys

# HTTPリクエストを送る為にrequestsをimport
import requests

# HTMLから必要な情報を得る為にBeautifulSoupをimport
from bs4 import BeautifulSoup  # 2箇所大文字
# グーグルスプレッドシートを操作する為にimport
import gspread
# グーグルスプレッドシートの認証情報設定の為にimport
from oauth2client.service_account import ServiceAccountCredentials  # モジュール名ミス

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/01/13 09:43

    変更しましたがエラー改善しませんでした…

    キャンセル

  • 2021/01/13 09:58

    末行も誤りがあったので、それも修正したverを全文のせました。
    試してみてください。
    それでも駄目な場合は試したコードを提示してください。

    キャンセル

  • 2021/01/13 10:03

    ありがとうございました!解決しました!
    非常に助かりました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る