質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.80%

Laravel AWS EC2デプロイ時の composer install のエラー

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 644
退会済みユーザー

退会済みユーザー

前提・実現したいこと

Laravelで作成したプログラムをAWSのEC2へデプロイしようとしており、composer installを行ったところ、
下記のエラーが発生しインストールに失敗いたしました。

発生している問題・エラーメッセージ

[ec2-user@ ... ]$ composer install
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.

  Problem 1
    - tijsverkoyen/css-to-inline-styles is locked to version 2.2.3 and an update of this package was not requested.
    - tijsverkoyen/css-to-inline-styles 2.2.3 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
  Problem 2
    - phar-io/manifest is locked to version 2.0.1 and an update of this package was not requested.
    - phar-io/manifest 2.0.1 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
  Problem 3
    - phpunit/php-code-coverage is locked to version 9.2.3 and an update of this package was not requested.
    - phpunit/php-code-coverage 9.2.3 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
  Problem 4
    - phpunit/phpunit is locked to version 9.4.3 and an update of this package was not requested.
    - phpunit/phpunit 9.4.3 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
  Problem 5
    - theseer/tokenizer is locked to version 1.2.0 and an update of this package was not requested.
    - theseer/tokenizer 1.2.0 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
  Problem 6
    - tijsverkoyen/css-to-inline-styles 2.2.3 requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
    - laravel/framework v8.15.0 requires tijsverkoyen/css-to-inline-styles ^2.2.2 -> satisfiable by tijsverkoyen/css-to-inline-styles[2.2.3].
    - laravel/framework is locked to version v8.15.0 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
    - /etc/opt/remi/php74/php.ini
    - /etc/opt/remi/php74/php.d/20-bz2.ini
    - /etc/opt/remi/php74/php.d/20-calendar.ini
    - /etc/opt/remi/php74/php.d/20-ctype.ini
    - /etc/opt/remi/php74/php.d/20-curl.ini
    - /etc/opt/remi/php74/php.d/20-exif.ini
    - /etc/opt/remi/php74/php.d/20-fileinfo.ini
    - /etc/opt/remi/php74/php.d/20-ftp.ini
    - /etc/opt/remi/php74/php.d/20-gd.ini
    - /etc/opt/remi/php74/php.d/20-gettext.ini
    - /etc/opt/remi/php74/php.d/20-iconv.ini
    - /etc/opt/remi/php74/php.d/20-json.ini
    - /etc/opt/remi/php74/php.d/20-mbstring.ini
    - /etc/opt/remi/php74/php.d/20-mysqlnd.ini
    - /etc/opt/remi/php74/php.d/20-pdo.ini
    - /etc/opt/remi/php74/php.d/20-phar.ini
    - /etc/opt/remi/php74/php.d/20-sockets.ini
    - /etc/opt/remi/php74/php.d/20-sodium.ini
    - /etc/opt/remi/php74/php.d/20-sqlite3.ini
    - /etc/opt/remi/php74/php.d/20-tokenizer.ini
    - /etc/opt/remi/php74/php.d/30-mysqli.ini
    - /etc/opt/remi/php74/php.d/30-pdo_dblib.ini
    - /etc/opt/remi/php74/php.d/30-pdo_firebird.ini
    - /etc/opt/remi/php74/php.d/30-pdo_mysql.ini
    - /etc/opt/remi/php74/php.d/30-pdo_sqlite.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

試したこと

エラーメッセージに
requires ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
とあり、これに従い php-dom のインストールを実施、下記の通り正常に完了はしたのですが、composer のインストールには失敗する状況で、解決方法についてご教授頂きたく質問をさせていただきました。
当方プロクラム学習を初めたばかりの初心者で、、まだいろいろ理解が及ばない点が多いため、他に必要な情報あれば
併せてお教え頂きたくよろしくお願いいたします。

[ec2-user@ ... ]$ sudo yum install --enablerepo=remi --enablerepo=remi-php74 php-dom
読み込んだプラグイン:extras_suggestions, langpacks, priorities, update-motd
307 packages excluded due to repository priority protections
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ php-xml.x86_64 0:5.4.16-46.amzn2.0.2 を インストール
--> 依存性解決を終了しました。

依存性を解決しました

============================================================================================================================================================================================================
 Package                                      アーキテクチャー                            バージョン                                                  リポジトリー                                     容量
============================================================================================================================================================================================================
インストール中:
 php-xml                                      x86_64                                      5.4.16-46.amzn2.0.2                                         amzn2-core                                      125 k

トランザクションの要約
============================================================================================================================================================================================================
インストール  1 パッケージ

総ダウンロード容量: 125 k
インストール容量: 321 k
Is this ok [y/d/N]: y
Downloading packages:
php-xml-5.4.16-46.amzn2.0.2.x86_64.rpm                                                                                                                                               | 125 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  インストール中          : php-xml-5.4.16-46.amzn2.0.2.x86_64                                                                                                                                          1/1 
  検証中                  : php-xml-5.4.16-46.amzn2.0.2.x86_64                                                                                                                                          1/1 

インストール:
  php-xml.x86_64 0:5.4.16-46.amzn2.0.2                                                                                                                                                                      

完了しました!

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る