質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Q&A

解決済

1回答

4435閲覧

httpd-develのインストールが出来ない。

antiwararug

総合スコア35

Apache

Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

0グッド

1クリップ

投稿2020/09/16 06:52

編集2020/09/16 08:02

CentOS7.8環境にて、こちらの記事を参考にApacheのインストールを実施しています。

//epel-releaseパッケージのインストール #yum -y install epel-release //ius-releaseパッケージのインストール #yum install -y https://repo.ius.io/ius-release-el7.rpm //epelリポジトリのyum実行時のデフォルト使用無効化 #vi /etc/yum.repos.d/epel.repo - enabled = 1 + enabled = 0 //Nghttp2(HTTP/2コアエンジン)のインストール #yum --enablerepo=epel -y install nghttp2 //mime.typesのインストール #yum -y install mailcap //Brotli(ブロートリ)のインストール #yum --enablerepo=epel -y install brotli //アパッチのインストール #yum --disablerepo=base,epel,extras,updates --enablerepo=ius -y install httpd #yum -y install openldap-devel expat-devel libdb-devel //ここでdevelが依存関係によりインストール出来ない。 #yum --disablerepo=base,extras,updates --enablerepo=ius -y install httpd-devel mod_ssl Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile Including mirror: ftp.riken.jp * remi-safe: ftp.riken.jp Resolving Dependencies --> Running transaction check ---> Package httpd24u-devel.x86_64 0:2.4.43-1.el7.ius will be installed --> Processing Dependency: perl >= 5.004 for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: apr15u-util-devel >= 1.5.0 for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: apr15u-devel >= 1.5.0 for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: /usr/bin/perl for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: perl(strict) for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Running transaction check ---> Package apr15u-devel.x86_64 0:1.5.2-2.ius.el7 will be installed ---> Package apr15u-util-devel.x86_64 0:1.5.4-3.ius.el7 will be installed ---> Package httpd24u-devel.x86_64 0:2.4.43-1.el7.ius will be installed --> Processing Dependency: perl >= 5.004 for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: /usr/bin/perl for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: perl(strict) for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Processing Dependency: /usr/bin/perl for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 --> Finished Dependency Resolution Error: Package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 (ius) Requires: /usr/bin/perl Error: Package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 (ius) Requires: perl >= 5.004 Error: Package: httpd24u-devel-2.4.43-1.el7.ius.x86_64 (ius) Requires: perl(strict) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest *** Packages skipped because of dependency problems: apr15u-devel-1.5.2-2.ius.el7.x86_64 from ius apr15u-util-devel-1.5.4-3.ius.el7.x86_64 from ius httpd24u-devel-2.4.43-1.el7.ius.x86_64 from ius

原因、対処方法をご教示いただけますでしょうか。よろしくお願いいたします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

yukky1201

2020/09/16 07:49

コマンド実行した際に、記載の4行しかメッセージが表示されてないでしょうか。依存関係の失敗の場合もっと出ているはずなのですが。
over

2020/09/16 07:49

エラー内容に「Requires」がでています。要求されているパッケージをインストールすればよいと思います。
guest

回答1

0

ベストアンサー

--> Processing Dependency: perl >= 5.004 for package: httpd24u-devel-2.4.43-1.el7.ius.x86_64

依存関係で、perlを要求されています。

perlはbaseリポジトリにあるはずですが、iusリポジトリからhttpdインストールするためにdisableしているのが原因だと思います。

perlのみインストール(yum install perl)してから、http-develのインストールを実行してみてください。

投稿2020/09/16 08:08

yukky1201

総合スコア2751

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

antiwararug

2020/09/16 08:40

ご回答いただきありがとうございます。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問